Export failed - Find solutions

Your export failed for one or more reasons. There is always a reason why it failed. Below are the posts by others describing their faults and solutions. This tutorial is not a definite tutorial as you may have a unique situation not described in here.

Time Code

After failure to export it may display a time code, make a note of the time displayed and look on your timeline to see what’s there that could be causing the problem. It could be a clip, audio or video file, transition.
firefox_2020-10-04_08-29-15

Export Job Log

The major source you’re going to look at is the Export job log. When the job failed it will be in the job’s window. At times it may be requested to share “View XML” as well. Right click on the job then View Log.
2020-10-07_21-51-56
To share with this forum save the Job Log by clicking Save, and name the file. Then you can drag/drop the file into the forum or upload by the Upload icon. firefox_2020-10-07_22-00-52
shotcut_2020-10-07_21-54-40

You may not know what to look for, but look at the bottom of the log for clues to what is going on. There may be Exit codes at the bottom of the report.

You can always search the forum with that exit code to find a solution, or suggestions to how to resolve the export failure.

I compiled a list of posts with problems, suggestions, and some solutions. I only went back a few years and even few issues have been resolved with the latest release of Shotcut. Click the arrows the expand the list for each code.

Antivirus

:eye: If you’re using an anti-virus/malware set the program to approve melt.exe and ffmpeg.exe.


Failed with exit code -1073741819
  • 06-28-20 Post: I can't export my video. When I try to, it just stop
    Information offered: Export job log, system specifications, 32 Bit
    Suggestion posted: Could be a filter.
    Solved by OP: Applied a Filter: Glow to a transition.

  • 05-29-20 Post: Failure when exporting a video
    Information offered: Export job log.
    OP posted: Fixed it by removing blur effect from image.
    shotcut: Do recall which blur filter exactly and whether it was using keyframes?
    Op posted: Blur Box, no keyframes.

  • 05-23-20 Post: Video Exporting Fail
    Information offered: Export job log, system specifications, Shotcut version, Stabilize filter usage
    Suggestion posted for Stabilize filer: Video Exporting Fail - #5 by Toopavix
    OP: Removed Stabilize filter on clips

  • 05-14-20 Post: Whats is wrong and how to fix ... export dail
    Information offered: Export job log.
    OP solution: Copied from Timeline to Source.

  • 12-28-18 Post: Failed to export (1073741819) please fix
    Information offered: Project MLT file.
    Suggestion posted: Turn off Hardware Encoder, turn off Parallel Processing, read the export job log.
    OP responded that the suggestions didn’t work.
    OP later responded they changed various settings in Advanced and the export did not fail.

Not Solved

  • 8-30-20 Post: Confused on why My video Is failing
    Information offered: Export job log, parallel processing not available.
    Suggestion posted: “You are running the 32-bit version and running out of memory. 32-bit is very limited. You can only make simple HD 720p or less with it.”
    No response from OP.

  • 8-24-20 Post: Exporting failed with exit code -1073741819
    Information offered: Export job log.

  • 8-10-20 Post: Cannot export: error
    Information offered: Export job log.
    Suggestion posted: You are probably running out of memory.
    Close Shotcut
    Close as many other apps as possible
    Start Shotcut
    Open project
    Export
    No response from OP.

  • 07-13-20 Post: Error rendering video - Please help I have a youtube channel
    Information offered: Export job log, Video mode setting, Sped up clips, computer specs.
    Suggestions offered: Corrupted audio on the source file. Might be using an older version of shotcut. Upgrade to latest version of Shotcut.
    OP responded saying they suspect it was because they sped up the clip. Exported fine in a different project.
    No further update from OP.

  • 06-28-20 Post: I can't export my video. When I try to, it just stop
    Information offered: Export job log, system specifications

  • 06-18-20 Post: Export failure?
    Information offered: Screenshot of export settings, and export job log.
    Suggestion posted: “You are probably running out of memory. Reboot, immediately start Shotcut and nothing else, and try export again.”
    No response from OP.

  • 06-11-20 Post: Exiting With Error Code -1073741819
    Information offered: Export job log, export settings, hardware encoder off, lossless h.264 preset.
    Suggestion posted: Add a blank video track.
    Unclear if OP tried the blank video track that was suggested.
    Suggestion posted: Try with another lossless preset or h.264 high.
    No response from OP.

  • 05-26-20 Post: Exporting crashing at different percentages
    Information offered: Export job log.
    3 Suggestions posted: Read post.
    No response from OP.

  • 05-09-20 Post: Failed on export video
    Information offered: No Parallel processing, exit code 1073741819.
    Suggestion posted: “Then you are using 32-bit and running out of memory. You need to simplify your project or use 64-bit.”
    No response from OP.

  • 04-26-20 Post: Failed to export file
    Information offered: Export job log, XML log.
    Suggestion posted: Running the 32-bit version could be running out of memory.
    OP confirmed they are using 32-bit Windows.
    shotcut: Gave example of what might cause the issue with memory and suggested lower resolution.
    OP said they will try everything suggested and upgrading to 64 bit.
    No update from OP.

  • 03-25-20 Post: Code 1073741819 NEED FIX
    Information offered: Filters used, export job log.

  • 03-07-20 Post: Trying to export video keeps failing with -1073741819
    Information offered: Export job log.
    Suggestion posted: “When the export job fails, it displays a time code. You can visit that time on the timeline and look for something around it that might be special or advanced and temporarily disable it to see if the problem goes away.”
    No response from OP.

  • 12-23-19 Post: Export failure log
    Information offered: Export job log, computer specifications.
    Suggestion posted: Possible running on 32-bit, running out of memory. Look at qmelt.exe process to see if goes over 2GB. When job fails is will give a time code in the job panel.
    No response from OP if issue has been resolved.

  • 07-17-19 Post: Export crash with Stabilize filter (v190715)
    Information offered: Computer specifications, Export settings, Export job log, Stabilize filter used.
    Suggestion posted: Use Analyze with Stabilize
    OP: I only have one filter (Stabilize) and I tried also performing Analyze before exporting, but it crashes consistently.
    shotcut: Is this an issue specific to the combination of this one clip and Stabilize? Does it work for you with other clips?
    No response from OP.

  • 07-17-19 Post: 50fps Export Issue
    Information offered: Export job log.
    Suggestion posted: Try without hardware encoding.
    No response from OP.

  • 06-28-19 Post: Export process failed
    Information offered: Partial export job log.
    Suggestions posted: Windows 10 fix, Wave Filter bug
    No response from OP.

  • 05-19-19 Post: Crashing for "Missing Key Frame"
    Information offered: Export job log, Export settings used. Tried removing 1 clip.
    Suggestion posted: Re-add the clip.
    No response from OP.

  • 01-11-19 Post: Failed to Export to mpeg at around 22%
    Information offered: Partial Export job log. Project & Export settings. Windows 8 with 4gb Ram.
    Suggestion posted: “Try without changing ANY export settings and see if it works. If not then only turn OFF Parallel processing and try again. If it still fails it reports a time code of the failure on the job status. Look immediately after that spot on the timeline for something that may be causing the problem.”
    OP responded: Tried default settings, didn’t work. Starting project over.

  • 01-01-19 Post: Stabilize analysis always fails around ~90%
    Information offered: Partial export job log.
    Suggestion posted: User permission to write to c:/
    OP responded: Has all admin rights, “Ran as Administrator” get the same error.
    Suggestion posted: Convert the clip to edit-friendly. Offered to debug the source file.
    No response from OP.

  • 01-08-18 Post: Can't export! GET Exit code error
    Information offered: exit code -1073741819
    Suggestions posted: Asked for more information, and to turn off GPU processing and display method to Automatic.
    No response from original OP.

Exit Code 1

Exit Code 1

  • 09-24-21 Post: Help! export failed
    Information offered: Export job log, AVG Anti-Virus is blocking melt.exe
    Suggestion posted: Whitelist files blocked by anti-virus program.
    Solution: OP took files used by Shotcut out of anti-virus quarantine.

  • 12-25-20 Post: The dreaded export issue
    Solution offered: In a reply, set AVG Anti-Virus approval of melt.exe. Log not offered.

  • 10-29-19 Post: Can't Export - failed message
    Information offered: Export job log
    Suggestion posted: Check permission of the folder “Videos” is writable. Try a different name or folder.
    OP responds: Selected the correct MP4 file. “The correct one works fine - so, once again, MANY thanks for your support.”

  • 09-25-20 Post: Export fails with "[consumer avformat] Could not open"
    Information offered: Export job log, export setting attempts.
    Suggestion posted: Move the folder to a different drive/folder.
    OP posted solution: https://support.microsoft.com/en-us/help/4046851/windows-10-allow-blocked-app-windows-security

  • 09-15-20 Post: Export failure (could not open output file) in version 20.09.13
    Information offered: OS, Shotcut version, Export job log.
    Suggestion posted: Can’t open export file.
    OP posted they installed the previous version and it solved the problem.

  • 07-13-20 Post: Cannot export mp4 anymore - #3 by Hudson555x
    Information offered: Export job log.
    Suggestions posted: Restart computer, try a different folder. Is the folder a part of a cloud drive system?
    Op responded: No cloud drive system, no back up mechanism.
    OP solved it by putting the MLT file on the desktop, and exported the file.

  • 07-11-20 Post: Can't export a video with new Shortcut version
    Information offered: Export job log, Windows (x64), Shotcut version 64-bit
    Solved by OP: Anti-malware was blocking Qmelt.exe.

  • 04-14-19 Post: Error at 17% exporting mp4 file
    Information offered: Export job log, Windows 10
    Suggestion posted: Running out disk space.
    OP responds 55gb where attempting to save file. Tried smaller projects with same result.
    OP solution: Converted partition from Fat32 to NTFS. Exported without a problem.

  • 01-19-19 Post: Export MPEG-2 failed at 0%
    Information offered: Export job log
    Suggestion posted: Used invalid combination of Format & Codecs.
    OP responded: They entered Advanced and changed export format.
    Suggestion posted: Cannot put H.264 video into a mpeg2video format file.

Exit Code 3

Exit Code 3

  • 08-25-20 Post: Export problems. Failed with exit code 3
    Information offered: Export job log.
    Suggestion posted: “Probably out of memory (or not enough for a big block of memory). You can try to reboot and immediate start Shotcut and export project before opening other applications.”
    OP responds: “Thx for help!”

  • 08-17-20 Post: Failed to EXPORT file in Shotcut
    Information offered: Export job log.
    Suggestion posted: “This often occurs because you are running out of memory.”
    OP: “It is not memory.”
    shotcut: “This happens sometimes because the background export program can fail while cleaning up itself, and that is a harmless failure. If you want to further test the export result, open it in Shotcut and choose Properties > menu > Start Integrity Check Job. Then, observe the Jobs panel.”
    No response from OP.

  • 06-07-20 Post: Shotcut using 20GB of RAM then failing
    Information offered: Export job log, computer specifications, OS, “latest version” of Shotcut.
    Suggestion posted: Log indicates problem with converting audio samples at 32x speed. Use less speed, disable pitch compensation.
    No update from OP.

  • 02-15-20 Post: Export of Video ... Failed with exit code 3
    Information offered: Export job log, OS, Shotcut version.
    Suggestion posted: Background export program crashed, possibly because of HTML-based filter including some where it is not obvious such as Swirl, Crop: Rectangle, Crop: Circle, or Text: 3D.
    No response from OP.

  • 04-13-20 Post: HELP : Export failed with exit code 3
    Information offered: Export job log.
    Suggestion posted: “When it fails, it reports a time code for that job in the jobs panel. Go to that position in the timeline and see if you can find something to simplify. You can try to export certain portions, by using Timeline > menu > Copy Timeline to Source, mark In and Out points in the Source player, and Export.”
    Possible reason by @Elusien: lack of memory. Elusien offered and exported the video for OP, and did this to help from crashing: “At one time I had to minimize Shotcut itself to give the “qmellt.exe” process a bit more memory to play with.” (Project Files = 10GB) HELP : Export failed with exit code 3 - #21 by ysalo1

Exit Code 11

Exit Code 11

  • 07-22-20 Post: Shotcut 20.07.11 Linux rendering "failed to load producer"
    Information offered: Partial Export jog log, Linux 18.3, Shotcut version, proper rights to source file.
    Suggestion posted: Works with Ubuntu 20.04 with AppImage or snap. Works with Mint 19 and Ubuntu 16.10 VMs. Current version not compatible with Mint 18.

  • 07-29-18 Post: Crash during exporting video
    Information offered: Export job log, XML export file.
    Solution from OP: Removed V2 where a JPG image was.

If you can’t find a solution that works for you, fill out a new Help/How to post and describe what’s going on.

Note: If there are more relevant export fail posts to add I can certainly edit this tutorial to include them.

Insufficient Memory

A common cause of an export failure is running out of system memory. While an export is in process, use the task manager (system monitor, etc) to observe the memory utilization. If the memory is exhausted, the export may fail. See How to Reduce Memory Usage

8 Likes

the export still failed1 i dont know what to do.

Hello, this is the problem I have, can you help me please? I can’t export my video :frowning:

plugin_mgr_get_object_file_plugins: error opening shared object file ‘C:\Program Files (x86)\Shotcut\lib\ladspa/FFTW_docs/COPYING’: “C:\Program Files (x86)\Shotcut\lib\ladspa\FFTW_docs\COPYING”: No se puede encontrar el m�dulo especificado.
plugin_mgr_get_object_file_plugins: error opening shared object file ‘C:\Program Files (x86)\Shotcut\lib\ladspa/FFTW_docs/COPYRIGHT’: “C:\Program Files (x86)\Shotcut\lib\ladspa\FFTW_docs\COPYRIGHT”: No se puede encontrar el m�dulo especificado.
plugin_mgr_get_object_file_plugins: error opening shared object file ‘C:\Program Files (x86)\Shotcut\lib\ladspa/FFTW_docs/NEWS’: “C:\Program Files (x86)\Shotcut\lib\ladspa\FFTW_docs\NEWS”: No se puede encontrar el m�dulo especificado.
plugin_mgr_get_object_file_plugins: error opening shared object file ‘C:\Program Files (x86)\Shotcut\lib\ladspa/FFTW_docs/README’: “C:\Program Files (x86)\Shotcut\lib\ladspa\FFTW_docs\README”: No se puede encontrar el m�dulo especificado.
plugin_mgr_get_object_file_plugins: error opening shared object file ‘C:\Program Files (x86)\Shotcut\lib\ladspa/FFTW_docs/README-bench’: “C:\Program Files (x86)\Shotcut\lib\ladspa\FFTW_docs\README-bench”: No se puede encontrar el m�dulo especificado.
plugin_mgr_get_object_file_plugins: error opening shared object file ‘C:\Program Files (x86)\Shotcut\lib\ladspa/FFTW_docs/README-WINDOWS’: “C:\Program Files (x86)\Shotcut\lib\ladspa\FFTW_docs\README-WINDOWS”: No se puede encontrar el m�dulo especificado.
plugin_mgr_get_object_file_plugins: error opening shared object file ‘C:\Program Files (x86)\Shotcut\lib\ladspa/imp_1199.dll’: “C:\Program Files (x86)\Shotcut\lib\ladspa\imp_1199.dll”: No se puede encontrar el m�dulo especificado.
plugin_mgr_get_object_file_plugins: error opening shared object file ‘C:\Program Files (x86)\Shotcut\lib\ladspa/mbeq_1197.dll’: “C:\Program Files (x86)\Shotcut\lib\ladspa\mbeq_1197.dll”: No se puede encontrar el m�dulo especificado.
plugin_mgr_get_object_file_plugins: error opening shared object file ‘C:\Program Files (x86)\Shotcut\lib\ladspa/pitch_scale_1193.dll’: “C:\Program Files (x86)\Shotcut\lib\ladspa\pitch_scale_1193.dll”: No se puede encontrar el m�dulo especificado.
plugin_mgr_get_object_file_plugins: error opening shared object file ‘C:\Program Files (x86)\Shotcut\lib\ladspa/pitch_scale_1194.dll’: “C:\Program Files (x86)\Shotcut\lib\ladspa\pitch_scale_1194.dll”: No se puede encontrar el m�dulo especificado.
plugin_mgr_get_object_file_plugins: error opening shared object file ‘C:\Program Files (x86)\Shotcut\lib\ladspa/readme_LADSPA_plugins-win.txt’: “C:\Program Files (x86)\Shotcut\lib\ladspa\readme_LADSPA_plugins-win.txt”:
plugin_mgr_get_object_file_plugins: error opening shared object file ‘C:\Program Files (x86)\Shotcut\lib\ladspa/unins000.dat’: “C:\Program Files (x86)\Shotcut\lib\ladspa\unins000.dat”:
[h264 @ 0bcf3dc0] Reinit context to 1920x1088, pix_fmt: yuv420p
[h264 @ 14ee8880] Reinit context to 1920x1088, pix_fmt: yuv420p
[h264 @ 14f817c0] Reinit context to 1920x1088, pix_fmt: yuv420p
[producer avformat] audio: total_streams 1 max_stream 1 total_channels 2 max_channels 2
[AVIOContext @ 05707040] Statistics: 247834 bytes read, 2 seeks
[AVIOContext @ 05707240] Statistics: 247834 bytes read, 2 seeks
[AVIOContext @ 05707480] Statistics: 247834 bytes read, 2 seeks
[libx264 @ 1513a540] using SAR=1/1
[libx264 @ 1513a540] using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2 AVX FMA3 BMI2 AVX2
[libx264 @ 1513a540] profile High, level 3.1, 4:2:0, 8-bit
[libx264 @ 1513a540] 264 - core 159 r2999 296494a - H.264/MPEG-4 AVC codec - Copyleft 2003-2020 - http://www.videolan.org/x264.html - options: cabac=1 ref=2 deblock=1:0:0 analyse=0x3:0x113 me=hex subme=6 psy=1 psy_rd=1.00:0.00 mixed_ref=1 me_range=16 chroma_me=1 trellis=1 8x8dct=1 cqm=0 deadzone=21,11 fast_pskip=1 chroma_qp_offset=-2 threads=12 lookahead_threads=2 sliced_threads=0 nr=0 decimate=1 interlaced=0 bluray_compat=0 constrained_intra=0 bframes=3 b_pyramid=2 b_adapt=1 b_bias=0 direct=1 weightb=1 open_gop=0 weightp=1 keyint=125 keyint_min=12 scenecut=40 intra_refresh=0 rc_lookahead=30 rc=crf mbtree=1 crf=23.0 qcomp=0.60 qpmin=0 qpmax=69 qpstep=4 ip_ratio=1.40 aq=1:1.00
[mp3 @ 14f5b680] Skipping 0 bytes of junk at 143146.
[mp3 @ 28ce52c0] Skipping 0 bytes of junk at 143146.
[mp3 @ 5bbaf680] Skipping 0 bytes of junk at 143146.
[producer avformat] audio: total_streams 1 max_stream 0 total_channels 2 max_channels 2
[AVIOContext @ 05707040] Statistics: 262144 bytes read, 0 seeks
[producer avformat-novalidate] D:/music/Fairy Tail S3 - OP4 MORE THAN LiKE.mp3
checking VFR: pkt.duration 0
[producer avformat-novalidate] D:/music/Fairy Tail S3 - OP4 MORE THAN LiKE.mp3
checking VFR: pkt.duration 1
[mp4 @ 15462040] Using AVStream.codec to pass codec parameters to muxers is deprecated, use AVStream.codecpar instead.
[mp4 @ 15462040] Using AVStream.codec to pass codec parameters to muxers is deprecated, use AVStream.codecpar instead.
Failed with exit code -1073741819
Failed with exit code -1073741819

1 Like

You will need to provide more information.

What are your computer specs?

Are you running out of RAM?

How far does the export get before the failure occurs (what percent)?

1 Like

I have the same problem and it happens to me at 72% done, I went to that stage in the timeline, 72% of the video and altered it. I also restarted my computer.

1 Like

Hudson, this is a wonderful compilation - many thanks for the hard work that went into this!

1 Like

i get a timecode error. how do you fix it? i dont see a solution

the same thing happens to me. shotcut uses all my memory and disk

and disk

Get or use a bigger disk; video editing is demanding.

thank you sm

Just wanted to share how I resolved a consistent Export failure with exit code 1073741819. After upgrading from Release 20.10.31 to Release 21.12.24, I got the error with every export. Even with the simplest video and with any of the Export presets I tried, trying various output formats (codecs in the h264_x or libx264 realm), always got the error.

Fixed it with a clean re-install of Shotcut:

  • Un-installed the old one (using Windows Settings, Apps)
  • Deleted EVERYTHING from the Shotcut appdata folder. For me it was in C:\Users\ user-id\AppData\Local\Meltytech\Shotcut but may be in a different place on your system
    — Note: this will wipe out your custom presets if you saved any, history, and probably other personalized settings. I had some presets and had to re-create after.
  • Installed the new release. During install, made sure the “Remove Shotcut Settings from Registry” was checked on.

When upgrading the first time, I did not clean out the Shotcut folder or registry, and had the problem. After a clean re-install, export is working again.

It’s not unreasonable to guess there was some setting left over that was incompatible. I have no idea which setting(s) it might have been, but the clean re-install definitely fixed it for me. Hope this is helpful, if you’ve migrated from a previous release.

Thank you, Hudson, for taking the time to write this post. Extremely helpful!

On Windows if a shotcut.exe or melt.exe process is running, possibly hidden in the background, then it locks files that it is using such as DLLs that prevents them from being upgraded. But usually the installer warns you about that.

I am trying to export a 3 minute long video. I tried to export it multiple times but it failed. The timestamp it gave me was right where an audio clip that I had sped up a bit started. It’s pretty important that this clip is sped up in my video. I have narrowed it down and that one clip seems to be the only thing that is the problem. I’ve tried slowing it down closer to its normal pace, and right now it’s only at 1.2 speed, but it’s still failing to export. What am I doing wrong? Is this a glitch?

Remove the audio clip completely temporarily just to test export without it and verify that is the source of the problem. Temporarily = do not save project. Export uses the state of the timeline in memory - not saved. If that audio clip is the problem, then select it and use Properties > Convert on it (or another tool to convert to WAV).

I tried taking that single clip and putting it into a new project, but that also immediately fails to export. Is my computer just being a butthole? Could be.

I don’t see a “convert” option anywhere when I click properties.