Is Shotcut broken now?

Thanks for your reply!

None of the Norton processes seem to use any more memory or CPU resources when Shortcut is running. The only program specific white-lists I can find only relate to communication firewall rules, not anything to do with the anti-virus or just running the program. Norton does accept Shortcut’s install program as a “trusted application” based on automatic customer feedback.

I looked at the Windows compatibility settings for Shortcut, but there was nothing there that looked reasonable to try. I sure don’t want it, or anything, to ever run in Windows 8 compatibility mode!

This evening, I was able to process a small file with Shortcut just fine - but like I’ve been seeing it totally bogged down and the UI pretty much stopped responding once I loaded a 5GB input file.

All of my 4 hard drives are formatted with NTFS, using different allocation unit sizes depending on their total size and what’s on them. I just replaced one of the 8TB drives (the one where most of my videos are stored) with a new one, because the old one had been spinning for over 30,000 hours and its brother drive failed a couple of months ago. I formatted the new drive with a 256kb allocation unit, while my other 8TB drive was formatted with a 128kb unit size. I copied one of the input files from the one with the big allocation unit to the smaller one, to see if Shortcut worked better with it on that drive. Well, not really - it still ran through the steps I did on the UI like a stuck pig, much slower between mouse clicks than I would normally expect - so no conclusive differences there.

I may try to download another free, open source video editor to see if it can process the same input files better than Shortcut is currently able to do. Problem is that when I was looking around and found Shortcut several years ago, most of the other ones sucked by comparison. I’ll look around again but If I’m desperate I may try the bloatware one that Microsoft shipped with Windows 11, ClipChamp, which I deleted but wouldn’t expect too much from…

I’ll keep this thread posted, and again thanks for your help!

I tried installing an older version of Shortcut, 22.06.23 just to see if it would behave any differently with the UI hangs, but it did not. As soon as I tried to load a 15GB input file, the UI totally hung and never completed that action. I saw its memory use as reported by the Windows task manager jump to over 21GB - making the total system memory in use go up from about 23% to 97%.

So I know I was probably running version 22.06.23 successfully under Windows 10 for quite a while, so this again focuses attention on what could have changed to impact its performance in the Windows 11 environment. Not clear what could be the direct cause, since every other application I had running before the Windows 11 upgrade is still working and performing normally.

I re-installed Shortcut’s latest 22.10.25 version and will continue to try to understand what’s going on with under Windows 11.

Well, sometimes that does happen when running an upgrade, as opposed to a clean install (which I understand is impractical as a first port of call, and that can even be the same in a Linux environment when upgrading).

A couple more options. Try creating a new user profile, only install Shotcut on that and test your 5GB file locally and see what happens.

I don’t work with WIndows much anymore these days since my tech days are over, but take a look at your page file settings also (since your RAM gets gobbled up rather quickly from what I read). Maybe try System managed instead of automatic, and then if that doesn’t work go with a custom size. I doubt this will help but it’s an easy and quick change. I’d test all this on the new profile.

Good luck mate.

Thanks for your thoughts!

I reconfigured my page files (swap space) after the upgrade to Windows 11, because it got changed to just use my OS SSD when Windows 11 was installed. (I wasn’t really happy with that, because I didn’t want to wear out my SSD with all the paging, that could just as well be being done on all the hard drives I have). I did this after observing the Shortcut UI problems, which behave the same way both before and after any reconfiguration of the system’s paging space.

So now I have page files (system managed size - generally about 5GB each) on all four of my hard drives, which is better because it distributes the load across more devices - just as we learned decades ago on old mainframe computer systems. I have no indication that this isn’t working well - as pretty much everything else and the system itself are running great, with excellent performance and responsiveness except for Shortcut.

When Shortcut’s UI drops into its super, super slow mode (pretty much always after loading an input file bigger than a hundred or so megabytes), the working set size gets larger that expected - noticeably larger than the total size of the input video (like 21GB if a 15GB file is loaded). Still smaller than my main memory size (32GB) though, so most of it shouldn’t be being dumped into paging files.

The fact that the Shortcut UI gets so super slow and hangs so much may be related to how work is being assigned across the threads that Shortcut is using? There are plenty of CPU cycles to do everything that Shortcut should be doing just fine - but the UI runs like a lead brick when ever a moderate sized input file is loaded. (Even before any jobs are running either). Generally, lots of heavy duty work shouldn’t be being done in the same thread that is running the UI - but from these symptoms, it seems like that may not be being followed?

Why the heck the transition from Windows 10 to 11 should have anything to do with this is another question that I’m still puzzling over. …

Shotcut! Shotcut! Shotcut!

So you tried a new profile?

Thanks for your reply! If by profile you mean a different preset in Shortcut, yeah I’ve tried a few different ones but have seen no difference in the UI hanging using any of them.

I did not try setting up a new userid in Windows (as my understanding is that each requires its own “Microsoft account” under Windows 11, which I’d rather not fight with). I can’t imagine how that would behave any differently anyway, especially since every service my system provides now (everything from FTP, web, media, and home security camera hub) are all run from perfectly from my main userid - while I’m off playing demanding AAA game titles to boot.

I just tried loading a relatively small 444MB input MP4 file and watched the UI instantly hang and the Shortcut process going nuts grabbing system memory. (The performance monitor graph It was climbing at about a 30 degree angle and was just passing 7GB (and still climbing) when I killed the process from the task manager. Instantly the system memory use dropped back to a total of about 9GB total for all the other running processes. I/O activity on the hard disks where the system’s paging files are located only hit 1% on one of the four drives the whole time.

Most of the input files I normally process were created as 1920x1080 screen grabs using OBS studio. These files are relatively efficient in their size (not huge) while providing excellent resolution, color depth, and smoothness (usually about 30fps).

I’m wondering what would cause Shortcut to want to consume so much memory, that quickly - even before any output job had been started? (No old jobs were restarted in the background either from what I can tell). From the totally frozen behavior of the Shortcut UI, it seems likely that what ever was consuming the memory was being done from its thread within Shortcut. The system’s CPU metrics never showed more than about a 20% load and any other application I accessed from the desktop continued to run perfectly, with no hangs or unexpected delays, the whole time Shortcut was locked up.

So the more I look at this, the more puzzled I am about what the heck is going on. It never did this while I was running Windows 10, even though I processed some much, much larger input file with no sweat - and it certinally should have under Windows 10 if it was consuming system memory like this is now. I guess I need to try to find another open source video editor to try, just to compare the measurable performance for comparison. (I don’t trust the bloatware one Microsoft stuck a “free trial” for in Windows 11, that’s for sure)!

O.K., I just downloaded, installed, and tried to use the OpenShot video editor for a comparative sample. I then combined 4 separate input video files (1920x1080 at 30fps, about 150MB in size each) into a single file rendered at the same resolution at 50fps. The whole process ran smoothly to completion using about 30% CPU (across all cores and virtual threads I guess) and consuming about 1.1GB of system memory the whole time. (No detectable paging activity seen at all). The output file was just over 2GB in size, probably because of the higher fps being output. The memory consumption was more in line with what I would expect, and have historically observed, Shortcut to be doing.

The OpenShot “simple” UI is just that, pretty simple. I had a hard time figuring out how to trim the input files as I merged them together, never finding any good way to move up and down the output timeline very well. As the output was processing, I spent some time reading the online user’s guide which explained that they expected individual input files to be split in the project workspace, rather than being edited once they had been added to the output timeline - which wasn’t what I was expecting…

So I’m still baffled about why the Shortcut UI is going into the weeds on me right now, to be sure!

Hello there,
I’m experiencing the same UI hang issues.
In my particular case looks like it started when Win10 upgraded its .NET Framework. Tried uninstalling it, but it seems not possible.
The only way to get a decent responsiveness is running Shotcut as administrator, but by doing so I can’t drag any files in the timeline anymore.

FYI, I do the same - I edit these in Shotcut under Windows 10 and Windows 11 and have no problem whatsoever with memory.

Since you have this problem with different versions of Shotcut it has to be a Windows 11 problem. I don’t suppose you’d consider doing a PC Reset (under SystemRestore?

Thanks for your reply! While I agree with you that whatever is going on seems related to my system being migrated to Windows 11, I’m not dead sure that I may not have been seeing it with recent versions of Shortcut on Windows 10 either - but I may not have used it much for the past few weeks and just don’t remember!

As far as resetting the system and trying again, I have a lot of stuff that it took a long time to figure out and configure on Windows 10 that (to my amazement) still worked perfectly after Windows Update automatically transitioned me to Windows 11, that I don’t want to risk screwing up.

If “Windows 11” is the problem somehow, it is still a mystery as to why the hundreds of other programs on my system still work perfectly on it - even at the same time that Shortcut’s UI is frozen and it’s falling into a black hole. Nothing wrong with the hardware, that’s for sure - it’s running as well as it ever did…

I’m wondering if this could be related to the CODECs that Shortcut may be using, and if it’s getting any of those directly from the Windows operating system environment itself? I only have a fuzzy notion of what a CODEC is, and little understanding of how and when they are used, but I’ll poke around and see if I can figure out where Shortcut is picking up those that it is using. Still, a lot to be explained here!

I doubt that this is the problem. Shotcut doesn’t use CODECs itself. It uses ffmpeg to do the COmpression and DECompression. So I can’t see how this would affect the UI itself when you are using it.

Uhm, no. A new User profile or account on Windows. Sorry if that wasn’t clear.

Use the offline method.

Start → type cmd, and then click on Run as administrator.
net user “UserName” /add

That will create a new local account without a password. Less invasive than a reset and is usually what I’ve done for debugging some issues in the past before having to get out a bigger hammer. In this case it is unlikely to solve your issue, but it’s up to you.

Thanks, but I agree - I can’t really think of any reason why a different userid should make any difference with this issue…

I did try another performance test with a different video editor, DiVinci Resolve. I set it up to merge the four input files I had tested with before into one output clip at 1920x1080 after I had trimmed them. It used more memory than OneShot did, (but much less than Shortcut was consuming before I killed it) about 4.5GB but the rest of the system still had plenty (17GB or so) and it and everything else ran without any observable performance problems at all.

If I forced DiVinci to re-render everything in the same output resolution (but as I found out later a lower fps value, half what the input files were), it consumed all the CPU resources it could get (across all cores and threads). If I used its unexpected option to “not re-render the input clips if it didn’t have to” it did the same job using only about 15% of the CPU resources, in about the same amount of time (just over 15 minutes for a 21 minute long output file, as opposed to the nearly hour time that OpenShot took). The memory usage was the same, no matter which of these options I used.

With Shortcut it didn’t make any difference (other than the reported CPU utilization) if I had it use a hardware or software encoder, as far as the UI freezing and the memory usage going through the roof. These issues always were happening instantly when the input files were being imported to the project, long before any editing was done or any export jobs were ever started.

So this once again shows that there is no particular reason that my system’s hardware and underlying OS software stack shouldn’t be able to process these input files without going into a loop consuming memory and subsequently freezing the video editor’s UI. I wish there was a way to turn on a timestamped debug log in Shortcut, with enough detail to show exactly what it thinks it’s doing at different times as the roof caves in.

Not sure what to try next, other than to wait for the next update of Shortcut and hope it mysteriously solves this problem. I can’t think of any compatibility issues between Shortcut and anything else I’ve got installed or running that could account for this. I have no evidence that there’s anything “wrong” with my system, as Shortcut is the only application that’s not behaving perfectly as expected.

I figured out my problem! It was almost by accident that I found it and unfortunately it will probably not be the solution for everyone. It was simply my OneDrive transferring video/photo files to to my computer in the background!!!

I’m still learning how OneDrive works in conjunction with my PC’s hard drive; confusing w/the whole desktop thing in OneDrive… anyhow. But I do have a slight grasp on it. Here’s the problem and solution.

Problem: I decided to free up space on my PC by deleting video and picture folders with HUGE amounts of data in them from my PC’s HD (after backing them up to my external HD). What I didn’t know was that my OneDrive would automatically redownload them back to my HD! I kept doing this over and over not knowing why after a couple of days the folders would one by one show back up on my HD. At first I thought I was crazy but finally confirmed it was happening when I matched the folders w/the ones I had already backed up on my external HD.

Solution: I manually selected which folders I wanted to “mirror” from OneDrive against my PC and deselected the huge photo/video folders.

Shotcut is now working as it should. With that said, I’d like to thank everyone on here that has taken the time to help. I also want to apologize for my tone and for accusing “Shotcut” when I was frustrated at the beginning of this mess. I was at a loss and at wits end. Despite my tone, possible solutions were offered up promptly and w/out the usual snarkiness found on typical forums. I hope my solution will be able to help others experiencing the same issue. Again, thanks to all for your time and support.

In Google Drive there is an option to Stream files instead of Mirroring them.

Maybe there is a similar option in OneDrive?

I am having exactly the same issue, though mine freezes before Windows ultimately shuts it down. I am running the latest version ( which I installed in an attempt to resolve this. Have been a user since 2021 and have never experienced this. Event Viewer shows:

  • Faulting application name: shotcut.exe, version:, time stamp: 0x63581bf9
  • Faulting module name: libmltplus.dll, version:, time stamp: 0x63581a6d
  • Exception code: 0xc0000005
  • Fault offset: 0x000000000001bbf5
  • Faulting process id: 0x2828
  • Faulting application start time: 0x01d8fec588753894
  • Faulting application path: C:\Program Files\Shotcut\shotcut.exe
  • Faulting module path: C:\Program Files\Shotcut\lib\mlt\libmltplus.dll
  • Report Id: 689fc8c8-472d-4d03-ad5e-29eb61294521
  • Faulting package full name:
  • Faulting package-relative application ID:

Any help resolving this would be appreciated. I have gone through all the tips provided in this forum and have been unable to resolve. As is, ShotCut is totally unusable on my system.

Before proceeding further, when you say you have gone through all tips, make sure you have undergone a full uninstall, including registry cleaning and folder removal. That process is documented here, and should be followed to the letter:

Assuming you have done that, 2 more questions:

  1. do you have one drive or another synchronised backup service like dropbox installed?
  2. do you have grammarly installed?

Since this thread has been closed, if you don’t get any joy in relatively short order, it might be best to start your own topic.

Hi. I have just read Glad8tor’s thread and I think that I have the same problem, the problem is, I don’t quite understand how you fixed the problem. I’m not sure what you did about it. Should I clear my One Drive deleted files? I have already uninstalled and re installed Shotcut twice. It seems to fix the problem for one editing job but then reverts back to freezing and lagging until I have to control/alt delete just to get out of Shotcut. I have quite a high spec HP Omen gaming laptop. I noticed that my One Drive storage was maxed out and bought extra space. Still no joy! I am at a loss. If anyone can offer any advice I would extremely grateful! Cheers!

I just ran into a similar problem on a Linux machine, and I found that the configuration data was corrupt, specifically, the recent files list. If I try to scroll that list to the end, Shotcut would hang very long (waited at least 5 minutes before giving up). I was able to move the config file, but on Windows the default is the registry. You can try to delete Shotcut’s recent key in the registry or completely reset the configuration data using either the installer or Settings > Reset menu item within Shotcut.

I made a change for the next version to move the recent data out of the configuration (settings) data and to clear the recent data in configuration.