Shotcut using 20GB of RAM then failing

Hello there,

I have used Shotcut for several projects before I experienced this.

I edited a video, then went to export. It worked fine for a while, with normal resource values, until it reached 81%. At this point, the RAM usage slowly climbed, reaching up to 20GB (I have 24GB, and my computer never reached 100% ram). After several minutes of staying at high values, it failed.

After I realised that it had failed, I tried again. Same thing. After that, I restarted my PC and tried again. Same thing. I reinstalled Shotcut and tried again. Same thing. I did some reasearch after this, there were some posts about this;

I tried messing with export settings, to no avail

I tried running qmelt from the command line, same thing.

I tried running Shotcut as administrator. Same thing.

I tried re-editing it. Same thing.

I tried different footage. Same thing.

I tried different export presets. Same thing.

I am using an AMD Ryzen 5 (6 cores, 3.6 MHz, 12 threads) and 24 GB of DDR4 RAM. I have a 1000GB SSD which has 600GB free. I have a GT710, which has 1GB of GRAM.

I am using an up-to-date copy of Windows 10.

Can you examine the export log to see if you can deduce where the problem is coming from?

Often people are able to look in the export log to find the time in the video where the failure occurs. Then, upon inspection, they find what feature they are using at that time. Perhaps the beginning of a transition or a filter. If you can identify a feature that begins at that time (or maybe just guess at some), disable that feature, or try to change it in some way to see if the problem still occurs.

You can post the log to this forum so other people can see.

At 12:46 (the corresponding timecode), I did the following edit;

Speed up to 8x (no pitch compensation)

Speed up further to 32x (with pitch compensation)

I did this to get the sped-up footage effect thing, but not so much that it hurts anyone’s ears

The error report is too big to fit in a message. Here it is on Pastebin: https://pastebin.com/kBK1eFGn

The error report doesn’t have any recognisable timestamp as far as I can tell, so I just went off of the percentage that it got to upon failure

The last message before the crash is:

[producer avformat] C:/Users/sean/Videos/2020-05-26 15-45-22.mkv
checking VFR: pkt.duration 16
[filter swresample] 2(stereo) f32le 1411200Hz -> 2(stereo) f32le 48000Hz

This message indicates that it is trying to convert the audio samples for the 32x speed change.

There is something about the 32x speed change that it does not like.

Can you try with pitch compensation disabled?

Can you try less speed change? How low do you have to make the speed so that it works?

What version of Shotcut are you using?

I’m using the latest version of Shotcut, and the segment wasn’t that important, so I cut it out entirely. However, I think that it may have been struggling with the sheer speed of 32x.

32x works for me in my tests. But maybe there is some combination of other things that causes the failure for you.

I forgot to mention, Shotcut crashed shortly after I edited that segment. I reloaded an autosave. Maybe that has something to do with it?