Crashing for "Missing Key Frame"

I have a video I’ve been working on ready to go. I’ve tried to export with my custom quality settings and the H264 High/Main profiles. All three fail. I can export with the Default and YouTube settings.

Checking the logs on the failed exports, I see:

[mov,mp4,m4a,3gp,3g2,mj2 @ 0000000030e9bcc0] st: 0 edit list: 1 Missing key frame while searching for timestamp: 1001
[mov,mp4,m4a,3gp,3g2,mj2 @ 0000000030e9bcc0] st: 0 edit list 1 Cannot find an index entry before timestamp: 1001.
[h264 @ 000000000969e080] Reinit context to 1920x1088, pix_fmt: yuvj420p
[producer avformat] audio: total_streams 1 max_stream 1 total_channels 2 max_channels 2
[AVIOContext @ 000000000a3ec680] Statistics: 300500 bytes read, 2 seeks
[producer avformat] C:\Users\cdodd\Videos\Todd Judy Ford\Factory Invoice\the-invoice.MP4
    checking VFR: pkt.duration 1001
Current Frame:       1026, percentage:         33
Failed with exit code -1073741819

I have nothing in the video with keyframes. To be clear, I DID have some keyframe text during an earlier pass, but that was removed long before. Nothing at frame 1026 even has a filter applied. I’m not sure what else I can provide to help track this down.

I tried deleting a clip that started there, and successfully exported it. There were no filters on that clip, and it was not keyframe. The clip was slowed down and it’s possible I clicked the keyframe button there at some point in the past but it was not set during the attempted exports.

Now can you re-add the clip? Does it export successfully after re-adding it?

This key frame is not Shotcut’s keyframes. It is a message from ffmpeg complaining about reading your file. Most video codecs support the concept of key frames as a part of compression.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.