Export fails with "[consumer avformat] Could not open"

I edited a video for yt. Video includes .gif, .mkv & .mp3 if that matters. Went to go export it using the stock yt option without changing any of the presets & it fails over & over. Hardware encoder is unchecked. I’ve also tried it with the hardware encoder checked & I also tried to look in the advanced settings to see that parallel processing is unchecked as well (as some youtubers advised). I’ve also tried restarting the app. Still fails. Can anyone check out the logs & see if able to spot what’s going on? Please help? :frowning:

Export Fail Log.txt (3.2 KB)

1 Like

[consumer avformat] Could not open 'C:/Users/QUAY/Videos/completed yt vids/r2r100bby.pt1.mp4'

consumer avformat is the component that needs to create the output file. For some reason it was unable to create it. Others have reported it, but not many have followed up with their workaround other than I think one person succeeded after trying a different drive and another using simply C:\. Does the file already exist? If so, try removing it in Explorer. Try a different folder that does not have automatic backup or sync to a cloud drive service.

1 Like

So i have no idea what any of what you said means lol :woman_facepalming:t4: , however, what you said sounded like something i heard before about the app not having permission to place files where it needed to. To fix that, i had to allow the app through the controlled folder access (quick start menu search will bring it up). So this time I turned controlled folder access off & tried again & now it’s rendering! Yaay! lol Hopefully it goes all the way through–if not i’ll come back lol :slight_smile: TYSM


Thank you for replying with that excellent workaround!

And from Protect important folders with controlled folder access on microsoft.com:

Protected folders are specified when controlled folder access is configured. Typically, commonly used folders, such as those used for documents, pictures, downloads, and so on, are included in the list of controlled folders.


No problem! :slight_smile: I wouldn’t have thought to try that without your response! You’re awesome! lol

This topic was automatically closed after 90 days. New replies are no longer allowed.