Linux: Cannot export


Great software to use. One problem. It fails when exporting. The ending of the log says the following. If more details are needed, please let me know.

I was exporting the work in progress OK then I added a short video from youtube and this problem started to pop up. If the time shown when export fails is the time in the video, it does not fails where the video is but rather around where a jpg is found on an additional video track. Question: should there be only one video track or are all tracks merged when exporting ? - Thanks !

[mp4 @ 0x7fcb48200f00] Using AVStream.codec to pass codec parameters to muxers is deprecated, use AVStream.codecpar instead.

[swscaler @ 0x7fcb30661e00] Warning: data is not aligned! This can lead to a speed loss

[producer avformat] audio: total_streams 1 max_stream 1 total_channels 2 max_channels 2

[AVIOContext @ 0x7fcb31da21c0] Statistics: 34293 bytes read, 3 seeks

[libvpx-vp9 @ 0x7fcafc6cfa80] v1.9.0

[libvpx-vp9 @ 0x7fcafc6cfa80] --prefix=/root/shotcut/Shotcut/ --enable-vp8 --enable-postproc --enable-multithread --disable-install-docs --disable-debug-libs --disable-examples --disable-unit-tests --extra-cflags=-std=c99 --enable-runtime-cpu-detect --enable-shared

[chain avformat-novalidate] /VM/OpenShot/FaceValue/JamSection/LSDPEAKVISUALS-PsychedelicAcidTripSimulation.webm

checking VFR: pkt.duration 41

Failed with exit code 11

Failed with exit code 11

SOLVED. I’ve combined all video tracks (there were three) into one video track and it now exports OK.

I guess that having several video tracks is not a good thing to do.

You could have several tracks and it works properly for me, I created a project with 6 tracks 2 hours of length and ram usage of about 27 GBs’ and it still ran smoothly and export was normal, you are having the problem due to a unsupported old version or unstable version, or you are running out of ram.

I do not know anything about log files and exit codes, so I can’t say anything about them.

But shotcut actually have already a solution about this exit code 11 in another topic (I am not totally sure that it is useful for you):

Failed again yesterday. Today I opened the session and tried to export (always using default, no custom) and it failed again.

Exit code 11 is a segfault if I’m not mistaken.

So I shortened the default transition between a jog file and a webm youtube clip and it exported successfully.

I put back the transition at full length and it failed.

I’ve put transition back to the shortened version at it failed.

I saved the session, closed Shotcut, restarted it, did an export and it was successful.

There’s clearly some instability in the software, as far as I can see.

Is Shotcut using the Qt multitasking library ?

Is the .mlt format a standard ? Is it possible to load such a file in another software for exporting ?

Thanks !

What is your Shotcut version?

Can you upload the full

application log and the export log?

When it fails, does it always fail at the same spot? Or does it fail at a random percent?

From your test results it is difficult to conclude if the transition is causing the failure or if the failure is just intermittent. You could also try removing the transition and creating a new one.

The exit code failures are infrequent, inconsistent, and do not happy to most people. We have been working to reduce them, but if a failure does not happen for a developer, then the developer can not fix it.

We have a collection of advice here which may be helpful:

I am a developer and I do not know what that is. The front end GUI is written using QT and the backend processing (that is used for export) is mostly written in C, but some filters do use the QT library.

No. There is an EDL export feature in the File menu, if that is useful for you.


“I am a developer and I do not know what that is”

Years ago when I invited the Trolltech guys at the company it was called Qt. Uppercase Q, lowercase t. And it featured a multitasking ‘library’ consisting of slots and signals if I’m not mistaken. What I meant is that, part of Qt there are multitasking capabilities offered to the developer. Like a sub-system.

Version is 21.06.29

It does not fail always at the same place, considering no modification to the video. The time shown when exporting and failing corresponds to the middle of jpg file.

You will find attached the logs.

I wonder if it could be an external software called for processing that might be provoking what looks like a segfault.

Thanks ! Much appreciated.

applicationLog.txt (33.3 KB)
encodeLog.txt (2.6 KB)

It looks like the export is failing immediately (at 0% progress). Maybe it is having trouble writing to your output file. Can you try to export to a different partition or folder?

No, this is not the case at all. Every time data was written on the disk. Just tried to export again, see attached screenshot. The file created was FaceValue.mp4 :

-rw-rw-r-- 1 user user 58367244 Jul 19 21:26 FaceValue-backup.mp4
-rw-rw-r-- 1 user user 57490285 Jul 21 13:00 FaceValue-backup2.mp4
-rw-rw-r-- 1 user user 57677914 Jul 21 13:13 FaceValue-backup3.mp4
-rw-rw-r-- 1 user user 61866032 Jul 23 06:46 FaceValue.mp4

Aside from this I do not experience any disk related problems. I create music and use Bitwig and Harrison’s Mixbus32C. Never had any problem with that disk.

The disk space is:

/dev/sda6 289G 260G 15G 95% /VM

15G available, should be more than enough. Nevertheless Shotcut shows a warning at the beginning of the export. See second screenshot.


And this is the other screen shot since new users can only put one at a time:


This is just a portion, can you put the screenshot of the whole shotcut window.

Darn. Without doing any modification to the project, just opening Shotcut and exporting, it succeeded. Let me do it once more. I’ll close Shotcut, restart it, then export again …

There it goes, it failed. And here’s the full screenshot.

There isn’t much to spot out, but have you tried to use hardware encoding? If you have tried it, try to configure what you will be using in it now.

Hardware Encoding

The benefit of hardware encoding is that it reduces the load on your CPU by using a purpose built piece of hardware on your Nvidia graphics card.

I hope it’s a useful piece.

Pure speculation here… Do all of your clips have the same exact frame rates (fps) as your video mode?

  • When it keeps stopping, as in your screenshot (3m : 27s: 10th frame) at that location does that file have the same exact FPS as your Video Mode?

    • To check your current video mode, click on “Output” in the timeline, then click on Properties. And to check on that clip, select it on the timeline, then Properties.

    • What what exactly is happening at that location? Transition I’m guessing. What filters and settings are being used at this location?

  • What distro of Linux are you using?

  • Did you get Shotcut from this website? Shotcut - Download

If you were to do a Save As (save it as a new file name), and delete those problem sections or delete filters/transitions at that location, will it export 100%?

1 Like

This is simply a warning and not blocking export. It cannot accurately predict how large the file will be. Read it; it is simply telling you getting low on disk space.

You see that time code next to “failed” in the job view? There is likely a problem around that point. But maybe also you are running out of memory.

I am not a developer of Shotcut (though I have done software development on other projects), so take this with a grain of salt - but in general, I would say that running any modern OS with your disk drive 95% full is likely to run into intermittent problems. The OS needs some room to swap things out, and even though the “swap file” may “only” be, say, 4Gb, the way that the system allocates temporary files can chew up a lot more space than that.

Keep in mind that video is VERY memory/disk intensive. If your RAM is not overly generous, on top of a 95% full disk, then I would say you need to address the memory and disk space issues before trying to pin down any particular cause for any software that may be crashing.

Hello. To everyone else: I haven’t had much time to pursue the problem these last few days. However there was one successful export of the current state of the project. I’ll be back to it in the coming days.

@awake : There are currently three disks. The disk here labeled /VM is not hosting the OS. And there’s no user partition on that one. However the main disk with the OS and the user partition is also on the low side. That might be a good point and I can do some cleanup on that one. I can rather easily clear up 16GB on the OS drive, which in turn would give more space for /tmp.

System memory is 16GB and the swap is on the /VM disk with the /VM disk having 14GB free. Which means that after cleanup the thing that will be different will be the /tmp directory having at least 16GB available (actually more). I can give this a try, no problem. In the next few days. Thanks.

1 Like

Hello. Sorry for the delay ! I have made some space. Now the main drive which hosts the OS and /tmp has 18GB free. I have tried an export of a very simple clip taken from youtube which I split in two parts and put the last part to the beginning.

It failed again. I rebooted and tried another export w/o changing anything and it worked.

Looking at the log it reported the following when it failed:

(cannot include the log text, see screenshot)

Looking at the log when it succeeded, it reported the following:

(cannot include the log text, see screenshot)

My question is: Is it possible to add a ‘verbose’ or ‘debug’ flag to melt-7 ?

Ans here’s the log text: