V19.01 BETA now available

Rules of Participation (Important)

  • Provide all feedback as a reply within this thread or as a GitHub Issue.
  • If using a GitHub issue, make sure you indicate the version.
  • You can reference other threads from this thread, but do not confuse others by opening new posts/threads.
  • Do not report about existing bugs that have not been indicated as fixed by this version.
  • The beta period is only going to last 7 - 14 days.
  • We are only interested in major regressions over recent versions (v18.08 and newer).
  • We are also interested in major bugs in new features and changes specific to this release.
  • There will only be another beta released if there is a critical problem that needs confirmation from testers after the fix.
  • The actual release may add some low risk fixes and additions (e.g. new filter) over the beta.


Get the beta release from this GitHub page that also includes the list of fixes, changes, and additions.

Thank You For Your Help!

1 Like

Center playhead for timeline and key frames is very cool. Color grading improvement is great, especially for Shadows (Lift).

There is a new How To Contribute page on the web site that explains a little more about the new templates framework for the Overlay HTML filter.

its very nice improvement of color grading filter and centre playhead works great. I have some issues with this new beta version of Shotcut 19.01.19 BETA. OS : Linux Mint 19.1

  1. I downloaded Shotcut 19.1.19 beta Appimage and open it, I want to compare this beta version with my pre-installed shotcut 18.12 (from Flathub) on my Linux Mint. but I found older version (18.12) is now become 19.12 with new size and position presets and overlay HTML templates.(before I using SC 19.1.19 beta Appimage I downlaod and extracted SC 19.1.19 beta . txz file in download directory but Shocut didn’t run after making executable from properties, so I moved it to the trash and clean my trash but still previously installed Shocut shows version 19.1.19 !!)

    2.Overlay HTML:
    a. after adding overlay HTML filter, it do not automatically checked the checkBox. after choose one of the Templates and try to check filter, selected Template disappear. Re-check now works fine.
    b. after I choose one of the Templates, it works fine but I want to use another Template,now how can I do this without remove filter and re-add ?? because there is no option to cancel selected template and add another.

Thank you.

  • Fixed the lossless/H.264 preset to be completely lossless.

Does this also go for the H.264 option in Convert to Edit-friendly/Reverse? In the last version you corrected the ProRes Export preset so did that correction also apply to the ProRes option in Convert to Edit-friendly/Reverse?

Version 19.01.19 beta Windows 10: still not seeing video scope graticule or numeric markings.

The “Center the Playhead” works really great.
This will really help doing voice overs.
Thank you for adding it.

Hi - clicking on the new HTML templates doesn’t seem to direct me to the appropriate folder where the files are - i.e. share/shotcut/qml/filters/webvfx/templates.
Should it?


Seems to point to a random folder on my desktop. I think it’s the last folder I accessed.

No. Go there yourself in a file manager if you want to. Otherwise, click on a Template name starts a new one. If you are using the project folder feature, this should create it automatically and go to the editor.

Sorry, but I cannot follow what you did and help you. This is your mess and not a bug as far as I can tell.

You cannot.

OK, thanks, Dan. I wasn’t using the Project folder. I did navigate to the blue middle bar html. Will experiment.

Fails to load audio files

So I tried using shotcut on Ubuntu to see if there are any big differences in performance but when I tried to import an audio file by clicking and dragging it to the preview area it came up with an error saying “Failed to load [file path of audio]”. I tried using both MP3 and WAV formats and the exact same error occured. The same error occured when dragging audio into the playlist.
(I can’t send a screenshot right now since I’m on mobile but I’ll try tomorrow at some point)
I have not tested this bug on windows yet since I’m gonna try to stick with the latest v18 release for now until v19 goes out of beta

Also if it does have any significance, I was running Ubuntu on a virtual machine with 8gb ram, 4 cores, 64gb total allocated storage

Unable to reproduce.

Ok well as soon as I have access to my PC I’ll send you a screenshot and hopefully some logs or something. Also the shotcut I got in Ubuntu was from the Ubuntu software app and not from the official site so maybe that might have something to do with it. Try using the store version.

That is the snap, which I produce from the portable tar. I pushed it to the store already because many Linux users are suffering from a crash on startup. There is an urgency to this new release and the beta will be very short.

These changes do not apply here. The H.264 option in the Convert/Reverse dialog is not lossless, and the ProRes option do not have the same quality % problem that Export had.

Ok i’m on py pc now.
here’s the error

You’re on VirtualBox?

yea I said that in my first bug report on this thread