Shotcut is not working in Xubuntu 18.04


#1

Hello!

I have fresh install of Xubuntu 18.04, and try to get Shotcut to work. I tried both snap install and archived zip, none are working. I tried to run executable file from archive, nothing happen either. Is there any way to make it work?

I had Kubuntu 18.04 installed before that, and archived zip worked fine (except I had some bug when copying filters - fade away timing would not set to default). Snap didn’t work either though. And yet before that, I had Ubuntu 17.10, snap was working fine.

I use Nvidia drivers if that matters.

Thanks.


#2

Please run the Shotcut startup script from a command prompt and report the output messages. Be sure you are running the wrapper script (Shotcut.app/shotcut) and not the actual Shotcut executable.


#3

Here is the output:

This application failed to start because it could not find or load the Qt platform plugin "xcb"
in "".

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, wayland-egl, wayland, xcb.

Reinstalling the application may fix this problem.
Aborted (core dumped)


#4

There you go. Install XCB.

See here:


#5

It worked. Shotcut starts now. Thank you.

However, I have some issues with the interface.
image

The arrows are bigger than place holders, I didn’t have it in my kubuntu installation.
Is it possible to correct it?


#6

Could be a DPI issue. Try the suggestions here:

Also of interest:



#7

thanks, it fixed it. I just added

QT_AUTO_SCREEN_SCALE_FACTOR=0

before

bin/shotcut “$@”

in …/Shotcut/Shotcut.app/shotcut and it did the trick.