Program dont fit on tv screen


#1

Program don’t Fit on my screen when i add time line and other windows they get out of screen and there is no way to adjust them to screen. I am using linux and tv as screen via hdmi cable. Everything else except this app fits correctly to screen.


Shotcut Resolution Ubuntu
Shotcut is not working in Xubuntu 18.04
#2

This sounds like an issue with overscan on the TV, Do you have any OS level adjustments to compensate?


#3

search for overscan compensation on tv or in your graphics card software
but it can also be that the video is 4:3 but the project export is 16:9, soo then you need to change project settings


#4

This sounds like a video card and driver problem to me. I am using an nVidia GT-710 with HDMI driving a Samsung S24F350. TVs historically utilize overscan to avoid viewers seeing scanning artifacts - but HDTVs much less so. The nVidia driver on Linux has adjustments for Resolution and so on. But TVs are not well suited for PC work.

If Shotcut is displaying beyond your screen edges then how are you able to see the Status line and system tray, for instance?

-=Ken=-


#5

It is possible you are experiencing a HiDPI issue. Search the forum here on that keyword. If so, there is a workaround. Also, you did not specify your resolution. Shotcut can be made very small especially if you do not open many panels. It can be made smaller than practically usable. Here is an example on Windows with all panels open that is 1014x585.

And another one with less panels that is only 679x585.

On small screen resolutions, you might need to make some panels floating to prevent them from making the main window bigger. I challenge you to identify another multitrack video editor that can be made to resize that small.


Shotcut too big on tv screen
#6

I am having the same problem. Running a 1920x1200 screen. Have run this with both Intel and GTX 1060 hardware with same result on Ubuntu 16.04.
All other fonts/windows are correctly sized. The attached image shows how Shotcut seems to have a graphic scaling problem. Even if you shrink the window, you can see that items don’t fit. Other problem symptoms appear to be:

  1. On menus such as Edit, the drop down has double-vision text, i.e. repeated a slight distance down and to the right. It is almost unreadable.
  2. I have run shotcut in windows 7 (dual boot system) and it is perfect and has various sizing handles within the window to sub-size various things. I don’t see these running under linux.

In any case, any thoughts or solutions are welcome. Thanks.

See image.


#7

I also use 16:10 monitors and Shotcut is fine. I suspect your scaling is not 96 dpi ?


#8

Hi Steve,

Thanks. I think you have identified the root problem. This appears to be a problem other ubuntu users are also having, also with some confusion.

xrandr reports a screen size of 160mm x 90mm — which seems consistent with the sizes seen in Shotcut as it tries to magnify itself for what it thinks is a microscopic screen. The Nvidea x server tool reports 96x96 dpi.

One would think it would be easy to force xrandr to use 540x340mm (25" Samsung), but I have not yet found the solution. I will post if/when I do. Thanks again.


#9

One more thing is that xrandr and xdpyinfo are NOT in agreement. That may explain why the resolution problem doesn’t affect anything else (yet). Again, suggestions or leads are welcome. Thanks!!Screenshot from 2018-04-21 12-33-28


#10

wait linux actually tries to query the screen size instead of just dpi and the resolution?


#11

HI D_S,

To answer your question on ‘wait linux actually tries to query the screen size instead of just dpi and the resolution?’:

I am assuming the monitor must report its size and available resolution settings. Since DPI is just pixels divided by inches, the inches are fixed but the number of pixels can change, for example if for some reason we run at lower resolution. So DPI is likely just calculated somewhere probably after it is rounded to a default value.

But all of this is just my guess.

One last thing is just a note that I have dual boot and, when I boot into windows, it reads the correct monitor size. That would confirm there is no hardware failure with my monitor, video card, etc. I also have another built-in GPU since I have a Skylake processor, and I had the same problem with then.

Thanks for all the help and ideas.


#12

Can you manually set a DPI scaling setting in ubuntu without having to worry about the screen size?


#13

HI D_S,

To answer your last question on ‘Can you manually set a DPI scaling setting in ubuntu without having to worry about the screen size?’, that is what I am trying to find.

There is a x-windows configuration file xorg.conf that has a section Monitor where I can add a parameter DisplaySize 540 340, and it would presumably override everything. I have not tried this yet.

First, I found you can obtain a utility to read the information from the monitor. Its called read-edid. You can install it by:
sudo apt-get update
** sudo apt-get install read-edid**
And finally run it to see what it finds by typing:
sudo get-edid | parse-edid

My monitor is returning DisplaySize 160 90, so it would appear that the “bug” after all this is the monitor itself returning the wrong size. This begs the question of how xdpyinfo and the Nvidea X-server utility correct this, or even Windows for that matter. Ideally, I would like the monitor to return its correct size information, so perhaps there may be a firmware update possible. I am looking into those.


#14

Windows to my knowledge generally ignores the “display size” and assumes that things are going to be ok at 100%


#15

Solution is here:


#16

Hi Dan,

This does sound exactly like my problem. Can I assume that Shotcut uses the QT software GUI for its graphics layer? That is apparently what gives Shotcut the smarts to resize itself based upon the screen settings.

Can you provide a little more clarification on how to “export” QT_AUTO_SCREEN_SCALE_FACTOR=0? I am assuming this turns off the scaling that is causing the problem. Is it an environment variable that I would set before invoking Shotcut? I am using the portable version, by the way. Thanks for your help!


#17

I’d like to second this motion. I’ve had a very similar problem, and I’d like to try and fix it myself.

I’m running Shotcut on a new TrueOS (FreeBSD) installation, and every time to run it I see what looks like a small corner of the splash logo, as though it was sized for a monitor roughly four times bigger than mine. After that Shotcut lags heavily, and occasionally freezes the entire system, requiring a hard reboot. If I’m lucky I can force quit the program and everything’s fine.

I can dig up more technical specs on demand, but I’m new to this OS as well as this software, so I’m fumbling my way through both.


#18

In the command line, you can run like follows:

export QT_AUTO_SCREEN_SCALE_FACTOR=0
path/to/Shotcut.app/shotcut

Or, you can edit path/to/Shotcut.app/shotcut and add the line export QT_AUTO_SCREEN_SCALE_FACTOR=0
anywhere between the first and last lines (the new line cannot be the first or last line).

Better HiDPI (or not) detection ought to be fixed when we next upgrade Qt, which is scheduled for the June release.


#19

Hi Dan,

Thanks for the guidance. That resolved the problem. Shotcut size is now perfect.

Since my monitor is reporting the wrong size, all programs running on my system would have the same problem, so I added a system-wide environment variable. I created the file /etc/profile.d/myenvvars.sh with the following contents:

myenvvars

I am new to Ubuntu and I found many ways to set the environment variable. The above is one of many. Another way that would only affect Shotcut is to edit the Shotcut.desktop file as Dan suggested. The one exec line could be changed to the following:

Exec=env QT_AUTO_SCREEN_SCALE_FACTOR=0 sh -c "$(dirname “%k”)/Shotcut.app/shotcut “%F”"

I chose not to do this Shotcut-specific fix since it may get overwritten with the next Shotcut update.

This whole problem is rather ironic. Shotcut may be one of the rare apps that check monitor size and correct itself for viewability. Most other apps (including windows) just ignore monitor size and blindly size themselves based upon pixels.

So this whole solution is really Shotcut fixing a problem with my monitor reporting its size as 7" when it is really 25".

But all this is nice to know. It is NOT just a problem with HiDPI (e.g. 4k monitors), but can rear its ugly head in other “normal” places when things aren’t quite right. Oh well — such is life.

Thanks for all the help!


#20

Hi , can you import videos on freebsd ? i tried to install freebsd and i can’t import videos on shotcut it crashes instantly, also i tested kdenlive and cinellera none of them works under freebsd , maybe i’m missing some codecs or something ?