Keyframed image doesn't move in exported video

I have a .jpg image on a video track above another video track that contains my video. I add a size and position filter to the image and add keyframes to animate it. It looks great in the preview window, but in the exported video it doesn’t work. The image doesn’t move or resize at all. Is there some export option that messes with it? I exported it as an mp4 file.

I’m running the latest version and preview scaling is turned off, as was suggested here: Export corrupts size position keyframe

image_2021-02-27_210646

I recently did precisely that, except it is a PNG with alpha-chanel transparency. I have exported it with Shotcut 21.01.29, 21.02.05 beta, and 21.02.27; in all of these MP4s, Mad King Nebuchadnezzar floats over my opening titles, wandering about and shrinking in size until he fades away. I double checked, using these multiple versions, ten minutes ago.

Does the same problem occur with a PNG instead of a JPG? That shouldn’t make a difference, but…

1 Like

Maybe, You forgot to press the keyframe button and just changed the position at specific times, so the position you changed last has been permanent, so make sure to press keyframe button before doing any animation, If you have pressed the keyframe button then try to send the log file.

1 Like

To cover all bases, I just now re-exported, substituting a JPG for the PNG.

Mad King Nebuchadnezzar still floats around and shrinks.

Curiously, someone else has reported the same issue, calling it a Shotcut bug.

So far, no one else has been able to replicate this problem.

1 Like

Yeah, same thing happens with a .PNG. I noticed that they are stuck on the last position in the animation. Inside Shotcut the animation works fine, but they’re stuck on the last frame in the exported result.

I believe I’ve done it right, as far as I’m aware. Where do I find the log file?

Menu Item: view -> Application Log at the bottom of the list.

Or Settings -> Application Directory -> Show

1 Like

Curiouser and curiouser…

I have Shotcut 21.01.29 (as well as the latest beta, yesterday’s release, and several other versions) and I do not have GPU filters.
I wish I did.

@Marmot, can you list the steps which you used to enable GPU filters? If there is a way to turn them on (like we used to do), I would like to know about it. I deeply miss those high-speed GPU filters.

1 Like

The good news: I have reproduced the problem.

I discovered how to enable GPU Effects on the latest versions of Shotcut under Linux.

The bad news:

“GPU Effects is unsupported, and that is well known. Shotcut used to issue a warning dialog every time you started the app with that turned on. But after some time, I decided that if you go out of your way to turn on something that is hidden you already understand that and removed the warning dialog.” - @shotcut, Opacity (GPU) for Chroma Key Advanced Issue

However, some good news:
The Size. Position, Rotate filter works fine for this kind of animation using Keyframes.

More bad news:
GPU - Size, Position, Rotate filter is a different filter fom the normal CPU version, so you may lose your Keyframes work when the GPU Effects is switched off, and need to recreate it manually. That happened to me when I switched GPU Effect on with an existing project.

Note to developers: The GPU Effects version of Size, Position, Rotate puts the image in the LAST Keyframe position and size, from the beginning.

2 Likes

Good catch!

2 Likes

@Austin, you get credit for the “assist”.

1 Like

Aha! The GPU effects were the problem. I think I enabled that a long time ago and forgot about it, so I guess it stayed enabled throughout the versions.

Thank you so much, everyone!

1 Like

Actually, you will be completely unable to load your project.

Yes, I was starting to notice that.

In know GPU Effects are unsupported; yet in the past they were not quite as depreciated as they are now, and there are a lot of old projects floating about with GPU filters.
It would be nice if they could at least load to be edited, so that the GPU filters could be removed and replaced with supported filters.

…without needing to learn how to safely edit an MLT file in a text editor.

You can always install an old version that did support GPU filters and do this. This is what I have done for old projects of mine that use WebVfx that is no longer supported in the recent Shotcut versions.

1 Like

This topic was automatically closed after 90 days. New replies are no longer allowed.