White color in background causing mixed up layer overlay

I’m using version 22.06.23, downloaded today.

I see a few similar questions over the years.

Open a color clip by going to Open Other or by using the shortcut keys Ctrl+Shift+O. Choose Color. In the window you’ll see it says “transparent”. Click the button to the left of it that says Color. Choose white then press the Okay button. Shotcut will open a color clip in the video player under the Source tab.

Bring that color clip to your timeline and place it on v1 and extend it for as long as you want your video to last. Place all of your pictures on video tracks above v1. Now, you will have a white background for your video. :slightly_smiling_face:

The problem is this:

v3 is on top, unless v1 is visible, then gets covered by intersection portions of v2
v2 is underneath v3 unless v1 is visible
v1 contains WHITE color

In other words, v2 and v3 behave as expected, unless v1 has a color, in which case v2 is obscuring v3.

I saw mention of “composite” setting in a post from 2017, but it doesn’t look still relevant.

I don’t know what you mean by “behave as expected”.

You do not need to have a color on V1. V2 will not obscure V3.
Perhaps I do not understand what your problem may be.
shotcut_2022-09-22_20-12-11
I used the same version as you for this example: 22.06.23

There is a bug in the new reorder tracks operation in this version. This is fixed for the next version due in a few days, but it will not repair a broken project. Did you change the order of the tracks at any time?

I did. Thanks. There are eight tracks and one or two of them are later tracks that were moved down. Is the next version going to be 22.06.x? I thought I had seen a reference to a higher number on the forum.

22.09 is the next version probably released tomorrow