Video Stuttering in Preview and Export

I shot in 1080P at 60 FPS and got the footage to shotcut, setup project at 1080P and 60 FPS. I am slowing(0.25% or 0.5%) a trimmed part of the video to get a cinematic effect but I see teh frames stuttering . I see that frames are just jumping . If I move frame by Frame in Editor , I see that some frames are repeating every 2-3 frames. I rechecked the source and I see it playing very smoothly.

How Can I get a smooth playback with that kind of slow video playback ?

25% speed at 60fps means 15fps effective output, which is well under the human eye’s ability to detect motion. An effective 15fps is always going to look stuttery because the eye is fast enough to detect individual frames at that speed. For 25% slowdown to work, the source would need to be 100-120fps, which would result in 25-30fps output after being slowed down. Also, at the time of capture, the motion blur (shutter speed) needs to be calculated for the slow version of the video, not the real-time frame rate.

Shotcut repeats frames in order to stretch a video from real-time to slow-motion. In the case of your project, the input is 60fps and the output is 60fps. The input doesn’t have any “extra” frames to fill time when the clip is slowed down, so Shotcut repeats frames to fill the extended time.

There is a technique called motion interpolation (or optical flow) which attempts to mathematically construct in-between frames when doing a slow-down. Shotcut does not support this natively, but the footage could be prepared outside of Shotcut using FFmpeg if you’re adventurous. If going this route, the footage needs to be captured with as fast a shutter speed as possible to create blur-free edges so the algorithm will have a higher chance of matching edges between neighboring frames. See these links:

1 Like

The way people use high frame rate video to make slow motion is by setting the project to a frame rate lower than the source. In your case, that is typically 30 or 29.97 fps. The way to do that in Shotcut is by setting your Video Mode.