Video Shutters in Editing


#1

Hey,
When there are shutters to the video while editing everytime there is a something in another track at the same time of the first track, and then when there is nothing in the other track it returns to be normal.
Though, when I export it, it’s working normal.
I recorded the problem: https://youtu.be/_hXmCKi600g

Is there something I can do?
Thanks


#2

It sounds to me like the video you are editing is in either 2K (1440p) or 4K (2160p). If your project is a long one then this can be frustrating. In those cases, you should consider editing it via proxy. Here is a tutorial on it:

BTW, @shotcut, in the above video at 3:12 he mentions a difference of the Resolution and Display Resolution and that Shotcut detected what he called the incorrect resolution. And at 11:00 he shows that the exported project also had a different Resolution. Were those bugs?


#3

Hey,
Thanks for the help though I am editing the video as a 1080p, any other idea?


#4

There’s an option about realtime encoding for the preview. You could try to enable/disable this option.
In general: Which version of shotcut are you using?
How powerfull is your computer?


#5

Hey Faeb,
How do I enable and disable that option?
I am pretty sure I am using the latest version and my computer is very powerful.


#6

Go to “Settings” and in the drop down menu under “Player” you will see “Realtime (frame dropping)”. You should list what version of Shotcut you are using as it can help in finding a solution in certain situations. Go to “Help” and hit “About Shotcut” and it will tell you what version you are using.


#7

Hey,
I am running the latest version, 18.09.16 .
Turning this option on and off doesn’t help.
When I disable it though the audio just becomes completely messed up though.


#8

Also another bug in the editor, when I reduce the audio as a filter on a video, it just returns to the normal audio automatically, but that’s something else, less important.
Also it always crashes and sometimes I forget to save and I have to start everything again…
Shotcut is really having problems, though I can’t really find other good free editing software’s.


#9

What are your computer specs and are you running it on Windows, Linux or Mac? Can you also give the MediaInfo for the file you are using? It’s strange that you are experiencing this as 1080p because I’ve only had this happen on 4K files when using Shotcut.

Here is a post to make clear on what kind of info to give when reporting issues like this for future reference.

And for the crashes you say are happening for you, there is currently a beta version that is for testing before the release of the next official version. Download it here and test it out to see if you are still having the same issues and if you are then report the issue there. Don’t make a separate post about it.


#10

This is normal behavior. You have a PNG with transparency on V2. Therefore, it has work to do to blend it in realtime. It is not a perfectly optimized program. Settings > GPU Effects makes this processing faster, but it also makes the program crash much more.

When I disable it though the audio just becomes completely messed up though.

This is due to a bug in version 18.09. It is fixed for the next version 18.10 coming real soon.

Also it always crashes

It is not perfect, but we keep trying to make it better. You need to provide the steps that caused the crash, or you have to wait for a developer (all 2 of us) to experience the problem ourself and try to fix it. As you can image, we spend much more time working on the code than editing video.


#11

Alright, thanks.
Glad to see that at least you know about those problems and it might be fixed.
I prefer to have problems while playing it while editing than it crashing more because even without it, it crashes alot to me.
Also if it helps somehow, It crashes mostly to me when I upload a big file or make a big change in the editing.