Ver 20.10.31 - Right Click Mouse Menu Not Working

What is your operating system?
MS Windows 10.

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
Version 10.20.31, 64 bit. Using the portable version.

Can you repeat the problem? If so, what are the steps?

Steps done:

  1. Move arrow to a clip to choose. No problem.
  2. Left-click to focus. That’s ok.
  3. Right-click to display additional menu. NOT WORKING anymore.

I do not reproduce the problem or I do not understand the steps.
What is “arrow?” The play head / cursor / current position indicator?
What panel are you in? (The name as it appears at the top of the sub-window or View menu.)
I assume you are talking about right-clicking a clip on the Timeline. That works fine for me. Maybe you want to make a screenshot and highlight the thing you are right-clicking.
Did you use a previous version where it worked?

Sorry for not being specific. What i mean here is, the “arrow” that i was referring is the mouse pointer. On the previous version. I don’t have a problem using the Right-button or right-clicking the button of the mouse to access additional or alternative menus like CUT, COPY, REMOVE, LIFT, REPLACE, SPLIT AT PLAYHEAD, DETACH AUDIO…PROPERTIES.

This menu, using the right button of the mouse could no longer be accessed after i upgrade to version 20.10.31


I have another laptop here with Linux (Endeavour OS) where Shotcut v20.09.27 is installed . This is an AppImage version. This one does not have a problem accessing the right button menu.

Kind Regards,

OK, that is “right-clicking a clip on the Timeline.” It works for me on 2 different Windows 10 systems. Fortunately, you do not need it for most things. You can select and choose an action from the toolbar or keyboard shortcut. Even detach audio can be done manually by simply copying the clip to an audio track and muting the video clip.

But that is still a bug right? And i found two more bugs i think. Shall i create a new topic for it?

I am comparing this function with my other laptop in Linux having an AppImage Shotcut. And the additional menus are working perfectly on the previous version.

Sure, if you want to call it that, but I cannot fix it if I do not reproduce it. Feel free to work on it yourself. The source code is readily available.

Each bug should get its own thread.

Ok, i will create another topic later but first I will try to uninstall the apps and reinstall maybe that might help. I will keep you posted. After I’ve done it. Maybe the problem will be solved by reinstalling the app.

Thanks again.

Please also try the different options in Settings > Display Method to see if it makes a difference.

The Setting > Display did not work either. I reinstalled the Windows Installer. The newly installed portable version did not work too. Sha256sum is the same for all the package i have tried.

The windows installer has the same problem. I will just use the portable one.

You can also look in View > Application Log immediately after right click fails to see if there is a message about it at the end of the log. What about right-click an empty area of the Timeline or a track header? Do those work?

Here is the last few lines from the log:

[Info ] MainWindow::showStatusMessage “Click in rectangle + hold Shift to drag”
[Info ] MainWindow::showStatusMessage “Click in rectangle + hold Shift to drag”

The forum editor does not want me to post more lines.

I can’t duplicate the issue.

Windows 10 Home

Shotcut 20.10.31 (Portable)
Video file on the timeline, right clicked.

Shotcut 20.10.31 (Installed)
Image file on the timeline, right clicked.

1 Like

Works fine for me too.

Good Day everyone!

This is very strange! I installed now the AppImage on my Lenovo with Linux (Endeavour OS) and it works fine! None of the problem is showing up BUT on my Dell laptop with Win10, this bug(?) occurs. I installed the Windows installer last night but was disappointed also. I just removed it and re-download the portable version. All checksums are good but i still encounter the same problem.

I just hear a clicking sound whenever i right-click my mouse. I tried with the track-pad or mouse-pad on my laptop but still the same problem.

Are you using a Logitech wireless mouse?

I am using a Dell mouse. Wireless but I am using the same mouse for several months with the old version of Shot without any problems. I will swap with HP mouse on my other laptop. Thanks.

Same problem with HP mouse. I think it is not the hardware has the problem for me.

Are you able to right click on other applications?