Urdu Subtitle

I am adding Urdu subtitles in my video and they are working perfectly fine during edditing but after exporting the video they change their place and move to the extreme left of the screen.
I want to know that how can I fix it so that the subtitles appear at the desired place even after exporting.
One more thing I would like to add for those who don’t know is that Urdu is written from right to left like Arabic.
Thanks.

This sounds like you changed the resolution setting in Export - Advanced from what the original Video Mode is. To reset, when going to Export, click Reset to have Export match your video mode’s resolution.

It is highly possible there is some other reason, but without more information it will be hard to keep guessing.

It will be helpful to get a screenshot of your project, with the clip selected. Playhead should be on that clip showing in the preview, full view of the timeline with all tracks visible. Full view of the filters pane for that clip, specifically showing filter in question.

Possibly related to this post (however, I do not see any solutions posted):