Transitions and joined clips create 'crackle' sound

Hello, I’ve been using Shotcut for a while but I’m not an expert at this. I’m experiencing a small problem and not sure what could be causing it:

within tracks, wherever clips are joined / back-to-back, the audio creates a brief crackling noise as it moves over the joint. It’s even more noticeable on transitions, where it crackles at the beginning and at the end of the transition. I’ve tried muting the transitions, but that’s not helped. Does anyone have any idea what could be causing this? Is it something to do with local settings?

The audio is part of the video, not separate. I’m using filters such as low pass, high pass, compressor, normalizer on the entire track. Mostly with default settings or slight adjustments, nothing dramatic. Video mode is automatic. Audio channels match the clips at 2. I’ve tried different exports such as YouTube or mpeg4. Any idea where else to look?

Is this post different than your other post?

Hi there, yes it is. The other post was about a total crash, no audio at all. But on other files where the audio is fine otherwise, there is a crackle on transitions. Could it be related?

How many source files are you using?

Is there a direct reason for using all of those audio filters?

It’s only 2 or 3 source files, perhaps max. 4 or 5 in some projects.

The audio needs improving and I was taught to use these filters in an audio editing course. As I understand, the mentioned selection is common practice. It doesn’t seem that many, does it? How many would you suggest can be handled at once?

I just tested removing the filters, but it doesn’t remove the crackle. The filters enhance the volume of the crackle with general volume increase of the audio, but the crackle itself doesn’t seem to be caused by the filters.

It may be better to use Audacity, or other DAW software for enhancement of the audio, export that audio to WAV and use that in your video.

Is it common practice to fix audio, perhaps depending upon your needs are. It’s more common practice to have excellent audio when recording the first time.

Then I suspect you may have a video file with bad audio. Have you tested playing with a different media source, such as VLC media player?

Also look at the audio wave form in the timeline. Is your audio wave form higher than the yellow? Any of the audio above the line? Perhaps the crackle could be distortion from the audio being too loud.

One thing to keep in mind when using Shotcut, currently, when using video, if your video has multiple audio tracks, Shotcut only sees one track, and it’s always defaulted to track 1 by default. You can choose which audio track you want to use, one audio track used per video track in the timeline.

For all of the source files with the audio issues, can you list these items for each source file?

If you hide the video, do you still get the crackle sound?

I have never experienced crackling sounds with Shotcut, ever. I always experience some sort of audio stutter, jumps, which is why I have these setting turned off, as I don’t need them when editing.

Hello! Thanks for your suggestions!

Yes, we’ve tested on various devices with different players. The source files are fine.

Checked and the audio is well below the yellow line.

Interesting! Thanks for the info! in this case, there is only the original audio in the video track.

Yes, I do.

Scrub audio is off too.

I just saw that the source files are mono - sorry, I did check before and must have missed this somehow. There are 2 other source files in there without transitions and therefore no problems and they both have 2 channels. What setting must the audio mode then be? It was on 2 channels, but now I just switched it to mono to test, then the file crashed and closed and now it won’t open any more - when I try, it just closes again immediately. Is there any way to undo the setting without opening it?

I’m really curious to see the MLT save file, you can drag it in here. I still can’t seem to duplicate the issue. I’ve just made a 10fps clip and a 25fps clip to attempt to have the same issue. I haven’t tried making one mono yet.

You do have a mis-match of resolutions with just two files, and a super low FPS of just 10. You can still have more than one audio track (even though track 1 is mono).

Meanwhile the file has agreed to open again :slight_smile: temperamental!
It’s now running on mono, but still the same.

Sure! I’ll insert the file here.
You’ll see there are other muted tracks - you can ignore those. I just use them for editing space and to store some clips in case they are needed. I also tried saving a copy of the file and deleting all unused tracks so just the one active track is left, but unfortunately it didn’t make any difference.

The source files are produced in MS PowerPoint as screen captures. The difference in resolution must have to do with the screen capture area? Though it should be the same as it’s from the same setting … strange.

If you have any suggestions for improvements, I’d love to hear them! As I say, I’m not an expert as this and keen to learn. Thanks for looking into the problem!

[file removed]

I’m not an expert either, but over the past year learning this software and reading the forum there are things I know that work and don’t work for others.

From your other thread:

I didn’t know you were using Dropbox. There has been other issues where people couldn’t sue dropbox, and/or LAN connections within a business for whatever reason, which might come down to metered connection associated with you business IT department or internet service speed. You’re essentially trying to edit across an internet connection, not your local hard drive. It may show C:\ but the dropbox directory is from an app that’s installed on your computer.

This is from your MLT file. (I blurred the obvious names you might not what shown)
Because you didn’t assign any video mode, it used the Automatic, and adopted the first file you imported, and your video mode is now 1552x902, and all your video editing will be constrained to this size, which is almost 5:3 aspect ratio.

Not sure if you were aiming for a different resolution, but 1920x1080 is fairly standard, and is why there are presets in Shotcut that you set before you start your video process.

For capturing video, you might want to look at screen capturing software, something with at 30fps to a 60fps settings. If you’re going on YouTube 1080p, 60fps is really great to have on there.

I do recommend OBS for screen capture. The software itself, like Shotcut, isn’t exactly pretty to look at but highly functional. With OBS, you can literally record an entire video with it without editing. Free & Open Source, and it’s standard among game streamers that don’t use XSplit. Their support forum is massive and very active every hour of the day. There are simple setting with OBS, but I suggest going through this playlist on YouTube to find what you have to do to get things set up. (skip to 1:00 in each video to get past all of the intro/self made ads) When you look through the list of videos in there, you’ll discover not all of them will be for you, so skip them.

Essentially with OBS you’ll record your Power Point presentation as it’s being displayed at whatever FPS setting you desire, and at whatever Resolution you desire. This way you have a really nice file to work with.

This is what OBS looks like capturing the screen. Don’t worry about the Scenes, just create a Source: Display Capture. You can add in all sorts of audio, other video devices, for your video. The red outline is what you can manually adjust your source from. You can assign keyboard shortcuts for every scene, source, transition, every function of OBS.

Is this only in the app preview or also in the exported result played in a media player? Preview is not optimal because it is trying to do many things in real-time and introduces processing latencies.

Also, AAC is not optimal for editing because it does not always accurately cut to the correct sample. Uncompressed (WAV/PCM) or an audio codec with no delay such as AC-3 works better. However, it is possible the problem is some combination of audio channels and frame rate problem especially if you are changing the frame rate when you export, which you should avoid.

Thanks! Yes, the problem is also in the export files - and there even more noticeable.

Sounds like I need to learn more about the right files and settings to use! Thanks for the info! I’ll check it and try to improve the source files.

Thank you for your help!

Hey, this is so helpful! Thanks a lot! I’ve downloaded OBS and will definitely check it out! I had an inkling that PPT might not be ideal … so I’ll improve the source files and formats and then hopefully that should fix it.

About Dropbox: I have the files stored locally and then synchronised to Dropbox/cloud, so there is a copy of the file on my computer. I’m not working in the browser/cloud, is that what you meant?

Thanks a lot for your time and help! I’ve learnt a lot :slight_smile:

I found this video on how to export powerpoint to a video.
Would this help? Not sure what settings you used.

Hey thanks! Yes, I’ve been exporting the files like that already. And it’s also possible to right click on individual clips on the media and save them as mp4.

Now I just realised… that’s where I’m getting the bad resolutions in the souce files - from right-clicking and saving the clips, right? So I should always use the export function if I want to edit the files afterwards. doh
Thanks for the nudge!

It you’re talking from within Powerpoint I have no clue. Never used the program.
Best practice is to have your source material of the highest quality possible.

I originally searched for a file converter from ppt to mp4 then I ran across the above video.

This topic was automatically closed after 90 days. New replies are no longer allowed.