There are missing files in your project

I have this problem.
I don’t changed place for my files, I have all files in two folders.
I don’t know what is this , blank "
Please, help me.
I spend +10 hours for my new film


When I clicked , OK "
In my films, the image, resolution, zoom have changed,
Can’t repair this, can’t be same like earlier

Double click in that spot to point to the file you’re missing.
Either you deleted or moved the file since you last save the mlt.
Or you don’t have access to that directory.

Read this post, and scroll down to where is says “Missing Files”.

When I click Replacement, I got this window

You have to find that missing file on your computer. It opened up the last known folder location. With that window open, you have to navigate your computer to find that missing file. Once you find that file, Shotcut will repair your MLT, thus creating a repaired copy of your original MLT file.

I did this fix but the images in those videos broke, why?

Only one video of them is good

The main and only problem after the repair is that the maximum resolution of the videos has decreased, how to fix it?

Still nothing :confused:

Could you upload 2.mlt ?
Just drag and drop in the reply window, or use the file uploader icon.

Yes I can, but when I do this, all my videos in " 2.mlt 234 jazda polaczone.mlt " have problems with the maximum resolution of the videos has decreased, 1ss

2.mlt 234 jazda polaczone.mlt (45.2 KB)

Is it possible to somehow increase the maximum area of ​​the movie? This error has made smaller.
If it is possible, everything will be fine

Ok, I fixed the image problem by clicking this

Set your video mode to the video mode you want. Right now how have it set to “Automatic”. You can change that via Settings - Video Mode
[Language: English]

I’m not sure the exact progression from “2.mlt” to your current file.
It’s unclear what video mode you had set in “2.mlt”>
The file you uploaded has “Automatic” set for a video mode.

To learn more about the Video Mode read this:

Another related question: I sometimes end up with “Missing files…” - because I intentionally moved part of the files after the first edit. Example: I import from camera VID-01 VID-02 VID-03 VID-04. I put all of the videos into Shotcut. I start cutting VID-01, then I realize VID-03 and VID-04 was from the car racing, not the birthday. So I move (“delete from original folder”) the 03 and 04 files. In the end I have a MLT file that describes my edits, of 01 and 02 only, nice.

Now when I re-open the MLT project file… I get “Missing files”. No, well, in a sense missing, but on my command, on purpose. Now I found that I can hand-edit the MLT file, and remove the part <producer id=. Ok, I can do that. Is that (one) good way of getting rid of the message? Is there another (better ?) way of getting rid of the “Missing…” message, in case the files are gone intentionally, on purpose?

Note that I am Ok with hand editing the MLT file, not a problem. In fact I will read up more (some day when I have time) on MLT format.

Best Regards from / Jan

With Shotcut you’re not importing, rather you are opening a file to be edited. All source media is left on your computer or storage devices connected to your computer.

If you have your camera on, plugged into your computer, then open a video file into Shotcut, it will write an absolute address (see Project Management) in the project file. The project file is just computer code.

Once you move/delete a source file, or if your camera shuts off, Shotcut doesn’t know where the file is at.

A better way of repairing a MLT file is to read Project Management. All instructions are posted there.

The ultimate way to avoid having to repair a MLT file is to have all files in the same folder where you save the project MLT file to. Don’t move/delete files in said folder that you use in your project. You can move the folder where ever, just not each file within that folder.

And to safeguard your work, do Save As, and add a date or a revision number in the file name. This gives you the ability do back up your work to a different file name.

This topic was automatically closed after 90 days. New replies are no longer allowed.