Text:Rich filter not exporting what shows in Shotcut

What is your operating system?
Windows 10 Home, 64 bit operating system, x64-based processor

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
Shotcut version 20.09.13, 64-bit

Can you repeat the problem? If so, what are the steps?
(Please be specific and use the names as seen in Shotcut, preferably English. Include a screenshot or screen recording if you can. Also, you can attach logs from either View > Application Log or right-click a job and choose View Log.)

I built a service for our local fellowship, which I have done in shotcut, with text, before with no issues. Prior to putting it together, I noticed that there was an update available for shotcut, so I downloaded it prior to importing clips and starting editing. When it was exported and viewed today on YouTube, the text was not at all what was shown in the editor (examples attached) and not what I had experienced before using Shotcut and exporting with the same settings. The only things that were different between putting together this service and the other one (which was fine) were the update and the text: rich filter. Did it not save my settings for the filter on those sections when it exported? Did I do something wrong?

What showed on YouTube

From 00:04:57:00 to 00:04:58:00 in Shotcut, do you see the same thing in your screenshot from YouTube? Your screenshot of Shotcut is 5 seconds from the one shown in YouTube.

Can you click on the clip with the text rich filter applied, and show the filter settings?

Did you use Keyframes for this filter, if so, where?

Hi,

No Keyframes used in any of the text rich filters throughout the video.

Here is the filter settings

Yes, the screen on Shotcut shows the same as pictured at 00:04:57:00 to 00:04:58:00 as the screenshot previously. Different from what was exported and shown on YouTube

Any ideas?

Thanks,
-C
p.s. It’s very frustrating to only be able to upload 1 photo at a time, and have to wait between replies >.<

I am editing similar videos, but mainly use the text simple filter.
I just tried quickly reproducing what you did, but just using an image and it exported ok.
Can you try the same but with a text simple filter?
This would quickly indicate whether the problem is with the filter or something else.

I do have other areas in the video where text simple filter was used and they exported fine.

With your current settings, I am not able to reproduce the issue you’re having.
Are there any other settings I could try to duplicate what you see on YouTube?

Video Mode 1920x1080 30 fps

https://streamable.com/i44eua

Lots :sweat_smile:

The text didn’t show up at all on this one, rather than just being cut off / huge compared to what Shotcut was showing

This one only showed
"Gabirel’s
Oboe
in very large letters

Did you have Parallel Processing on in the Export menu?

@Hudson555x, same question to you.

Yes, my Parallel Processing is turned on.

Sorry, I’m not sure what that is (wait… I see the little box. What does that do?), but these are what my export settings would have been at. They would have been the same for the last video I did as well that was fine.

Okay then you and @Hudson555x are having the opposite effect I am. I tried to replicate your issue with Text: Rich typing out the same text you did on a video and it only gave me issues in the exported file when I had Parallel Processing on. At least on my end, Text: Rich doesn’t seem to agree with Parallel Processing. The text didn’t show up in one export and in another it was flickering wildly. When I turned it off the exported file had the text show up just right. I don’t know if that’s a bug.

By any chance, do you know what font you were using?

Looks like Verdana regular (varying sizes based on how much text and the room around people in the shot). I did not change it at any point, so I guess that’s the default text for it…?

Okay, so you just used the default font. Me too. I just wanted to make sure I was doing as much as I could to reproduce the issue on my end. But my issues only happen with Parallel Processing on. Whereas with @Hudson555x it works anyway and according to the image you uploaded of your export options it gives you issues with it off.

You mind trying to export it again but this time checking the Parallel Processing box to see if it gives you any different result?

Should I try just a section of it (the whole file is quite large) or will that mess up our experiment here?

p.s. I just had the “aha” moment to check and make sure it wasn’t when it was uploaded to Youtube, but the file saved to my drive still has the same issues. The tinkering continues.

Sure but if you do first make sure you export it once with the same settings you had just to make sure you get the same result then do it a second time with Parallel Processing on.

Do you know how to export only a section?

I was just going to cut out the rest and save it as a different file before exporting. Is there an easier way to export 1 section?

Yeah. Right click on the timeline away from any clips. Scroll to “Copy Timeline To Source” and click on it. It’ll first save your mlt project file or create one if you didn’t already have one for that project. Then your timeline will be reproduced in the Source tab. Then just go there and set in and out points with the I and O keys of the section you want to export. Then in the export menu make sure it has “Source” selected rather than “Timeline” where it says “From”.