Text:Rich filter does not keep the position and background size

What is your operating system?
Windows 10 Pro, version 21H2, 64-bit

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
version 22.01.30 64-bit

Can you repeat the problem? If so, what are the steps?
Text:Rich filter does not keep the position and background size I set in the filter panel. I have the box sized to match the width of the video, and be just tall enough for the line of text. In some cases I have multiple lines, so I set a taller height, but the same thing happens and text is pushed down outside the view.

In the screenshots, top is what I see when editing the filter. Bottom is what I see during playback. Note the width gets shortened and text gets cut off.

I found some earlier threads about difficulties with Rich Text, but I want to point out some differences:

  • I can see the error happen in the playback preview
  • I do not have Windows display scaling. All screens set at 100%.
  • I tried the Compatibility setting “Override high DPI scaling…” and set it to System. I don’t see any improvement.

Check the background size, it is 1440, the text is 1916
So it is cut at 1440, the background size must be close to the text size

At my system, the text size is automatic set when you set the background size, so i can get a text size there is higher than the background size.

I tried playing around with this again and I cannot get “Text size” to be within “Background size”. I tried making the font smaller (from 50 to 30 in this case), then all the text stays on the screen, but I still see the background width being reduced to about 3/4 of the intended width. No matter what I do, the background gets shrunk and the text continues on a new line if the shrunk width is too small.

Now I also tried setting the Background size to 2000 (way beyond the video width) and I think I got my intended result. So I guess it works, but not in the way I would expect it to. See below.

This seems to be related to your video mode is not using square pixels. 16:9 at 1440x1080 instead of 1920x1080, the former of which is typical with some older HD camcorders. Not saying it isn’t a big, but just shedding some insight.

This specific clip is 1920x1080, but earlier in the project I have clips of 1440x1080 (from an older camcorder as you mentioned). So I assume the overall project is being limited by the 1440. Is there something I can do to change or avoid that (without throwing out the camcorder clips)?
I am okay with what I got now for the first project, but for the second one I am wondering if I should do anything differently. Thanks

If you set the project resolution before dragging in footage, you can lock the resolution of you project to 1920 x 1080, but the 1440 x 1080, will get black borders in the sides, so you will need to zoom it with an Size, position & rotate filter, if you what it to fit the project size

This is not correct per his screenshot above. It is 1440 wide but also 16:9 because it has non-square pixels.

1 Like