[swscaler @ 0x7ff24871e280] YUV color matrix differs for YUV->YUV, using intermediate RGB to convert

I have a lot of these. It is possible that it slows down export ?
I use libx265, slide deck profile with 50% quality.
I tried libx264rgb but it fails. If possible can I keep the x264/5 while forgoing the conversion ?

ps:last version

It is possible, but unlikely.

Shotcut is probably making multiple color space conversions under the hood before the image even gets to libx264. So avoiding this one intermediate conversion is unlikely to be noticeable.

Typically we see this message when the source media is full range since it needs to be converted to limited range. Maybe different source files would not cause the message to be printed. But, again, I doubt you would notice the difference.

So I have to put a flag indicating how the color space must be RGB and it won’t go through that conversion. Since it passes through RGB all the information is limited by what RGB can express, right ? So I don’t see the point in further conversion.

But fine, I suppose it’s not the issue here. I have no clue and it does tire me, that nothing ever works “just fine”. Last time, I discover that he it couldn’t process webp files, which every now and then in the preview, would appear “invalid” or just white, and I could remove and put it back or “reload” (depending on its mood…) to set it right. But all the webp images would be plain white in the export, any setting. The rest though was fine. So I converted them in jpeg.
Now close to no pictures work, especially png.
You can see a few attempts in the directory, and how it looks, with the log of the first one, and the mlt file.
I’m trying now exactly the same setting that used to work: h264 lossless, I’ll tell you.

This message appears for YUV to YUV colorspace conversion just as the message suggests because there is more than one YUV colorspace. And yes it is slower because it is doing something, but it is necessary for correctness.
WebP is on the road map web page. PNG works fine.

I disagree with accepting importing a format if it can’t get rendered in the first place !
Some pngs on my project don’t export, and almost no to no jpgs at all do.
I wish you look at what the folder I uploaded, because there is no indication here.
In twenty minutes you’ll find too the export with lossless settings that I used to choose before.
Always news things that don’t work… with the same file. Is it like that for other people or is my luck level just so negative ?
Ask if you need some other info.

Are you using one of our builds? Your folder has no images in it.

I didn’t think you needed the whole thing… and it’s BIG, because it’s a two/three parters and all is bundled. You see I used to use the archiving function in Kdenlive… and I miss that, because I can’t seem to order stuff that I finally integrate or not to the project. maybe a third is useless, in term of size.
I cloged the 15 damn Go of my ggdrive, so here’s the few remaining files:

I am sorry you got the impression I was going to try to load your project and you uploaded all of those files. I am not. You said you were having a trouble with some images, and I was going to check those. When I first visited the drive folder you shared there were no images - only a project and some exported videos. I already have projects with images and a mix of images, and I do not have a problem. I asked if you are using a build made by us, and you did not answer. Do not bother now; I am not going to look into this any further.

​Ahah no problem, I just misunderstood. I don’t mind anyone looking since I’m supposed to make public youtube videos out of them ! The clogging made me laugh, nothing else.
Actually I did answer by replying in a reply mail instead of the forum, but it doesn’t work that way :sweat_smile:
I use only the official app executable now, last, on both computers… with same result.
By default all pictures are in the “projet…” central folder.

I’ve removed everything, I couldn’t receive mail anymore…
I’ll rather upload a new video, with logs and a few pictures not exporting.

I wrote that Slide Deck profile. The default quality settings were chosen for extremely specific reasons. Changing the quality level undoes those benefits.

The videos in your shared folder don’t appear to be PowerPoint presentations, which is what the preset was designed to encode. The encoding time with the Slide Deck preset is very slow because it’s making an extra effort to find identical frames to get the file size down, of which there are many identical frames in a PowerPoint presentation. But live-action footage… there are no identical frames. So it’s wasting a lot of time searching for something it will never find. If your exports are slow, it is not because of YUV->YUV conversion (although that does take a little time). The real slowdown is because of the choice to use the Slide Deck preset.

That’s not really how it works. The best thing is to just ignore the YUV->YUV messages. The system is doing what it needs to do to be color-correct, and it’s quite fast at it. It’s not an error; it’s just an informational message. Your input video is YUV and your output video is YUV. Don’t try to force RGB anywhere, like using libx264rgb.

It appears your luck is unusually bad. :worried: It would have been nice to see a sample of these JPG and PNG images that don’t work uploaded to your shared folder. Then we can see if we can reproduce the error loading those JPG and PNG files into our copies of Shotcut.

An archive function is not necessary if all media is in the same folder or a subfolder relative to the MLT project file. To archive the project, just copy the whole folder to an archive location, and it’s done. See:

there’s a small part (full resolution), no pictures worked, I put those suppose to be on it.
setting: lossless h264 (htough mediainfo says “lossy”).


mengele@DasReich ~> mediainfo essai.mp4
Complete name : essai.mp4
Format : MPEG-4
Format profile : Base Media
Codec ID : isom (isom/iso2/avc1/mp41)
File size : 386 MiB
Duration : 1 min 24 s
Overall bit rate mode : Variable
Overall bit rate : 38.3 Mb/s
Writing application : Lavf58.76.100

ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High 4:4:4 Predictive@L4
Format settings : CABAC / 3 Ref Frames
Format settings, CABAC : Yes
Format settings, Reference frames : 3 frames
Format settings, GOP : N=1
Codec ID : avc1
Codec ID/Info : Advanced Video Coding
Duration : 1 min 24 s
Bit rate : 38.2 Mb/s
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 25.000 FPS
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.736
Stream size : 384 MiB (100%)
Writing library : x264 core 163 r3060 5db6aa6
Encoding settings : cabac=1 / ref=3 / deblock=1:0:0 / analyse=0x3:0x113 / me=hex / subme=7 / psy=0 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=0 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=0 / chroma_qp_offset=0 / threads=3 / lookahead_threads=1 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=0 / weightp=2 / keyint=25 / keyint_min=2 / scenecut=40 / intra_refresh=0 / rc=cqp / mbtree=0 / qp=0
Color range : Limited
Color primaries : BT.709
Transfer characteristics : BT.709
Matrix coefficients : BT.709
Codec configuration box : avcC

ID : 2
Format : AAC LC
Format/Info : Advanced Audio Codec Low Complexity
Codec ID : mp4a-40-2
Duration : 1 min 24 s
Source duration : 1 min 24 s
Bit rate mode : Variable
Bit rate : 148 kb/s
Maximum bit rate : 265 kb/s / 265 kb/s
Channel(s) : 1 channel
Channel layout : C
Sampling rate : 44.1 kHz
Frame rate : 43.066 FPS (1024 SPF)
Compression mode : Lossy
Stream size : 1.49 MiB (0%)
Source stream size : 1.49 MiB (0%)
Default : Yes
Alternate group : 1
mdhd_Duration : 84451

I downloaded all the images in that google drive folder and they all load just fine in Shotcut. I tested both Windows and Linux.

The project file did not work for me. It seems to reference many image files that are not in the folder.

I meant to reply earlier. I tested too with Linux AppImage 21.12.24 and all files loaded fine.

In the MediaInfo, “lossy” refers to the audio, not the video. The video is lossless H.264, which we can determine by qp=0 being in the encoder parameter list.

I am certain the lacking pictures aren’t part of the actual sequences… excess project pictures. Maybe amping up the project management capabilities would have its perks !
I paid attention to including all the pictures you see.
And it shouldn’t “fail” to open anyway… something’s more is amiss.

When I open aaa.mlt, it shows dozens of missing files:

as I suspected. these are parts of the projects, but not the timeline. shotcut doesn’t allow to make subprojects and clean the unused clips automatically.
You should be able to let it ditch all those references without trouble.

Shotcut removes unused references automatically. The problem here is that the project file still has 164 pictures and videos in the playlist, which are not included in the Google Drive folder, hence we get “file not found” errors. Shotcut is working as expected, since maintaining the playlist between sessions is an intentional feature. Shotcut still opens the project even with the errors… it just won’t show an actual image when it can’t find the file on disk.

Subprojects can be implemented with File > Open MLT XML As Clip.

I edited the XML file to fix the incorrect directory paths. Then, I opened the file and ignored all the missing file warnings. When the file opened, all the images loaded as expected.

Is it possible that you moved the files on your hard drive and simply did not update the location in the project?

No, as I tried on my two computers, and in neither cases they were any warning about missing files. Both rendered the same.
I thank you to have confirmed the issue.