Shotcut wont open/execute!

I have tried
Compatibility Troubleshoot
Installing older versions

I just cant find a solution!
This has been going on for weeks now

Any help will be usefull!

I think you are going to have to give more info if you want assistance. Also, have a look at the Shotcut logfile and let us know what is displayed there (see here for its location:

[Info ] <Application: :Application> Starting Shotcut version 20.02.17
[Info ] <Application: :Application> Windows version 160
[Info ] <Application: :Application> number of logical cores = 7
[Info ] <Application: :Application> locale = QLocale(English, Default, UnitedStates)
[Info ] <Application: :Application> install dir = “C:/Program Files/Shotcut”
[Info ] <Application: :Application> device pixel ratio = 1
[Debug ] <ShotcutSettings: :log> language “en_US”
[Debug ] <ShotcutSettings: :log> deinterlacer “onefield”
[Debug ] <ShotcutSettings: :log> external monitor “”
[Debug ] <ShotcutSettings: :log> GPU processing false
[Debug ] <ShotcutSettings: :log> interpolation “bilinear”
[Debug ] <ShotcutSettings: :log> video mode “”
[Debug ] <ShotcutSettings: :log> realtime true
[Debug ] <ShotcutSettings: :log> audio channels 2
[Debug ] <ShotcutSettings: :log> display method 16
[Debug ] <MainWindow: :changeTheme> begin
[Debug ] <MainWindow: :changeTheme> end
[Debug ] <MainWindow: :MainWindow> begin
[Debug ] <Mlt::Controller: :Controller> begin

By the way in between the two : : there is no gap just had to do it so it wont think its a link

See the suggestion concerning a registry change in the post here:

But what am i supposed to do in the registry?

The post I pointed to has a response from the developer of shotcut which says:

Shotcut does not work on every computer. Sorry, but I do not know why it is crashing from the logs you provided. The only thing I can suggest is to change the Shotcut “opengl” key in the registry to 0 using the info provide on our Configuration Keys page.

So use the windows “regedit” utility and using it navigate to: key HKEY_CURRENT_USER\Software\Meltytech\Shotcut.

Then edit the key “opengl” to change its parameter to the value “0”.

There is no openGL key? heres a screenshot

I apologize if im making you inpatient. im very new to this

Did you download Shotcut from here?
What Operating System do you have?
What are your computer specifications?
Have you tried turning off all anti-virus/malware software?

Windows 10 Home
CPU I7-8700K, GPU MSI GTX 1080, 16 GB RAM, 3TB HDD
I have added all accosiated files to the exclusion folder but it still doesnt work

My suggestion would be to download Shotcut from the link that Hudson555x has given and re-install making sure to tick the option to remove the Shotcut keys from the registry.

I have done the 2 second thing with reseting keys from the registry
but ill try again

Nope it does not work

I’m sorry, I have no other suggestions. I’ve installed it on 5 Windows 10 systems (3 desktops, 1 old laptop and a Surface-Pro) and it works fine on all of them, I have no idea why your experience is different.

Does this mean you are running anti-virus/malware?


You may need to then contact the anti-virus/malware software company for support.

I’m not running any anti-virus/malware software and I’m using Windows 10 Home, and it works fine for me. Never had any installation fail.

Me neither but this happend recently
Anyone have any alternatives to shotcut?
anything similar to this?

This is not the place for discussion of alternatives to Shotcut. Elusien already gave you good information. Obviously, if the registry key does not exist, create it.

The only full solution to the core problem is to rewrite the program to not rely on OpenGL, but some things will need to be reinvented. Soon, we will upgrade our GUI library, which may help. In the longer term, the GUI library is making some changes to be less dependent on OpenGL by supporting various and new technologies. So, I am not taking the route to rewrite.

But there will always be some things that will be a problem and incompatibility because every computer is different - not necessarily hardware even though there is much diversity there - but particularly the software environment. This is where the open source model is supposed to help by letting people fix it when the main developers are unable to reproduce and submit a patch, but sadly that is not working for Shotcut even though I have released new SDKs with every new release over the past several years.

I suppose another thing you can try is upgrade your graphics driver, reinstall Windows, make a fresh install of Windows on a different hard drive, or try a Linux live USB.

In your log output, why does is say “number of logical cores = 7”?
That is very odd. According to this it should say 6 or 12. I think something may be wrong with your system.

I apologize, I will look into it

How do i create that registry and what will it contain. ive never created a registry before i am sorry if i am somewhat annoying you, your software is amazing, im just still disstressed about the whole thing