Shotcut now crashes with every click

I’ve used Shotcut for over a year. I’m running most recent update. Yesterday, I went to start a new video file and after dragging the raw video to the playlist, every click caused program to stop and said “NOT RESPONDING.” I’ve restarted multiple times. I tried opening older files of completed projects and every click created “NOT RESPONDING” message.

When I check the task manager it shows Shotcut is using VERY HIGH POWER USAGE, 35-40% CPU usage, approximately 40% Memory usage. Again never had this problem before having edited over 50 projects.

In my scan of text file log, I don’t recognize anything causing a crash.

Before we go deep in debugging, have you tries restarting your computer? If so, have you tried re-installing Shotcut?

1 Like

Yes to both. Restarted multiple times. Totally uninstalled Shotcut and downloaded anew. I was already running the most current version of the program. I’ve also opened multiple projects thinking possibly the new project was corrupt in some way but the program reacts the same way on any project I open.

#2: I started to send the logs but they were too long, too many characters, for the submission box. I’m glad to email that if it will help. Thanks for your assistance.

Don’t cut and paste the log, just add it as an upload (the bar with the up-arrow icon) to the response.

Yes, the application log would be good. Be sure to capture the log immediately after the crash without reopening Shotcut. If you open Shotcut, the log is overwritten.

This is the upload button:

One possibility is that another application is interfering with Shotcut. For example, we have seen some cases where Grammarly will cause problems. Also, antivirus programs sometimes interfere. You can try disabling some of those applications to see if it helps.

shotcut-log 22 07 13.txt (34.7 KB)
shotcut-log.txt (34.6 KB)

Uploaded. I’m not running Grammerly however I am running AVG Antivirus. Attached Task Manager screenshots with Shotcut OPEN and Closed.

Task Manager with Shotcut OPEN.

Task Manager with Shotcut CLOSED.

Thank you for uploading the log. Unfortunately, the log does not give any clues about a crash - except to show that things look normal leading up to the end of the log.

I know you said that you reinstalled Shotcut. Did you try checking the box to “Clear Registry” when you re-installed?

I don’t remember. I assume that would be a good troubleshooting step, correct?

Did you see the Task Manager screenshots? That help any at all? Attaching it again.

Yes. Please try to install again and check the option to clear the registry.

I do not see any helpful clues in the task manager screenshots. Things look normal.

I cleared the registry as suggested when I downloaded a new version of Shotcut. I opened several projects and clicked around with no issues. When I opened a NEW project and only dropped in 1 video file THEN clicked CRL S, dragged video to a new track, skipped through the track with no issues
UNTIL I moved the slide to enlarge (or extend) the track to better see the waveform. As soon as I started to move the slide (circled in RED on attachment) Shotcut IMMEDIATELY locked up as “Not Responding.” I waited and waited and it eventually became active. The next click triggered “Not Responding” again.

I tried the process several times with the same results. THOUGHTS?

Well, that is good progress.

We have found that the timeline performance can be poor for some users - while it works great for others.

There are some recent comments here:

Some things I would suggest to try:

Disable Audio Waveforms:
Timeline Hamburger Menu → Options → Show Audio Waveforms

Change Display Method (try the options in this menu):
Settings Menu → Display Method →

As a test, try turning off Antivirus (this is just a test, I do not recommend running without antivirus)

I’m running Win10 on a 64 bit machine. I’ll try turning off the antivirus and other suggestions late tomorrow. Thanks again for the help.

This is common problem when the timeline duration is long or very complex. It is not a crash, however.

There is no complexity to what I’m doing. I even tested it with the same results with only ONE video on my playlist and timeline. With every click, Shotcut freezes up and says “Not Responding.” I’ve tried numerous things that have been suggested but it is still doing it. I’ve uninstalled and reinstalled three times.

Since the logs aren’t helpful in this instance, there are two other options you could explore for testing purposes:

  1. Revert to a previous version.
  2. Install on a different (preferably new) user profile.

I know those aren’t final solutions, but they will at least take a step in trying to determine what’s going on.


Thanks. I’ll look into this.

This topic was automatically closed after 90 days. New replies are no longer allowed.