Timeline length errors

What is your operating system?
Windows 10

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?

Can you repeat the problem? If so, what are the steps?
New user here so sorry if this has been addressed or isn’t a bug at all.
I’m having a difficult time with using the timeline to edit the length of the output. It becomes extremely choppy and slow to respond when trying to shorten or increase the length of the clip, and will often shorten it drastically even when just holding the mouse still. This is all dependent on how far into the clip I’m zoomed in, but bugger me if I can figure out why or a work around.

1 Like

From time-to-time people report that the timeline performance is not good on their computer.

A couple of things to try to see if there is any improvement:

Disable Audio Waveforms:
Timeline Hamburger Menu → Options → Show Audio Waveforms

Change Display Method (try the options in this menu):
Settings Menu → Display Method →