Shotcut "Behaves" Like working in 1080p even when working with 720p Footage

Hello There,
I run a small Gaming channel here


And use ShotCut to edit gaming videos.
I have come across a peculiar problem with Shotcut. And this did not change with different Software versions or laptops or Video footages. It Happens only sometimes.

Basically, what happens is when sometimes I am working with a 720p video, the Shotcut “thinks” the canvas is in 1080p. Please note that I do not have any 1080p external content loaded in timeline or playlist. There is only 1 video which is 720p. Rest are Open Other> Transparent canvas to add text overlays on th video. To Further explain, Please check-

  1. Export Frame Magically happens in 1080p
  2. Look at the size and position of Text Box. It needs 1687 pixels to cover most of the Canvass. Stretching it to full canvas indeed needs 1920x1080
  3. Size 36 font is looking so small. Usually 28 Size looks that way on 720p Canvas.
  4. Text Box Offset (Position) needed here was 220. On a 720p video that should actually be 140 pixels for this size.

System Specs-
CPU- AMD Ryzen 2400G
Ram- 16 GB DDR4
GPU- Integrated VEGA 11
Windows 10-x64
Recording software-
AMD Re-Live

Do let me know if you need any more details.

What version of Shotcut are you using?

You say it “thinks” it’s in 1080p. What does the resolution and aspect ratio say in the Export menu?

Are you setting up the video mode manually before starting the project? If so, where are you setting the video mode?

1 Like


Adding Proof.

There is no proof of a bug here. I think you are not using Video Mode correctly.

In particular read about Automatic. Even the text in the middle on the screen upon initial startup explains Automatic. If you want more predictability, then set Video Mode to something other than Automatic.

19.12.31

Regular 720p. As Input.

No. Atleast not Manually.
What I do is Start shotcut>New>Save (As MLT).
Then I Open the video footage in my computer, and drag it into Preview, And then to timeline.

The Proof is there in 3rd post, a screenshot that shows messed up properties. The post was uploaded yesterday itself but some Moderation hold did now allow it to show. I also lost my reply button.

I went through it.
What puzzles me is, Why does it behave that way SOMETIMES even though my project workflow is exactly the same for every video I work with. My first file I open in Shotcut is always the 720p Footage.

When you first start Shotcut, you’ll get this dialog box. Unless you’ve changed your Video Mode, it’s probably on “Automatic”, which you should read the underlying text. shotcut_2020-01-12_22-23-19

To change it, just click where it says “Automatic” and select a video mode you wish to have your project in. You can even create custom video modes not currently listed.
shotcut_2020-01-12_22-22-53

When you Export (default), it pulls the resolution/fps settings from your Video Mode. In this last example, the video mode is set to 1080p, 60fps. So for the next million projects I do will always have the 1080p, 60fps setting, even at export default.

1 Like

Hudson555x, Thanks
I will pay more attention here. I have 2 videos to edit today. Will keep you updated.
However, My Export file always says 720p, which is the Source footage resolution, which suggests Video mode was set to automatic and hence was pulled from source footage file. Hence it raises a doubt that this might be a bug.

I am also currently exporting the said mysterious file and posting it to youtube. Will report any Anomalies here.
Thanks for the input.

I just checked after editing 5 videos. The video mode is set to automatic. So far I haven’t Encountered the bug again.Will report back if I find something Repeatable.