Reverse and Extract sub-clip in 18.12.23 not working


#1

I have tried many times and many versions of shotcut to reverse and extract sub-clips. It does not work.

For reverse, all it does is say that the job is complete, but when I click open, it says "failed to open “…”. I go and right click and select open in folder, and all it does is open windows explorer and highlight the My Documents folder. I even opened the same folder in a separate window and rapidly hit the refresh button to see what comes up. It creates a random file with the same name for a tenth of a second, then deletes it.

For the extract, it will show the Documents folder as said above, and fail to open as well, I also go into the folder I specified it to save it to, and all I get is an audio file that is labeled as an “MP4” file. It does say the job is complete.


#2

This happened to me once.
The solution that worked is here


#3

Reversing a clip

Select a clip, go to Properties. Click Reverse. Click OK.
shotcut_2018-12-29_16-42-57
Name your file (‘Reversed’ will already be there)
shotcut_2018-12-29_16-43-33

This will appear in Jobs. Wait for it to start & finish!
shotcut_2018-12-29_16-43-44

Once done it will play automatically in the Source viewer.

I’ve got an i7-7700k (4.2GHz), 32gb ram, water cooled CPU, and for a 2 second clip, it took 30 seconds for it to process. The source file is 1920x1080, 3.4k bitrate, 60fps.

If you have a slower computer and/or a longer clip, more complex video this may take minutes possibly even hours for this to fully process depending upon your computer’s hardware and software environment.


#4

Works for me and do not know how to reproduce the bug.