Problem, with Exporting movie

Windows 10 home x64
Shotcut 21.06.29

after yousing shotcut for some time i tried to export my edited video. First try was succesful, i used H.264 Baseline Profile and decrese resolution tu hdReady (1280x720) and 30 frames per second.

i used 6 or more diffrent videos from diffrent cameras, phones etc. After adding video to my playlist i didnt agree to “change it” when program asked me to.
meanwile after some work i did extract movie and it was great. but… lately after expanding my creativity i slashed my project in half and added a lot od filters (wideo and audio) to the remaining half of my project. I tried to extract but it failed so here is my list of things i did:
-i reinstaled shotcut, and restart computer,
-also i deinstaled autocad and throu deinstalation it asked me to close the shot cut (but i didnt do it) so i had to restart computer (instruction from autocad)

  • i changed the location of the extracted file to another partition of the disk.
    -after looking at files: AUTHORS COPING readme i downloaded plugins from your website and cope paste it in the Shotcut install folder .
    -i changed the pre settings for extraction of the video, and trieded the full hdwith 60 frames

evenso it didnt extrac

so please help me…

here is the comand text from begining of task list:

plugin_mgr_get_object_file_plugins: error opening shared object file ‘C:\Program Files\Shotcut\lib\ladspa/AUTHORS’: “C:\Program Files\Shotcut\lib\ladspa\AUTHORS”: Nie mo�na odnale�� okre�lonego modu�u.

plugin_mgr_get_object_file_plugins: error opening shared object file ‘C:\Program Files\Shotcut\lib\ladspa/COPYING’: “C:\Program Files\Shotcut\lib\ladspa\COPYING”: Nie mo�na odnale�� okre�lonego modu�u.

plugin_mgr_get_object_file_plugins: error opening shared object file ‘C:\Program Files\Shotcut\lib\ladspa/readme.txt’: “C:\Program Files\Shotcut\lib\ladspa\readme.txt”:

[producer avformat] audio: total_streams 1 max_stream 1 total_channels 1 max_channels 1

[AVIOContext @ 0000026448243f40] Statistics: 58154441 bytes read, 608 seeks

for ALL help i will be apreciated

Hve you tried Recommended Stable Version: 21.03.21? I too use Autocad daily but never face a problem with Shotcut.

1 Like

Can you clarify this? Do you mean that you tried to export it? If your export fails, right click on the failed job and save the log file. Upload the log file to this forum so that we can see it.

I do not understand what Autocad has to do with Shotcut. Does Autocad create or use video files?

1 Like

I tried to replicate with Autocad 2018. Maybe Shotcut and Autocad sharing a same .DLL or file. Uninstall Autocad but nothing seems to be linked to Shotcut. Then i reinstall Autocad and uninstall Shotcut, again no files pointing to Autocad. Don’t know what @kajtus problem with Autocad.

Oh man…i forget to backup my Autocad setting…oh well.

1 Like

I wil try this version today.
About autocad:
Videos used for this project they weigh 60gb
I had them in folder on disk C, on that disk Shotcut is installed, but before second extraction of video I got message from Shotcut that there is small amount of space on my disk (20gb) so I tried anyway. It failed (same problem, task Logs are the same) so I started doing some clean up on my computer.
Few games were uninstalled, and autocad.
but… Only autocad through deinstalation asked me to shutdown application: Shotcut and explorer (windows) OR “you will have to restart your computer”
I didn’t close Shotcut but I restarted computer.

I pasted few first lines of log files (to much letters to put in here). Today I will put it on WeTransfer as a file and place link here.
About autocad: because of the timeline my first reply was to person with nick Sheep. (Above or below)
To simplifying:
Sometimes programs through installation or deinstalation are asking you to close other working programs: my example, I had open Shotcut while deinstaling autocad.

When viewing a log file, there is a save function. Saves the log to a text file.
Just drag that text file into a reply window here.

1 Like

here is saved log file from todays failed export.
log.txt (22.9 KB)

i tried version 21.03.21

but before:
i tried one more time and it faild so i added the log on this subject (reply to Brian)
i uninstaled the one i had (newest) and i even clean the registry (uninstal program had that option)
after restart i instaled the “old one”
and after opening my project program asked me to “repair” my saved project. i agreed and tried again but one more time it failed.
log from older program is in this post
log version 21.3.21.txt (25.9 KB)

i tried with old shotcut but without repair and it failed,
because it is my second export, and first one was form of a program test and it worked.
i dont know how to export from one “TRACK” or even selected part of my main “TRACK” so before every export i saved the “working project” and deleted remaining tracks and cuted videos to only 2 traks: one is ful of cuted and puted together movies and other is audio of the same lenght as the videoproject.

so i have few saved differnt project but the 21.3.21 version is seeing them as “damaged” (joker leto :D)

to sum up: new version is failing and older stabel version is also failing. i even could open one file from export and it had only few second and the other one had “no time” and i couldnt fast forrword it (damaged)

btw i had k lite mega codecpack (newest) i intaled it beor my journey with shotcut,

thaks to all of you for quick response. you guys are awsome

Maybe @brian can explain better.

Can you tell us what export preset you use?

1 Like

I used h.264 baseline profile
But decrease the resolution to hd ready 1280x720 and only 30 fps
But I tried with only the h.264 baseline without touching the “advenced” options.

And once I tried with “*.Avi” but I don’t remember which one was it.

From the log

avfilter.random is the Nervous filter in Shotcut. You can try disabling it.

You should try to avoid changing Export > Video > Resolution and frame rate (which is in Export’s advanced mode BTW), and use Settings > Video Mode instead. Maybe changing the export resolution and frame rate combined with something else in the project

See also other things in #FAQ.

1 Like

Damn, I will try and turn off nervous effect
But I think you are right with PREloading videos to playlist. Because of small amount of space on pc I didn’t allow Shotcut to adjust and prepare videos.

-because of editing videos that was not prepared by Shotcut now I’m “fukd”. If the systematic “turning off” of filters won’t help, is there anything I can do to save some of my work?
I learned my lesson :blush:

If without filters I could export movie I could export it, and again put it in Shotcut, cut it and add filters. And of course I will allow Shotcut to prepare videos before work.

I will try all of “the above” tomorrow and write here the results.
Again thank you all for help. I will donate/buy pro :smiley:

So, after few attempts I can say that it turned out pretty good. Here is list of thing I did to successfully export video witch problems previously stated:

  1. when I add video to playlist I should let Shotcut prepare it. All of them
  2. in version 21.06.29 there is filter called: audio spectrum visualisation. And with not prepared videos its not working. In stable version 21.3.21 this filter has less functions.
    3)same thing is with nervous filter (not working with not prepared videos)
  3. I used stable version 21.3.21 and default settings for exporting video
  4. I disconnected monitor from my laptop, so there was less work for computer.(graphic card, )
    6)I puted airplane mode (WiFi out) and turned of antivirus. This gave me some power (CPU, ram, disk) to distribute to Shotcut.
  5. I have laptop with i5 CPU, 12gb ram and hdd 1tb of space. It’s not much but after few attempts it worked.

Thanks to you guys I could do it. It took some time and attempts but it worked.

I turner all filters off and saved new file, and I started adding filters one by one to see which one was the problem. Turns out audio spectrum visualisation from early version was not working with my not prepared videos. I added same filter from version 21.3.21 and finally it worked.

Once again thank you for your fast replies.
Sheep , brian , Hudson555x , shotcut

1 Like

This topic was automatically closed after 89 days. New replies are no longer allowed.