Popping sound and visual glitches in exported videos

I’ve exported this video ten times now, each with different export settings and file formats. The stock “WEBM” export settings work best so far, but there’s still this loud popping sound at one point that I can’t get rid of. It’s always the same spot, and isn’t present in the original file or in the Shotcut timeline. So I tried other file types, but all they do is add to the problem, by making everything blurry or creating these blocks of white noise when images move. I’m not too concerned with fixing those since the WEBM export doesn’t create them, but I do need to fix this popping sound.

Shotcut ver. 19.12.31

Here are my PC specs:
Windows 10
Intel® Core™ i7-7700 CPU @ 3.60GHz 3.60 GHz
16.0 GB of RAM (15.9 GB usable)
64-bit Operating System, x64-based processor

I don’t know if this helps, but some time ago I had some popping/clicking noises in an exported file and found it was where I had joined 2 clips together, but didn’t have them exactly next to each other - there were one or two blank frames separating them. I got rid of the blank space and the audio problem was fixed.

No, the audio is all one solid piece.

My clicking happened when two video clips (not the audion clip) were not properly joined.

Do you have any (audio or video) filters that start/stop at the moment the popping happens?

Other than the popping, would it be a quiet spot in the exported video, if so you could try muting that particular spot then exporting, or even editing the exported video and muting that spot.

Sorry I can’t think of anything else to suggest.

Now that you mention it, the popping sounds do take place at the beginning or end of other clips on other tracks. The main audio is the narration, and is accompanied by muted footage that starts and stops frequently.

Edit: At this point, I’m thinking I might record the new audio directly from the editor using Audacity, then attach it to a muted export and re-render…

What is your Audio Channels set at? (Settings - Audio Channels)
What is your Video Mode? (Click on Master in the timeline, then Properties)
What are the Properties of the problem clips? (Click on one clip, then Properties)
What are the Audio Properties of the problem clips? (Click on the Audio Tab)
Do you have more than one audio track on the problem clips?
2020-01-26_11-32-57
shotcut_2020-01-26_11-29-16
What is your Display Method? (Settings - Display Method)?

Audio Channels: 2 (Stereo)
Video Mode: 1920x1080, 16:9, 30fps, Progressive, ITU-R BT.709

The biggest popping sound occurs during this section, which has five clips:
Vid1: Image with Size & Position filter.
Vid2: Image with Size & Position filter.
Aud1: Narration track with no filters.
Aud2: Sound effect with lowered volume.
Aud3: BGM with no filters, but the entire track has lowered volume.
The popping occurs as soon as the sound effect is done or nearly done.

Display method: DirectX (ANGLE)

How exactly are you muting? If you are doing a hard cut, then this is not unexpected. Are you ramping the volume down and then back up using keyframes?
You could also be experiencing clipping. When the sound waves of multiple tracks add up, they can exceed the numerical limit. Check your levels around the problem point.

I just use the Mute filter. I typically only use keyframes for moving images and fading.
And I’ve tried reducing the volumes of everything surrounding the pop; even clipping them out entirely. When I get home, I’ll upload recordings of what’s happening.

I guess you are trimming the filter to define the start and end of it. I am not going to change anything to automatically adjust surrounding samples to transition to and from mute. I recommend you keyframe the Gain/Volume filter instead and only use Mute for muting an entire clip.

I’m not sure exactly what you mean, but I don’t think that’s what I’m doing. If I want a section of a video clip muted, I usually just split the clip (with the S key), then apply the mute filter to the split-off section.

Anyway, here are the examples I promised:


That is similar to filter trimming but more crude. Split alone might be the cause an audio artifact depending on the audio format in your clip. Audio codecs AAC or MP3 are difficult and problematic in this regard. You should avoid splitting except to make edits.

I don’t really have a choice in the matter. My manner of gathering footage means having dozens of video files worth of gameplay that I crop at the source, import into the timeline, trim, then mute. Gameplay footage plays (silently) while I talk over it. But no gameplay footage is at the point of the popping sound (the purple circle).

You do have a choice in what technique you use. I did not say you cannot mute portions of the video. I am trying to help you with your problem by explaining why your current technique is likely the cause and a different way to do it. I am not available to help you any further on this matter.

Well, thank you for your time. I do appreciate it.

For anyone still interested, I do have an update on the nature of this bug. While it consistently did not play in the editor (see above video), it DOES play in the editor if the timeline is zoomed out enough. It might just have something to do my CPU usage.

Either way, I did manage to fix the popping by re-recording the popping sections in the editor (zoomed in so they don’t pop), then re-attaching them to muted sections of the export. The video is complete.

Now if only my other topic about the warping playback bar would get a reply…