Please test the version 21.06 RELEASE CANDIDATE!


The main purpose of the 21.06 release is to continue to address the new problems that resulted from the major changes in v21.05.01.

Rules of Participation (Important)

  • This release candidate will not be a general bug-fixing period. Only highly critical bugs and regressions since version v20.05.01 will be addressed.
  • Do not report about old existing bugs that have not been indicated as fixed by this version.
  • The release is expected by the end of June.
  • Provide all feedback as a reply within this thread or as a GitHub Issue.
    If using a GitHub issue, make sure you indicate the version.


Get the release candidate from this GitHub page that also includes the list of fixes, changes, and additions.

Thank You For Your Help!

1 Like

Shotcut is working fine with all of the filters, but one problem I noticed is a crash or a sudden closing of an app without a crash prompt after importing a clip in between.

Basically, Shotcut was using 400MB of my ram on a 32GB machine without any app in the background, on a 2792x1080 video which was unedited and I just imported it after some 10mins of working on the previous video on the same project, in simple words I added the video in between or after working on the first video in the same project and while I hovered on the button right to the ripple toggle and it just stopped working suddenly without any not responding prompt, And it is not a my ram issue as I tested my ram stability on the link that brian provided me on my last topic and the ram was stable. I re-opened the shortcut and did the same thing, and it again just did the same. The video was split and it had a size, position, and rotate filter with size going from 100% to 106.3% on a 10.5300006 seconds clip. The keyframe for 100% was set on the 3rd second and the 106.3% keyframe was set on the 8th second.

I don’t know exactly what caused it to crash, the filter or hovering over the button but when I reproduced it, I also opened chrome at the same time with 30 tabs open taking 3.2GB of my ram but chrome was totally fine and smooth when shotcut was closing.

Edit:- I again reproduced the same thing and figured out that whenever I add a clip in between or after working on the project for : Time (Time is not fixed as it works smoothly for days if we do not add a clip in between or after to the playlist) it crashes after some 50-60secs.

This, bellow, is not really a bug. Just a difference from the previous version. I don’t see mention of it in the fix/changes list.

In older versions, after splitting a clip in the timeline, the clip to the right automatically get selected.
In 21.06, no clip is selected after the split.

Version 20.05

Version 20.06

Whether this change is intentional or not, as far as I’m concerned, it’s an improvement. It used to take, say, half a second after the click for the clip to be cut, now it’s almost instantaneous.

Aside from that, even if I just started to test this new release, I find that it runs smoothly. I made a couple of exports from different projects, and they seem to be faster. In 21.05.18, I often experienced having to wait between 30 seconds to 60 seconds before an export would start, all the projects I exported with 21.06 started almost immediately.

Oh! and thanks for the Apply button in Properties. Works perfectly.


I just noticed it, but after checking, it’s also present in 21.05.18. I report it in case no one did before.

There is no scroll bar in the Time Remap parameters box


I was not talking about splitting causes the problem, It was SPR, Hovering over the button and adding a clip in between.

But the actual reason I figured out later was adding the clip in between.

I was not replying to you…
My post is a different subject.

Ok, but the way you said

I thought that you are replying to me.

Great !
No problems for the moment…
( New Version 21.05.01 doesnt work for me )

1 Like

Shotcut 21.06.15 seems to be working pretty well for me (and an issue with the prior version where it froze up and required a reboot of the application– which it did pretty consistently – doesn’t seem to be happening).

I use Shotcut multiple times a week so I’ll let you know if any weirdness turns up.

1 Like

Is this a bug?

As I mentioned earlier, I haven’t had an issues with Shotcut 21.06, though I noticed this behavior (which the screenshot I’ve included should help illustrate.

Notice that the lowest pane (level?) hasn’t been turned off, yet the image it’s supposed to show isn’t visible.

I have tried replacing it, but the particular file doesn’t seem to appear. As I said, I don’t know if this is a bug per se, though it is a behavior I don’t understand.

The same image has worked fine in other files (in Shotcut) so I don’t think this is a case of corruption of the particular file or a broken linkage.

I regret to report that the analysis of the stabilizing filter is still giving me problems.
I realized that it is not necessary to do several consecutive analyses. Just raise the precision set to 9 (or above) and the problem appears (and in this version Shotcut closes as well - something that didn’t happen in the previous stable version).

In the screenshot, the progress of the analysis is at 99%.
On the system monitor, it indicates that the processes Shotcut and melt 7 are running and waiting (alternately) until finally, Shotcut shuts down.
Even after Shotcut shuts down, melt 7 is still running for a while longer.

I normally use Snap versions. To test this release candidate I run shotcut-linux-x86_64-210615.AppImage

Operating System: Ubuntu Studio 20.10
KDE Plasma Version: 5.19.5
KDE Frameworks Version: 5.74.0
Qt Version: 5.14.2
Kernel Version: 5.8.0-55-lowlatency
OS Type: 64-bit
Processors: 4 × Intel® Core™ i5-7400 CPU @ 3.00GHz
Memory: 15.6 GiB of RAM
Graphics Processor: GeForce GTX 1060 3GB/PCIe/SSE2

I can’t find Time Remap in my Shotcut Linux version (AppImage)

It is there and working. You cannot add Time Remap to the clips in a project created (or repaired) with a version older than 21.05.01. Or there could possibly be some situations where the filter is not showing due to a bug, but we need the steps because I do not know.

Yes, I am using projects created with versions prior to 25.05.01. I think the Snap installation only upgraded to the current stable version (21.03.21).
I will create a new project when I finish rendering my current work and comment here.
I got it. I created a new project and the filter appeared.

Dan and I both reproduced this. It tracks back to the latest version of the underlying stabilization library that Shotcut uses. The developers of that library have made a change that causes it to break for precision higher than 9. The Shotcut Windows build does not have this problem because it still uses an older version of the stabilize library.

We have a couple of options:

  1. Revert the linux version back to the older stabilize library. That would make Shotcut incompatible with projects created with past Shotcut version before November
  2. We could limit the precision parameter to be limited to 8 (or whatever the highest working version is)
  3. We could remove the precision parameter and always fix it to a default value that works.

Do you have an opinion of the importance of this precision parameter? Does it make a lot of difference? Or could there be a default value that works for everyone?

Most of the time (and this is recent with two projects of my home SD PAL recordings) I use the default settings of the stabilize filter and it works fine. I don’t have much experience with this and unfortunately, I started to use this filter on footage that is perhaps not the most suitable.
In my current project (fireworks over the sea), the sudden brightness produces a very jerky movement with the stabilize filter, so in several scenes, I was trying different settings and that’s why I found that behavior with the precision.
Finally, the camera shakiness was less annoying than the sudden movement generated by the stabilising filter.
I don’t know if I interpreted the stab filter documentation correctly, but I think it says that the default value is 15 (from a range between 1-15). :scream:
In my case, there was no appreciable difference that would make me decide that I need an analysis precision higher than 8 (but this is my case and I was using the filter with two SD PAL projects).

Jack Audio works in this RC version again! (It was broken previously, maybe nobody noticed :grinning_face_with_smiling_eyes: )

1 Like

I didn’t notice :scream:. That’s great. :star_struck:
Working for me.

I was wondering if there is a reason why different filters with keyframes, have different track heights.
I thought that perhaps filters with multiple keyframe values spread the height between them and filters with only one adjustable keyframe value might take up more height, however this doesn’t seem to be the case.
Some examples:
Small height

Normal height

The track height is set to its default value. Still there are these differences.
Additionally, filters whose keyframes are displayed on a reduced height track are those that do not include a range setting value to the left of the track and are also those that do not display lines between keyframes. Is this expected behaviour?