Markers Exporting Blank

I’m using 21.12.24. Just edited my post above.

Just updated and it unfortunately still doesn’t work.

Strange indeed, maybe others can try to see what results they get.

Did you select the “Remove the old program” (not sure on the exact wording) in the installer?

I did indeed! This is so strange.

Your duration isn’t one frame though

Windows 10
Shotcut v21.12.24

Works fine for me

I might need to try the good ol’ restart the entire system and see if it sticks.

Ah ok… didn’t realize it was just for 1 frame use.

It works fine for me then.

I’m on Windows 10 also. I tried it right now on v21.12.21 and it worked for me.

By the way, a new version was released a few days later (v21.12.24). You should go to the Download page on top and get it because a little more got added and fixed.

This is so odd. I opened up another file, and it works! It just refuses to work on this project.

If you go back to that project does it still not work again?

It still does not! I even created a new project with the same files, and it refuses to work with these files.

Would you be willing to share your MLT project file with either of the two devs @shotcut or @brian so that they can see what’s happening in that project that’s not letting you export the markers as chapters?

Yeah, sure! They’re just pretty big files, but I’m okay with that. Should I just post them in this thread or elsewhere?

You can send either of them a private message. Just click on one of their names on my post where I tagged them then click on the Message icon. The MLT project file might be enough. If they actually need the media you were working with it’d might be best to share it with them on a file storage site (like MEGA) if they are big files.

I can’t seem to send either of them a private message. It’s not on their profiles when I click their names.

You don’t see this?

I just got it now, I think it was because I was a just-created account, and I just had the restrictions taken off!

This is fixed for the next release.

The bug here is that the markers are not detected during the export process if the project contains transitions. As a work-around, you could delete all the transitions from your project before exporting the chapters - however, I am sure that is a very inconvenient workaround.