Great PC, Poor performance when only basic editing

Hey folks,
Shotcuts performance is nearly unusable for me when only basic editing one mp4 file, with no filters and nothing else running on my computer. very choppy and stutttery, playback is consistently laggy. Once I make a video, the exporting and final product seem fine.

This has to be a bug, right? I have audio scrubbing turned off…
Edit: Also, it is now crashing, for example, when I try to change the speed of a video clip.
PC:
i5 8600k
1060 ti
16gb ddr4
1tb m.2 SSD

There are certainly issues with Shotcut’s playback performance but it’s never been as bad for me as what you are describing. I think your PC is more of an issue than you realize.

What version number of Shocut are you using?

It was announced that this year is supposed to be the year when Shotcut’s performance is updated and improved. The first step was taken in the last released version 20.02.17 by debuting the Preview Scaling feature which does help with playback performance in regards to effects being applied. In case you are not aware here is the page to read about it and where to download: https://shotcut.org/blog/new-release-200217/

While the other steps in development are taken towards performance improvement, if you are on Windows then I highly encourage you to also use this proxy tool that was shared by @KKnBB in the meantime: https://forum.shotcut.org/t/shotcut-proxy-videos-auto-creation-auto-replace-tool-for-fast-smooth-editing/14519

1 Like

You did not state your Shotcut version or OS. In any case, please be aware that when you first add a clip to the timeline, it will be decoding the entire file in the background to generate audio levels for the waveform and thumbnails. This slows down the user experience for a little while. My Windows 10 PC can play (i.e. no filters in Source player) a 4K 60 fps H.264 MP4 without dropping frames in Shotcut. It is also known that the Timeline performance is not great when it is very long or has many tracks with clips on most of them most of the time (dense). You should also try the different options in Settings > Display Method, in particular OpenGL:

1 Like

MS windows 10 Pro, version 10.0.18363
Shotcut version 20.02.17, fresh from the shotcut website.

video length was about 1.5 hours, no other tracks or clips. Possible it was decoding in the background? If I leave it for a while, or close it and reopen the next day, and it still happens, does that rule this out?

Had the video open for a good hour or so yesterday for it to decode. Reopened today, and tried to play it. Crashed immediately when playing back a clip I had tweaked to 0.7 speed.

You have set the speed of a 1,5 h clip to 0.7?
How much RAM?

snipped a short (4 second?) clip from the video file. I adjusted that little snippet to .7 speed.
16gb of ddr4 ram

And do you had a look at the used RAM?
Is meaning, yes, if you have (more or less) much work on the clips (like filter etc.), yes, Shotcut tends currently to stutter (depending also on the computer equipment (I know the difference between 2 cores / 4 threads and 6 cores / 12 threads)), but I never noticed it on a “clean” single clip.
And I tend to the meaning, that there is another reason…, and one reason can be, that a system can be in a SWAP mode, because of to little RAM. And even with a very<!> fast SSD like a M2, it will raise (more or less) heavy stutter.

Note that playing from the timeline is playing with all filters etc. on the fly. This may be less smooth as from a finished video file.

I also have the experience that sometimes changed speed can cause a crash when played from the timeline. Well, change the speed and do not play that part.

You could check if your graphics driver is up to date.
If you are savvy enough, download and run a Linux e.g. Mint live USB, download the Shotcut app image, make it executable by right clicking and going to tab permissions. Then run it and load your video. If it runs better your problem could be with Windows, if it still runs bad, it could be a hardware problem.

It is known that performance is lower with long videos. You can disable audio waveforms in the Timeline menu to make it faster. It will still generate audio levels in the background, however, to facilitate displaying audio waveforms when you want them. If you know you not need that much video, you can trim it in Source player before adding to the timeline.