Exported videos have a wide black border

I was using shotcut to assemble some video and audio from separate sources and when I exported the video file to an MP4 the resulting video had a huge black border around it.

The original data was 40 000 separate frames (1920 x 1920 resolution), which I have assembled to a source MP4 without audio by using ffmpeg.
Then I have used shotcut to assemble two such video segments and two audio segments to create an output mp4 which I create at 1920 x 1920 and 1200 x 1200. When I play back the produced MP4 it has created it as a rectangle 1920 x 1080 and has shrunk the video itself to something much smaller in the middle of that.

Source video (post ffmpeg) - https://drive.google.com/file/d/1ZhSij_dz16VsQRRyJWxuUXgxQWtcnnNM/view?usp=sharing

Exported video (post shotcut) - https://drive.google.com/file/d/1TSizCOsOnljPaIprpJxTNaytmZFEauHe/view?usp=sharing

In the past I have done the entire process in ffmpeg, but I used shotcut as I thought it would be easier than trying to remember the 18000 or so command line parameters for ffmpeg.

If I export the file as 1920 x 1080 it fills the frame but how do I persuade shotcut to do this with a square export?

In the export phase I have explicitly set the resolution to 1920 x 1920 (or 1200 x 1200) with an aspect ratio of 16 x 16 and frame rate of 25 fps but it still mangles the output. Normally if I use shot cut I am in a 16 x 9 frame format through and it works. But how do I persuade shotcut to use a square frame?

Set your Video Mode before starting your project. You still may be able to change it, but you may need to adjust filter settings after a project has been started.

Settings - Video Mode - Non-Broadcast - Square 30fps or 60fps (Presets)

Since you are exporting with 25 FPS, you can make a Custom Video Mode.
Settings - Video Mode - Custom - Add

Export settings will match Video Mode settings.
Default preset

Also make sure you don’t have an accidental filter on the Output track.
The filter symbol looks like a funnel.

1 Like

Shotcut includes square video modes in the Non-broadcast submenu.

This topic was automatically closed after 90 days. New replies are no longer allowed.