Export issue with 21.05.01 version and Time Remap

Hello everyone,
I’ve not found a similar issue so I’m opening a new one.
I tried the new Time Remap filter (great job guys !), but the resulting exported file has some white flickering (or frame, really I dont know). If I remove Time Remap filter no problems.
I’m using also Saturation filter.
I’m using Shortcut (64b) in Win10 (64b).
The source file is 4K resolution (from DJI Mini 2); the issue is in both 4K or 1080p export format.
Export format is is a derivative of the Youtube profile.
In this moment I have some connectivity problem (low bandwith); when will be solved I’ll supply the exported file and the related project.
What other information can I provide?

Here the video with issues

The same without Time Remap filter

You need to convert this video file because it is not seeking well enough. Use Properties > Convert.

Please, explain me better. sorry but I don’t understand.

I explained it well enough. Try a little harder to follow.

Do a forum search for Convert to Edit-Friendly. The video file has something like variable frame rate or B-frames or who knows what that is preventing accurate seeks (looking up a frame by timestamp). Convert to Edit-Friendly removes those problems, then the project is built off that problem-free video file.


1 Like

@brian @Austin
Thank you for your support. I’m not a Shotcut expert and my english vocabulary is poor.
I did, I converted but the result is the same.
Proxy files are enabled by default, maybe …

Please try with the export defaults (Reset) instead of your custom.
Please try with parallel processing turned off.

A quick answer: as your suggestion, now It works (!!!) Later I will tell you which of the two setting generate the problem. Thx !

I made other tests. I summarize test done with converted input video :
custom export + parallel on = bad (we knew it)
no custom export + parallel off = good
custom export + parallel off= good
custom export + parallel on = bad (to be sure)

I made also tests with the original project where the input video is not-converted:
custom export + parallel on = bad (we knew it)
custom export + parallel off = good

I seems that the problem is not related to the input video (in fact Shotcut didn’t ask me to convert it when I imported It in playlist) but the parallel processing.

This makes perfect logical sense.

With a Constant Frame Rate (let’s use PAL 25 fps for example) the parallel threads are all looking at the same “truth” about time; a constant series of frames 40 ms apart.

But with Variable Frame Rate, perhaps three threads have seen that the “time truth” is “40 ms between frames”, but the fourth thread, having seen two frames 80 ms apart, is working from the “truth” of “there is 80 ms between frames”. So the algorithms become applied differently by the different threads, and the result would be as you have seen.

I do not think variable vs constant frame rate applies here because OP has converted the file - and converted files are always constant frame rate. But the premise of everything else you stated still stands. The filter relies on some cached state from the previous frame. If parallel threads work out of order, that could cause the cached state to be unexpected.

I will bookmark this to take a look later.

1 Like

Good catch.
I missed that.

On further thought…

Cached by whom from what source? If time is being remapped, are we seeing a discrepancy between cached-before-remap and cached-after-remap, or something like that?

My tests had me arrive at a different conclusion. For me Parallel Processing is only an issue when a specific kind of video is used and the Convert To Friendly option is not used on it. For me that’s videos from youtube.

@shotcut @brian

Here is a video demo I did using the Bruno Mars music video “Leave The Door Open” directly from the 4K youtube upload that we were using in the last thread for Time Remap here. The first clip and second clip are exactly the same in terms of the section that it is slowed down and both exports used Parallel Processing. But only the second video shows this flash at exactly 29sec19ms:

The difference is that the first export in the demo used a converted to edit friendly sub-clip whereas the second did not convert a sub-clip so it’s the youtube video as is allowed by Shotcut to use Time Remap on and it’s on that one that the above flash appears. Not in the demo but I can confirm is that if I turn Parallel Processing off then the second export without the converted to edit friendly sub-clip does not produce a flash in the clip.

If I understand the reports correctly, both @Ric_Developer and @DRM test results show that they get good results when parallel processing is turned off.

Perhaps there is yet another category of video file that should get the “Convert to Friendly” popup.
Or perhaps only if Time Remap is selected on it.

I got a good result with Parallel Processing when I converted the youtube video to edit friendly. That’s the first example in my demo video.

1 Like

Yes, I confirm: with or without Edit Friendly, with parallel processing turned off I got the good result.

I spent some time trying to reproduce this issue using the bruno mars clip. I have not been able to create the problem, but I do not know if I am creating your same scenario. Some questions:

  • When the problem occurs, what is the frequency? Is it once per video or multiple times?
  • If you export the same project twice, does the problem always occur at exactly the same time? Or is it random?
  • Can you share the xml file from an export that created the problem (right click on an export job and save)?