Export faliure relating to filter: how to progress?


I’m using Shotcut version 21.01.29 on Windows 10, on my first significant project.
I’m getting “exit code -1073741819” export failures. I’ve read the FAQ and other info about export bugs. There are multiple Gb of memory free, and turning parallel processing or hardware encoding off make no difference. Nor does it matter what format it is encoded to.

I’ve narrowed the problem down to a particular clip - which is a still image - and found that it only occurs when that clip has an animated Size/Position/Rotate filter applied. The same error occurs whether it’s an “automatic” animation using one of the filter’s presets, or a manual one using keyframes, designed to look the same as the automatic one.

The same error occurs if I’m exporting the entire timeline, or just that clip from source.

If I turn that filter off, all is fine. But I really want that animation to happen.

Can anybody suggest anything else I can try? Happy to provide info to help investigate.


Can you make a project that has only that problem image clip with filter animation? Does that fail too? If so, upload that protect along with the image dimensions. If not, you can replace the problem clip in the larger project with the exported one.

Thanks for the quick response!

That fails too. The mlt file is attached. The image is a colour PNG file of 1711x1038 pixels. If it would be helpful I can upload the PNG as well - it’s a screenshot of a public webpage, so not sensitive.

test.mlt (3.7 KB)

Oh, that’s interesting. I loaded the PNG into Photoshop and saved it again, without doing anything. Now it works.

So seems like it might have been a subtly bad image file. Probably one produced by the Windows 10 screen snip tool.

That should solve the problem for me. I’m happy to send both files your way if it would help further work… but I imagine that reading images is probably a library rather than something under your direct control?

Please upload the problematic PNG

Hmm, that is reported by the forum software with too small a file size - suspect it’s messed around with the image. I’ll try uploading a zip with it.

problem_image.zip (1.1 MB)

Thank you. I reproduced it. For me the problem goes away when re-save the PNG without an alpha channel. The alpha channel is not needed on this image, but of course that is not a real solution but simply a workaround for your case. I will work on it.

Thanks for taking the interest :slight_smile:

This is fixed for the next version 21.02

1 Like

This topic was automatically closed after 90 days. New replies are no longer allowed.