Error when first time start shotcut

installed 64 bit windows installer of shotgun on windows 7 prof.


get this long error msg window when starting : failed to create openGL context for format Qsurfaceformat(version 2.0, options qflag(), depthbuffersize 24, redbuffersize -1, greenbuffersize -1 … etc.

tried both the 64 bit installer & portable version. not clear what needs to be done to resolve this. can someone help ?

Shotcut does not run on every PC. Yours appears to be incompatible. The system requirements are in the FAQ

You might consider trying a different graphics card or a different PC altogether. Some people have found that updating their video card drivers can help.

Other examples for your reading:

Also @smehta if you’re like me, it’s possible that you’re running this on a laptop which comes with multiple graphics cards in it, like my Dell XPS which has both NVIDIA as well as Intel Integrated graphics. I’ll copy/paste some of my response from another post here, partially to help out but also so I can get up to the correct number of posts so I can actually upload BOTH images required to help folks workaround this problem.


The fix is pretty simple. Even though it’s selected as default, right click the Shotcut icon and then explicitly select the correct graphics processor (might require you to experiment). In my case, the weird thing was that even though Intel Integrated graphics was my global default, Windows wasn’t launching it on that card. To fix that, go into the same menu as last time but click “Change default graphics processor…” and set it up in the next window that comes up. Here’s a screenshot (unfortunately as a new user, I’m banned from two images in a post):

This is not the correct use of this forum, to spam posts to circumvent spam settings.

It’s also poor forum etiquette.

Or just join both images in whatever image editor your have available to you?

No problem, sorry about that. I just deleted the other post. The initial post was the one that came up in google search results. Then, apparently according to the forum software, posting multiple images wasn’t allowed for new accounts.

Good idea, just didn’t think of it at the time since I wanted to have the images go with the flow of my explanation. No worries… just an unusual restriction that I’ve not seen before. It works fine with just the one image for now.