Crashing repeatetly when adding clips

Hello Community, hello Shotcut Support Specialists :slight_smile:

My Setup is: Mac Pro 2.1, ElCap 10.11.6, 8 Core 2.66 GHz, 32 GB RAM, ShotCut 18.03.06 (render-monster)
and iMac 7.1 24", dual 2,4 GHz, 6 GB RAM, same OS, same ShotCut (surf/rehearsal station)

Problem occures almost identically on both machines.

Shotcut is constantly crashing when I start new projects and later on editing or changing something, it mostly happens when adding new clips (.mp4 .avi .jpg .png) but also when dragging around in the timeline or starting a preview.

I avoided using GPU mode, but at the beginning, this worked and some projects still want to use it. So first question: how can i clean projects from requesting GPU mode?

Although the autosave option is quite clever and quick, so when i crash in a grown project, i can recover on the next start to almost the latest change, thumbs up for this! But repeating the needed import will crash the program again and again. Sometimes it helps to import something else, even if not needed, but getting another successful import opens the door for the WANTED import in many (not all of course) cases. So question two: where to get what kind of logs, how to inspect them to get onto the path of a solution? Where to send what parts of the log(s) to enable you helping on the issue?

Final but one question for now: do your have suggestions on Tweaking and finetuning Shotcut on ElCap and the Hardware/Disk setup being used? Currently, there is a System SSD (also holding the apps), another SSD Partition for TEMP Storage and a RAID0 array for User Home /Project Data.

Real final Question: I tend to install another render-monster setup with ubuntu-studio, maybe on mac hardware too, perhaps first test it in a VBOX environment. Is there some experience on this or recommendations about virtual render stations in general?

Thanks for reading this bunch of mess and I appreciate answers and comments. Kindly, SunDee

I’ve discovered that when the .mlt file has been saved with GPU Processing enabled, you can’t change it. And if you’re adding mlt files as clips with GPU Processing enabled, they crash for me every time I tried loading them.

RAID0 is used with 2 physical drives. From what I understand of RAID0 stripes the data across the 2 drives, so if you have a partition on drive, the other drive will have the partition as well. If one drive fails, you lose all of your data.

For me, I’m not running any RAID and I record to a SSD, and edit off a HDD without any problem. It doesn’t matter to me how long I wait for the render.

These two threads will help you remove and/or replace the GPU processing elements in your MLT file to get it to work again.

1 Like