How to disable GPU (switching BACK) in existing project

Hi All,
please anybody know, how to switch back to non GPU (experimental) processing mode?

I am worked on film where is GPU enabled. I am can´t swithc off, because when openning shotcut show message “project use the grafical processor effect… You want to enable it ? YES/NO”

When press NO, the project is not loaded, When pres YES, shotcut restart in GPU mode and the project can be loaded, but not be switching back.

I am compare the MLT files with GPU enabled/disabled and no see differences. It exist any other place, where the project information is saved ?

I am work on Linux Fedora Workstation 26.

Thank you for the advice… Jan

This might help you.

I had the same problem with GPU processing. Make sure and read the entire thread.

Dear Sauron,
I am know about this issue. Instead i am start project with GPU processing, i am can´t used TEXT filter.

The question is, how to switch back on existing GPU project… :(.


You need to edit the MLT file to be able to open it with GPU processing disabled. Open the file in a text or xml editor and follow the instructions in the quote posted below.

1 Like

Dear Sauron,

correct, thaks. All GPU filters was gone :). But solved my issue. Thanks a lot.
regards, Jan

Glad it solved your issue.:slight_smile:

You might want to mark it as a solution so others who might have this issue might benefit from this thread.

I tested one step further. If you remove elements with name “movit” you will loose transitions. I compared .mlt file from a project with and without GPU acceleration and noticed that “movit” properties may be replaced with non-GPU equivalents and the project will open and its content will be intact. At least it worked for my example.
See what I replaced, mind the xml comments:

<!-- properties of producer, I guess default -->
	<property name="movit.convert.width">1920</property>
    <property name="movit.convert.height">1080</property>
    <property name="movit.convert.format">2</property>
	<!-- may be removed -->
<!-- transition -->	
	<transition id="transition0" ...>
      <property name="mlt_service">movit.luma_mix</property>
	<!-- change into -->  
      <property name="factory">loader</property>
      <property name="mlt_service">luma</property>
<!-- fade out -->	  
    <filter id=...>
      <property name="mlt_service">movit.opacity</property>
      <property name="shotcut:filter">fadeOutMovit</property>	 
	<!-- change into -->  
      <property name="mlt_service">brightness</property>
      <property name="shotcut:filter">fadeOutBrightness</property>	  
<!-- fade in -->	  
	  <property name="mlt_service">movit.opacity</property>
      <property name="shotcut:filter">fadeInMovit</property>
	<!-- change into -->  
	  <property name="mlt_service">brightness</property>
      <property name="shotcut:filter">fadeInBrightness</property>  
<!-- seems that fadeIn/Out for gpu variant uses "opacity" property, and "level" property otherwise, but it worked without this change too -->	  
	  <property name="opacity">0~=1; 71=0</property>
	  <property name="level">0=0; 247=1</property>

I hope it helps someone :slight_smile:

1 Like

This is an excellent solution.:smile::+1:

I would like, if SC could change the options in the mlt by itself, or would offer an option to import / export between GPU and non-GPU.

bye, Ralf

Garbage program with broken settings… Congrats you’ve officially convinced me to pay for software.