Can't seem to export a file correctly

So the story behind this is… I imported a .M2TS file (so AVCHD) into Shotcut, it’s a Blu-Ray file with 1 minute of content. I can’t seem to export it correctly however because when i do, it’s only 3.83MB and a minute long black screen with no audio.

I exported it at the correct framerate (23.976024) right aspect ratio (16:9) an MP4 format, libx264 codec, Quality based VBR 60%, 120 GOP, B frames 3, AAC Average Bitrate 512kbps, 48000hz and audio in 5.1 surround sound and i left the “Other” part alone. I haven’t mentioned resolution, which is 3840x2160 (But only because i plan uploading said file to Youtube, uploading 1080p content makes the video 8mbps, while higher resolutions have higher bitrates) I even tried 1920x1080 and it didn’t work regardless.

Anybody have an explanation or idea why this is happening?

On the export did you tick “Use Hardware Encoding”? If so try again without this selected.

I didn’t export with “Use Hardware Encoding” selected.

The file might have copy protection.
https://en.wikipedia.org/wiki/.m2ts
2020-07-29_12-45-14

Interesting, though the file was already ripped and in my Desktop. But… i did manage to import the file into Shotcut to begin with however, so does the copy protection not stop that? Most importantly, how do i fix the issue? (Likely by decrypting i guess)

If you can see the video in Shotcut it is not copy-protected.
Did you try to play the exported result in Shotcut?
After the export job completes, right-click and view the log.
Try not changing export settings and using the defaults.

Okay so i redid everything from scratch. Sorry for the late response. So i figured the issue is the resolution. I used the default settings. When i export in 1080p, it works just fine, both video and audio work properly. The only thing i did with the other export is increase the resolution to 3840x2160 and the video just doesn’t work. It is 1 minute, but it’s actually a still frame of the very first frame of the video that goes on for a minute. Audio on the other hand works just fine. Exporting in 4k seems to be kinda odd because i also tried 1440p and that worked just fine.

What are the specifications for your system The minimum requirements for 4K are:

CPU: x86-64 Intel or AMD; at least 4 cores for 4K.
RAM: At least 16 GB for 4K.