Can I use "Size and Position" filter without blurry effect?

I often use “Size and Position” filter to positioning and scaling my image on my video project.
I found some unexpected blur effect when I applied the “Size and Position” filter.

When “Size and Position” filter is applied, there is too much anti-aliasing effect on the borders in the image, it’s more like strong blur effect than anti-alias. Moreover It sometimes introduces noisy colors on the borders so its very annoying. (There should NOT be grayish color on the borders of the image when resized!)

Please see the images on my link below. (This forum restrict me uploading just one image, so I uploaded images on my personal blog.)

Image comparsion by filter on/off

I can avoid this issue by preparing the images that fits to size of the video so that I do not use “Size and Position” filter. It is very inefficient and time consuming job.

So please help me find the way to avoid this blurry effect!


  • Shotcut latest version (18.05.08)
  • Tried on both Mac 10.13.3 and Ubuntu 16.04. (same result)

Thank you.

That’s just an overlay image guide for you. Click on the V2 header anywhere, around the symbols, it will take off that overlay. If you leave it on, it will not show up in your video.

Your image showed up just fine. You can just drag the image into the window.

Of course I know that the overlay is the guide for resize and move.

Please see the border of content, not the bounding rectangle.

I wasn’t sure what you were referring to, as the overlay is more visible than the blurring.
Make sure you maintain the correct aspect ratio and you are not going beyond each graphic’s resolution.

Let me explain the details.

This image below is before the “Size and Position” filter applied

  • Video resolution is 640x640
  • “G” shaped logo image’s resolution is 64x64
  • I imported this image into timeline and applied “Size and Position” filter (top: 556, left: 556 width: 64, height 64)

It’s perfectly same resolution of my original image resource.

However, it introduces some noisy gray color on content’s borders.

This is the filter applied version. Can you see the grayish border on the content?

If you are upscaling the whole video to the same standard size, I tend not to use size and position, unless I need the image to be some where directly on the screen.

Instead I use the video output to upscale the file.

If this is a static art file? If so might be better to adjust it in a program like Photoshop or GIMP. Then just use size and position to move it into place so it’s not doing any of the scaling.

Another option is to set up the art full in an art program to where you want it to be on screen save as a transparent PNG. Then add it as a transparent layer in shotcut as I did with this video, that way you won’t need to use size and position at all.

Thank you for the comments.

I experimented this but it also causes the same effect as soon as I applied “Size and Position” filter even if I don’t scale and move at all from default values.

This is the way I do it currently to avoid the situation, but it’s kinda annoying that I have to create all my static image resources with full video size outside Shotcut. (Because I have to insert many static image resources into my video.)

I think that there should be a way to achieve this within Shotcut.

Little bit of antialias or blur might be acceptable, however, the noisy color introduced on content border is deteriorating my video content when the background is light color. (can be noticed very well.)

1 Like

It’s might be the type of resizing Shotcut uses then, I agree it shouldn’t be happening, but resizing a smaller images most likely won’t give perfect results

Certainly an option to select methods such as, Bicubic, Bilnear or Nearest Neighbor for resizing would certainly help you out. Right now I don’t know how Shotcut actually does it scaling when you use size and position.

My little 64x64 pixel graphic I just made up: g64g64 properties

Filter applied with overlay turned on
g64 x1

Filter applied with overlay turned off
g64 x2

Original image 640x640

640 properties

Filter on, overlay on.

Filter on, overlay off.

Filter off.

It may be helpful to have a better resolution file to scale down with. When you turn the filter off, shotcut just displays the image as full screen.

@Riven [quote=“Riven, post:8, topic:5526”]
Another option is to set up the art full in an art program to where you want it to be on screen save as a transparent PNG. Then add it as a transparent layer in shotcut as I did with this video, that way you won’t need to use size and position at all.
Riven’s advice would be your best solution.

With @Riven’s transparent pixel advice. g64trans properties
No filters.

For in-app preview, it uses Settings > Interpolation. For export, it uses Export > Video > Interpolation.
Most definitely, the Size mode of the Size and Position filter should be “Fit” because that tells it not to upscale (it will only downscale to fit within the rectangle). And then perhaps Nearest Neighbor interpolation should be used.

I am trying to reproduce the problem with a 64x64 icon but struggling a bit as most of these icons have dark edges by design. If @YoungJae_Kwon can provide the G icon image, it will help.

Here’s my sample icon that caused the issues.


As I said earlier, this icon works okay when “Size and Position” filter is not applied. However, as soon as I applied the filter, it creates weird colors around the border of the content.

Thank you for the response!

In case it helps anyone figure this out – the Rotate filter appears to do the same thing (and leaves the clip the same size when initially applied, so it’s even easier to see).

The problem is that Size and Position (and Rotate) use a filter that composites against a transparent black background. The background color is blending with the values in the alpha channel of the PNG. If I change the code to use transparent white, then the problem goes away but only because I am using a white background in the Shotcut test project .This is deep in the engine, and I will see if I can fix it.

1 Like

Oh I see. Thank you for the clarification. I hope this issue fixed! It would save a lot of time for me.

Any good news? I’m waiting for your fix :smiley:

There were compositing fixes in v18.06 and 18.07 for this. Did you try either of those versions?