Annoying audio clicking


#1

how do you get rid off the annoying audio popping and clicking between scene changes?? i have tried muteing and i still get it!! i have the current version of shotcut but even the previous versions did the same… and have a respectable proceesor AMD a10 7870k and DGPU RX560 all running on WIn7 64


#2

?
Never had that happen in any version. Do you have an example to share?
What are the audio and video codecs use by your source files?


#3

By “scene change”, do you mean between one clip and another on the timeline? Audio popping/clicking can occur when putting two clips next to each other without any audio transition because the last sample of the first clip might be very different from the first sample of the second clip - which causes a pop. If this applies to you, try adding audio fade in/out filters to the clips. Or apply a transition:


#4

This might be more noticeable only when previewing in the UI and hardly noticeable if at all after Export. You did not specify.


#5

I had the same problem as well, In my case it is not a Shotcut problem but a camera problem (Canon SX280). But this is how I solved it.
Of every video cut a tiny piece off the first bit of the video, not much, just let us say 0.2 to 0.5 seconds or something like that. if needed you can use the audio fade in for 0.02 Seconds. No more clicking noises after that.


#6

sorry for late reply this applys to both in the gui and when expoted regarless weather i use fade in/out or not and even if the audio is muted . i just can fathom it out. i would like to continue using shotcut but this pain is really getting on my ocd nerves and i am seriously looking for alternative software. i have tried exporting via loseless still same result


#7

Just think about what you have said there…
And you still haven’t supplied an example.
People here love to help, but don’t appreciate their time wasted.


#8

who is wasting time? not me mate! I stated in the first post when the audio is muted it clicks between scene changes i get clicks… somebody else suggested try fade in/outs which i had done as a suggested even though i want muted audio. if your not going to help then fine but dont make me out to be the idotic one when you have not digested the thread.


#9

anyhow dont warry problem reoslved by putting the clips together


#10

I’m wondering where the popping comes from if you mute audio? That makes no sense.


#11

i muted the audio within the clip not the computer. it was popping between scenes like i stated weather it was muted or not like i stated when i opened the thread… anyhow like i said in last message it is sorted by eliminating the gap between clips


#12

Yes, OK. So perhaps you can see why not responding to mine or Brian’s posts which promptly tried to help in spite of very little information has in fact wasted time. Leaving it up to others to ‘guess’ and not returning for 3 weeks to your thread…
If you have other Shotcut issues you need helping with - be clear and provide as much information and as many details as possible. For example you didn’t even mention which version of Shotcut you were using or which operating system your computer uses. Also, where applicable samples are helpful to the developers as well as more experienced users.
Glad you’ve now sorted it.


#13

If the clicking still occurs even when adding a short fade to each clip, then you must be experiencing something that others do not experience. The problem could be something unique to the files you are using. Have you tried editing with files from a different camera/source? Would it be possible for you to post a minimal MLT project that reproduces the issue?


#14

i did provide the version which was the current version and i stated win7 64bit see at the start of the thread, not sure how clearer i could of been without giving you a copy of the video which am still working on. i didnt waste anytime and im sorry you feel that i did but anyhow lets draw a line under it and move forward.

i am quite happy with the general functionaitlity of the software and not attacking said software just needed a bit of a hand.

hopefully my latest video will be released on the 10th Feb and would gladly share it with you it is for an UK politcal action group that i am involved with called “Veterans Against Terrorsim” so contains some hard hitting stuff so you may not wish to see it.
as a note i do download videos from our accepted media man whome streams his footage direct to youtube and cut them up from there (once he has finished streaming)

anyhow many thanks yet again

quote=“mgm, post:1, topic:3798, full:true”]
how do you get rid off the annoying audio popping and clicking between scene changes?? i have tried muteing and i still get it!! i have the current version of shotcut but even the previous versions did the same… and have a respectable proceesor AMD a10 7870k and DGPU RX560 all running on WIn7 64
[/quote]


#15

i will try and recreate the problem if needed. so do i just send the MLT file? or do you need me to send the clips aswell?


#16

Would need the clips as well. Hopefully, you could recreate the issue with only a very short clip used twice in the project. But maybe you have to use two different clips? However you do it, it is best if you can provide the bare minimum to demonstrate the problem - that helps to narrow it down quickly.


#17

I got the annoying click/pop between some scenes too… I had the clips muted except for an audio track (I was making a music video). Also it was only in the intro when the audio was an accapella. I don’t notice it during the non-acapella parts.

I used Shotcut for months and never noticed it before. I also recently re-installed it so not sure if it is just to do with latest version or what.


#18

Hi, im having this same issue as well even after muting audio clips. I tried to put the clips together and add an audio track but the sound quality sounds like its underwater, how did you fix this?


#19

You haven’t provided any information for anyone to help you.
Posting just what you experience isn’t enough.
May want to read this post: Requesting Support
Glad to help when you provide needed information. :slight_smile: