After 20.10.31 update cannot run snap

What is your operating system?
Ubuntu 20.04 LTS

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
20.10.31 installed as a snap from Ubuntu Software

Can you repeat the problem? If so, what are the steps?
I’ve used Shotcut on my Ubuntu with no problems. Today, I wanted to open Shotcut as always and I couldn’t do this.

I used Shotcut on 30th Oct last time. I didn’t change anything on my OS. I suppose it is problem with the last update. Shotcut was updated throw snap, wasn’t?

When I try to run it from Terminal I got such a message:

Thanks for help. I need Shotcut for now. I have a project to finish.

UPDATE
I downloaded (shotcut-linux-x86_64-200927.txz) the previous version, I extracted and run it. It works like before. Well, it’s a serious bug of 20.10.31 version. The similar problem is seen on Windows 10 too. Look: Frei0r startup error

That is not the same problem!

I run Shotcut snap just fine in Ubuntu 20.04, but I can try in a virtual machine. You tested the portable archive of the previous version. Please try the portable of the latest version. I tested it in various virtual machines of linux distributions (but not the snap).

I downloaded the portable version 20.10.31 and it is the same error message during the launch.

I have Ubuntu 20.04 LTS, fresh installed over month ago, I thnik. I didn’t play with my OS. I have default apps, Shotuct, some additional language spell checkers not much more special. I used to work with Shotcut with no problems. I don’t remember from what version I stared but I’ve used it as a snap from Ubuntu Software. Today I couldn’t run it as described. The previous version works as before.

I can help to fix the problem. I can attach systems logs but you have to tell me what and how.

Thanks for testing that. I suspect a missing new dependency with the new version of Qt. It might be intentionally excluded per the AppImage exclusions list that we follow.
If you search “could not load the qt platform plugin xcb in even though it was found” on the web, you will find many results because this is such a common problem. It seems the most common is libxcb-xinerama0 or libxkbcommon-x11 is not installed. Can you check those?

I installed a virtual machine and reproduced the problem. Installing libxcb-xinerama0 fixed it for me. After that it starts, I can load the Count generator, and it successfully plays and exports. I will see if I can bundle or figure out why that dependency was not automatically bundled.

Yeah, the installation of libxcb-xinerama0 helps. Do I need install also libxkbcommon-x11?

Works the portable and snap version but there is something weird with resolution?
New version

Previous version

Thanks a lot :slight_smile:

PS. You tested on VMs, Ubuntu 20.04 too? Because it seams Ubuntu 20.04 does not have libxcb-xinerama0. You should added this lib to the package.

What is your operating system?
Ubuntu 20.04 LTS

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
20.10.31 installed as a snap from Ubuntu Software in a 64-bit machine.

Can you repeat the problem? If so, what are the steps?

Hello!

I’m passing through the same problem explained above by Marcin94 in my desktop. On the notebook shotcut is OK, but now I’m afraid to do the routine upgrade…

Only libxcb-xinerama0 is needed. This is fixed for the next version (including nightly build / snap edge channel).

The appearance change is due to the major Qt upgrade as mentioned release notes.

Thank you so much :smiley:

I’ve just finished my project using a snap version.

It’s great that the next version will include the missing dependency. It’s very important Shotcut to work out of box on major Linux distributions. Many new users could give up getting to know Shotcut and it’d be very sad because it’s very good software. I really like it :slight_smile:

It’s working here too now, thank you very much!

Congrats for the program, it’s very useful!

All the best!

PS. I’ve written before that shotcut was working normaly on my notebook, but I forgot to metion that it was running on ubuntu 18.04 instead of the ubuntu 20.04 on my desktop…

I will add that yesterday after another user reported more missing library dependencies (not in the exclusion list), I made a manual build in a docker container running the build image. When it was done, I ran something like ldd *.so* | grep 'not found' against all the bundled libraries and plugins to look for additional missing dependencies. And it all looks good for the next version! Thank you all for your patience and help.