XCB plugin not loaded

I have some troubles with installing Shotcut and it is very similar to this one. However the provided solution does not work in my case.

Ubuntu 20.04.1 LTS (as returned by lsb_release -a but it is a fresh install of a XUbuntu distribution)
Shotcut 20.10.31 (with both snap and portable versions)

I have the following packages installed:

  • libxcb-xinerama0
  • libxkbcommon0
  • libxkbcommon-x11-0
  • libxkbcommon-x11-dev

And I still have the error: qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.

Any ideas?

Does a previous version work?

Yes 20.09.27 works (.txz downloaded from github)

And if it matters, 20.10.31 worked on XUbuntu 18.04 before I decide to switch to XUbuntu 20.04.

Please try some of the things suggested by searching the web for “could not load the qt platform plugin xcb in even though it was found” as this is a fairly common problem.

By setting export QT_DEBUG_PLUGINS=1 I got more verbose error messages and could find the missing packages:

  • libxcb-icccm4
  • libxcb-image0
  • libxcb-keysyms1
  • libxcb-render-util0

And it works now!

Thank you, I can add all of those packages to our 18.04 build image (I checked their availability on 18.04 and they all are), Then our bundler will automatically collect those for the next build.

Thank you!