Adding Fade in and fade out filters

When a photo has been split at play-head (so that different filters can be applied to the different sections), Fade out effects won’t work if fade in effects have been applied.
Steps to reproduce:

  1. Add an image or video to the timeline
  2. Add another video track
  3. Add another image or video to the new track
  4. Add a chroma-key filter to the image or video on the top track
  • Between each of the following steps, check to see if the fade-in and fade-outs work.
  • Try with fade to black and adjust opacity
  1. Add a fade in and fade out effect to the same image or video
  2. Split the track into three segments
  3. Apply more filters, on different segments. I put blur onto the first and last segment
  4. Create transitions between the segments (extend one into another)

Sometimes, removing then re-adding the fades, or changing the order of filters fixes the issue, but most of the time the fade outs won’t work.

As far as I know, there is no work around for this issue.

I went through your procedure with two video tracks. One on V1 and another on V2. The fade-outs work continuously. Tried it twice to make sure.

When I put an image on V2 (video is on V1) and apply the fade in and out to it, then spit the image and apply a filter to the first part the fade-out stops working. If I apply a filter to the second part of the image the fade-out stops working as well. Tried it with png and jpg.

Make sure when you are applying the fade in / out that you have the segment you wish to use the filter on on the track selected otherwise it won’t know where to put them, I.E you may have been trying to apply a filter to a blank space between segments.

I have made sure that I am following the procedure provided. The fade filters appear in the list of filters for the clip but do not actually appear in the video.

You cannot select a blank space between segments to apply a filter.:confused:

No but in saying that when I have been splitting video and adding fade ins and fade outs if I make the split move the split part to the right so there is a gap between them the two pieces then the red highlight around the segment disappears I.E no segment is selected and effectively you are in the yellow areas between segments, if at this point you try to apply a filter it will fail.
If you select a segment so it is highlighted red and apply a filter it will work.
Note - Never mentioned ‘selecting’ the space between segments as it’s not select able, what I am referring to is if you have no segment selected then you are trying to apply a filter to dead space.

I am having the same issue with the Fade Out Video filter. I commented on this before. I discovered this problem while placing cross-dissolves.

Apparently, it is not resolved yet. I am now running Shotcut 18.03.06 on Linux KDE Neon 5.12 with a Ryzen 3 and 16 gb ram. The Fade Out Video displays either no fade or using the Throbber it may display an incomplete fade. The only way I have found to fix this is to remove the Fade Out Video filter and select it again - until it works properly.

Note: you may not notice the problem if the slideshow is not being composited over a colored background track. -=Ken=-

I still can’t work out how to completely reproduce the bug.

I believe it might have something to do with the order of applying filters
The issue occurs about 50% of the time for me if I add fade ins and fade outs to the image that I split after I have split it and added a transition. 80% if its a video.
I am not entirely sure what I am doing to cause the bug.

Each time I repeated it, the video was always chroma-keyed.

Hopefully, somebody can do some more investigating to try to reproduce the bug.

Oh also, I found a workaround.
If you put the track where the fade out should start, then create a transition between the two then remove the section where you want the fade out to go, you can apply the fade-out to the transition and it will work as expected

I was able to show a reproducible error. I created a new project and added a light pink background on V1. I added a photo on V2 sized to show the pink background. I made the photo 3 seconds long to show the effect more clearly. I grabbed the Throbber to extend the fade duration and you can plainly see the error occur - every time. There may be other conditions where this will show up - but this one is consistent. Note that muting the pink background track V1 this anomaly is not revealed.

-=Ken=-

@kenj69, if you add a Rotate filter to the clip in V2, just a straight filter with no parameters changed, does the dissolve work again? This seems to be a workaround for several of my fadein/fadeout/cross-dissolve issues. (Still doesn’t seem to work when cross-dissolving clips with different opacities.)

Yes, adding the Rotate filter makes my Fade In Video work properly. I wonder why?

-=Ken=-

Some of the filters, especially those that affect colors, seem to be assuming that the clips in the track are not being composited, and affect the entire frame. (Try applying a Brightness filter to a portrait-oriented clip/image, it will affect the entire frame of that track as if the clip included black bars on either side.) This might be by design. Rotate scales the clip to 100%. I’m assuming that this overrides the dissolve filter’s automatic full-frame treatment of a clip. And I assume that using masks will help workaround other filters. (Hmm. More specifically… I was just browsing some of the filter code, not really understanding what it did, and recall that it seemed to care an awful lot about “width.” Maybe the dimensions of the clip get kind of lost, “width” automatically sets itself to the frame dimensions, and Rotate specifically sets them again.)

@HDSQ.mid

Confirmed just with fades.
Split 1 is fine (V2).

Split 2 should be like Split 1 (V2)

TestFade01.mlt (8.4 KB)
Windows 10
Shotcut 18.05.08

I tested this several times duplicating the exact steps that HDSQ posted, but other filters beyond the 2nd split didn’t work.

1 Like

I’m having the same problems adding fade-in and fade-out filters. I’ve been trying to add text to an image on a separate video track with fade in and fade out. The text filter works, but the fade in, fade out filters don’t. I’ve tried adding a rotate filter.

Open a new track
Open “other” , Color (don’t touch, it’s transparent by default)
Add to the track
Add text to this part
Add fade in and out. Then on the filter, checkbox “adjust opacity”
See if OK

The workaround I’ve been using is to use advanced keyframes of opacity to emulate fade-in/outs
It works quite well for me.

I’ve found a variation on this bug. Fade In/Fade Out and Opacity just appeared to randomly stop working part way along my timeline. I’ve had issues with these filters before and not worked out what is going on.

Today I finally stumbled over exactly where it goes wrong. I have some audio clips in A1. Where the audio clips are, the video opacity does NOT work. I even tested have a slide in V3 with a long fade in that crosses over the start of an audio clip in A1. The fade starts off a nice gentle fade in, and as soon as it hits the start of the clip in A1, the image goes to fully opaque.

I can drag the audio to other audio tracks and it doesn’t affect the video opacity at all. Why is A1 messing with video opacity filters? There are no filters on A1 by the way.

At least I know I can work around it now by moving all my audio clips to another track, but why?!?

Are these audio-only clips? Or do they have a video component even if it is cover art?

Possibly related to Black background with image overlay

Oh, yes that sounds very related. The audio clips I am using are m4a files. I tested with a different mp3 file and it doesn’t have the same problem. I also will note that V1 is entirely empty on my project (don’t ask me why - just the way it ended up being built).

I can also confirm that deleting A1 and hitting undo also fixes the issue.

1 Like