Odd Compositing Behavior (Resolved-no bug)

What am I missing? I am creating a slideshow with cross-dissolves between photos (SD NTSC). Since there are photographs of various sizes I wanted to avoid the black screen background when the photo doesn’t cover the entire screen area. So I generated a light-pink solid color background and placed it on V1. Then, I added my photos on v2. I created 30 frame cross-dissolves between the photos. Playing or scrubbing the Playhead the pink background appears behind the photos as expected except when the Playhead is in the cross-dissolve area. Then, the background is solid black. Can’t figure this out.


I think this is an undisclosed feature a.k.a. BUG.
Reproduced your slideshow and got the same results. The color clip works except in the dissolve section.


The work around until the bug’s fixed is to use an alternate dissolve method which works. Using fade in fade out for the dissolve.


Hey thanks, sauron, for looking into this. Meanwhile, I created a test project and found more bad news. I created again a light pink background on track V1. Although that part may be unnecessary. On track V2 I added my first six photos but I spread them out a little, with a slight gap between them so they would be isolated objects. Then, I added the Filters ‘Fade In Video’ and ‘Fade Out Video’ to each photo, ticking the box which says, “Adjust opacity…” Scrubbing the Playhead along the Timeline from Home the first photo with fade in/out worked fine but for the next five photos only the Fade In Video filter worked. The Fade Out Video reacted like it wasn’t even there!

I don’t remember Shotcut behaving like this in the past. Meanwhile, since I have a deadline I may just dispense with the nice background and cross-fades. The people are only really interrested in the old photos anyway. I was just trying to “gussy it up” with some fancies.

Edit: I removed the ‘Fade Out Video’ filter from photos 2 through 6 and instead grabbed the “Throbber” and set the fade in time variously from 1 to 8 seconds. Scrubbing the Playhead across these photos got some variable amount of “action” but it was inconsistent and none was what was wanted nor expected. Definitely broken - right now.


I tried to reproduce your issue but could not. Put a color clip on V1. Added six pics to V2 with some space between them. Added fade in and out with adjust opacity to the first 3 clips. Then used the filter’s copy paste function to add the fades to the remaining 3 clips. All the fades worked.

Used the throbbers to add fades of various length to 3 clips and all worked.

I’m using the Windows version. Maybe the Linux version is broken.

OK, thanks. I backtracked until I had just the first photo working correctly. I have to admit - the copy filters function is nice - I hadn’t used that yet. However, I ended up with exactly the same result, at least on Linux. The Fade Video Out is broken.


The only anomaly I found was that if an image is resized after the fades are applied sometimes the fade-out doesn’t function. The only way I’ve been able to fix it is by deleting the image then adding the image back and applying the fades.

This is using Windows.

Maybe this thread ought to be re-categorized as BUG so the developers might take a look.

What Linux distribution/version are you using?
What version of Shotcut?
Where did you get (download) Shotcut from?

Sorry, I had already posted the vitals on my previous and similar post.

KDE Neon 5.12 - based on Ubuntu LTS 16.04; Shotcut 18.01.02 downloaded from shotcut.org, AMD Ryzen 3 1200, 16 gb ram, Nvidia GT-710

I don’t think the fade-in fade-out issue is a Linux issue.

I downloaded the latest version of Shotcut for Linux. Have a copy of Fedora 24 running in VMware Player 14.
I installed Shotcut in Fedora. Tested fade-in fade-out with 3 clips on V2 and color on V1. It worked fine exactly like it worked with the Windows version of Shotcut.

Thanks for spending the time on this! I uploaded a screencast to Vimeo. Let’s see if this works…


As you should be able see the first three photos have the Fade In and Fade Out filters applied. However, on photos 2 and 3 the Fade Out is ignored.


No problem. It gave me a chance to revisit Linux. Been a long while since I used it.

I uploaded what I did with Linux Shotcut. All the fade in and outs work on all the photos.


Very odd.

You are so right! Fades work beautifully. So, to quote myself, "What am I missing?"
Very odd.

Well, I will scratch my head for awhile - and see if that helps. If I can’t get it to work I will have to finish with no background.

Thanks, again,


I also had trouble with Shotcut constantly crashing when I adjusted the Fade Out Throbber. Because I was under a deadline I did the project in Kdenlive. However, I prefer using Shotcut whenever I can - and I wanted to find out why Shotcut was having problems on my new system.

So, I played with the Shotcut test project again with both png and jpg photos. This time, two days later, Shotcut performed flawlessly! The only thing I can attribute that to is KDE Neon is constantly being updated. I usually have a small amount of updates every day and sometimes I’ve had ~175 or so! Being a cutting edge distro maybe somebody released a glitchy module - who knows.

Anyway, it appears that Shotcut is just fine - no bug. I also found that the photo crossfades with a colored background work perfectly when the ‘Alpha Channel:Adjust’ filter is applied.


That’s a very good find. Maybe there ought to be a thread on this forum devoted to user discoveries.

Because of this thread and my using the Linux version of Shotcut my interest in Linux has been renewed. I use KDE plasma on Fedora 24 which last night got updated to Fedora 26.