Youtube is not converting to 4K?

My video is in 4K

and when it is searched in youtube it clearly says it is 4K


However, when video is being played there is no 4K option


I know sometimes it takes time but 24 hours have already passed.

Does any body have any clue ?

I don’t think to discuss this here, it is something YouTube related. Which could be solved by the YouTube community only.

The only thing we could say is to create a bug report to YouTube, re-export and re-publish that video, or just re-publish that same video again.
Very less people would be able to solve it on the forum here.

If you want to create a seperation line, then it is ___ (3 continous underscores).

OK thanks I will note that. As most people here are in video thing I thought I could get some idea. I will try to find youtube community .

It will take time. See here: Low video quality after upload - YouTube Help and here: 🚩4K video uploads and processing time - YouTube Community

1 Like

Yes, many (all) here are in video things. But it means we can tell about video related problems, but not uploading on internet.
Many here are good in those nitty-gritty stuff, so they might even tell you how to even make a custom filter. But I don’t think most know what could be the exact problem while uploading. As to what I know, only elusien is related in web stuff, he would help.

You are Just 10 secs faster man, I was only mentioning you.

Such a coincidence.

I did contact youtube but no answer and 2 days already passed just wonder if by any chance it has some thing to do with my shortcut setting perhaps I did some thing wrong when I exported from shotcut?

I made a test video with just the default preset (changed nothing for export).
4k, 60fps.

The option for 4k quality is there for me.

If you go to your youtube studio ( ) and go into the video detail page do you see a 4K bubble blinking next to SD and HD? It might give you a reason or just “waiting to process” when mouse hovering on it.


thank you for taking time to upload and test

can I know your export settings please so I can compare it with mine?

I did try to contact a person, which I know because of the community, he said that the either the video uploaded is itself HD only, or there is a unknown bug that could be happening because of some wrong export setting.

Can you share all the settings in which the video is exported, and the properties of the video. A screenshot of them would mostly help to discover the problem. Maybe A wrong codec, or some fake resolution.

This is the settings

I also used libx264 but same result

However, I did one thing: There is a open-source software called mp3tag I opened it and made changes to the video data

1 Like

Did you simply tried to use the normal 4k mp4 preset?

Maybe that does something, because to me the export setting look correct.

The normal 4k mp4 preset? I am trying to find that setting in shortcut . Is that under youtube export section?

I just used the default export settings. Basically I didn’t choose a export preset, and did not go into advanced to change anything.

The “default” preset is libx264 with a GOP that is the frame rate times five. Hitting the Reset button in the Export panel will take you back to the default export preset. The default is good enough in lots of cases.

One thing that looks a little non-standard is the frame rate. Try setting that to 29.970030 instead of whatever number is there, which was probably carried over from a variable frame rate cell phone file. However, I wouldn’t expect that to throw off YouTube.

This does not exist for export presets. If you are referring to Video Mode presets, it wouldn’t work either, because his source video fps is different than a 4k Video Mode preset in Shotcut.

1 Like

thanks the reason I used 30 and not shortcut default 29 was because I thought I need to match every thing with the source. This is my iPhone settings

He can simply change the fps and res if required. I don’t usually use 4k, but when I do, I simply change it what I want if I don’t find a correct preset.