Xdcam exports not playing

Videos exported with XDCAM-HD422 using default settings not playing in Pot Player or Windows Media Player.

Am able to play other .mxf videos generated by ffmpeg.

It is working for me except Windows Media Player where it is not normally expected to work.

Also works for me in VLC and Shotcut

Windows Media Player plays .mxf files created with ffmpeg and another NLE program just fine.

Not unless you have installed additional components to enable that.

Only the k-lite codec pack.

Videos exported with XDCAM-HD422 play only if “interlaced” is selected, either TFF or BFF.

It’s only progressive videos that don’t play.

Progressive works for me as well in Shotcut, PotPlayer, and VLC. I am not going to install K-Lite.

The only mxf files that don’t play for me are those exported by Shotcut. All others play fine.

Never install a Codec-Pack on WIN! It could corrupt other codecs and the registration in your system!

I uninstalled the codec pack, rebooted, and progressive mxf videos exported by Shotcut still do not play.

Not sure which version of SC you are using Chris, but I can tell you that XDCAM
progressive from SC does work.
Remember that XDCAM does not support (at least officially) 1080p at 50 or 60fps.
It will only do 1080p at 24, 25 or 30fps.

Only 720p supports 50 and 60fps.

Did you perhaps force ffmpeg to make 1080p 50/60fps and some players will not support it
as per the official spec?

Below, the options for XDCAM (50Mb/s variants):

Screen Shot 2020-05-25 at 9.53.54 AM

Do you mean 1080i at 30 fps? That would be 60 fields per second, 30 frames.

This is using all default settings in Shotcut. No modification by me. The SC default is 720 progressive, 59.94 fps.

No, I mean 1080p at 30fps.
For interlaced, it would be 60 fields, i.e. 30 (frames) fps and 2 fields.

Use SC properties or Mediainfo and report on the fourcc of the clip that does not work.

That’s what I said.

Using all default settings in Shotcut. Version 20.04.12. Shotcut’s video settings are:

1280 x 720
16 x 9
59.94 fps

MediaInfo reports the same parameters for the input and output clips. Same with SC’s “Info”.

1080p 30fps is part of the ATSC standard but in the U.S. nobody uses it. In U.S. broadcast 1080 is universally interlaced.

Shotcut’s export “Other” setting has vtag=xd5c which is 1080i50 according to your chart, so the vtag is not correct for 720p 59.94. It should be xd59 for 720p 60. Still, it doesn’t play when corrected to xd59. Setting Video to 1920 x 1080 interlaced @ 29.97 fps sets the vtag to xd59, also incorrect. Your chart does not have 1080i 30 frames.

2 interlaced fields at 59.94 gives 29.97 frames.

The input clip in my tests plays OK.

The chart is from the XDCAM specs, it’s always worked for me.
Are you able to try SC on another machine, or possibly another version of SC on the same machine
and see if that sorts the problem out ?
It may give a clue as to where the problem may be.

Dan did upgrade the ffmpeg version included with SC, just can’t remember when.

These are not Shotcut’s default settings. The default Video Mode is Automatic, which makes it adaptive. What you see when you start Shotcut after the very first launch are not defaults; they are your saved settings.

I choose as a matter of priority not to add code to set the vtag properly per the video attributes. I do not care about this preset, and neither do 99.9% of the users. Often times a preset is used as a starting point to tweak and possibly build a custom preset. I can leave this preset in for the people who are able to use or simply remove it.

Might as well leave it in. My suggestion is to make the default 720 progressive @ 59.94 and the vtag xd59 as 1080p 25 is not a common distribution format.

The alternative is to export to a lossless format such as utvideo and take care of the rest with an external ffmpeg script.

Here is a list of common distribution formats:

The majority of our users are not in broadcast and many are in Europe and elsewhere that 25 fps is typical. I could be willing to change it to 1080p 29.97, however. But not yet 50p or 60p (higher than most people use nowadays) and not 1280x720 (lower than what most people use nowadays). I have not received many complaints about 25, and it is not difficult to set a Video Mode that makes sense for your needs.

Leave it at 1080p 25 fps, but you need to change the vtag to xd5e.

OK, I made the change to vtag for the next version and added a short note in the preset’s tooltip to set vtag as needed.