Xdcam exports not playing

After uninstalling the K-Lite codec pack, Shotcut XDCAM files now play correctly and my machine now handles video levels correctly.

Sorry for the false alarm.

Thanks for correcting the vtag.

You now see better. :smiley:

Hello, hrm, why is K-lite or other codec packs dangerous? Because of bundling of other software/settings? The codecs themselves should be ok, I would guess.

Nowadays I do not need as many codecs as with XP, then it was necessary with many codecs, to play anything but AVI.

If I want Windows media player to play some unusual format (was it MP4 that did not play…), where do I then find a “safe” codec…?

It would be useful/interesting to get more information about 1). where to find correct codecs, 2). why not to use codec packs.

If you feel like it, feel free to start a new topic! Or maybe I will start it.

Best Regards from Jan L

Exactly, one never knows what other “surprises” are bundled together.

Over and above this, not all codecs are created equally, for example MP3 or AAC, some implementations are better than others.
A codec (coder/decoder) is not a magical thing that will encode or decode
some format perfectly.
These have to be created, the interpretation of the specs by the people/person
creating codecs is often wrong.
The result is video that looks bad, wrong colours, etc or/and audio that sounds like crap.

Then of course there is the matter of settings, registry etc.
How much does K-lite and others modify these? Who knows.

Of course it’s your machine and you have the right to decide if you want to try it out or not.
Let us know how it works out for you.

Why windows media player?
There are many far superior players out there that will play a majority of formats “out of the box” negating the need for you to hunt around for dodgy codec packs.

1 Like

The K-Lite codec pack was altering my video levels. It seems it was reversing “full range” and “limited range”. After I uninstalled it I had to change all instances of “full range” to “limited range” and vice versa in my code to get video levels back to where they should be.

Video levels are critical to the work I do so I can’t have this. This is not the first time a graphics library or codec has screwed me by not playing by the rules. In addition, K-Lite appears to have been the culprit in my XDCAM Shotcut exports not playing.

I had to stop using VLC because it was forcing luminance levels of 235 to 255 and there was no way to defeat this behavior. Needless to say I can’t have software that’s pulling shenanigans behind my back.

Clearly the programmers who write these are not interested in accuracy and don’t bother to test for it. I had to create a couple of test signals so I could test for proper color and gray-scale rendition.

I now use ffplay to test video levels using this code:

ffplay -i clipped.mxf -t 10  -vf scale=in_color_matrix=bt709:in_range=limited

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.