WideScreen lossless convert

Hi all,

A mkv video with 976x720p frame rate: 23.976 does not appear full screen on smart TV…

How can I edit this in full screen losslessly?


Most, if not all, modern TVs upscale. They often have a menu to state what to do for common formats (e.g. widescreen). 976x720p is not a common format, If your TV screen is 1920x1080 what it will probably do is make it full height (1080) with a width of 1464, so you will get black bands on either side of the screen.

What are you expecting to do? To fill the screen you can either stretch the video sideways, so everything is out of shape, or you can magnify it so it fits width-wise but cuts quite a bit of the video off the top and bottom of the video. Those are your two options.

Yes, there are gaps on both sides. TV Full HD.

I’m looking for a way to make it Fullscreen. For example, another satellite device has this feature. makes the video full screen. But the TV’s system does not make it full screen.


Set the project resolution to 1920x1080 (or 1280x 720). Open your video in Shotcut.

Then there are several options e.g.

  • Use the “Crop: Source” filter, changing the “Top” and/or “Bottom” parameters.
  • Apply a Size, Position & Rotate filter to it, Zoom-in until the black sidebars disappear.

then export. Both of these will chop the top and bottom of the video.

1 Like

You are essentially converting a Portrait video to Landscape. See here for more information:


Thank you, I will try.


I’ve tried. Not that way… it shouldn’t be missing from the sides or top to bottom.

I will try to find another method.

Thank you very much.

As I said. To make it fill the screen you either have to stretch it sideways, which will distort the picture, or lose part of the image from top and.or bottom. There is no other option. The image is not in 16:9 aspect ratio. You cannot make it be 16:9 without doing one of these two things.

1 Like

Try also the Blur: Pad video filter.

1 Like

Does the export look squished? If so, we may be dealing with non-square pixels.

I do not know. I tried it with another program other than Shotcut. When I changed one of the personal settings from the TV to 4:3, 16/9, the video started to show again in the same small format… I couldn’t quite figure it out.

This is how I solved the issue :slight_smile:

ffmpeg -i input.mkv -aspect 16:9 output.mkv

Then, you could have done it in Shotcut by changing Properties > Video > Aspect ratio but
no one completely understood your original question as it was too vague.

1 Like

To understand you correctly:

You are wanting to go from this:

To this:

Is this the result you got with your ffmpeg command line?

For me, the conversion appears to be distorted/squished.


So there is some defect. but acceptable.


The problem was to make the video full screen, just like I wrote. For now the issue is resolved.

Yes, I could do it with shotcut. But I prefer to edit videos with more features with Shotcut.

it was just a one-point shot.

This topic was automatically closed after 90 days. New replies are no longer allowed.