White video when exporting a video made of images

Using last linux Mint Cinnamon edition, 64 bits, with or without hardware encoder, in shotcut-linux-x86_64-211031.txz. It was working ok until now. I’ve tried deleting shotcut config files, shotcut itselft…
I think I’ve read something similar in the forum but I’m unable to find it…

Xeon 2678v3 (12c/24t) to 3.3Ghz 32 GB DDR4, nvme, GTX 960.

The last test: new project, just drop a 1920x1080 jpg in timeline. Export. Result: 4 seconds white video.

One strange thing is that sometimes, when I start a new project, the video part of the window goes white too, and thumnails in playlist are white too when I drop some jpg files. Just today, but I can’t get rid off this thing.

EDIT: It happens with jpg images. It seems working for png.
EDIT2: yes, a lonely png exports ok. A slide show of 10 png exports ok. A slideshow of 30+ png fails with exit code 11, and it takes a forever to begin to export (it is using 1 core only to “prepare” or begin. Stops always in the same point.

Preview is ok always.

Trying with default settings, changing codecs, video mode…what could it be?

Try using the app image, to make sure that you disto is not the problem

I have no problems with .jpg on Fedora Linux 35, using flatpak or appimage

This is basically the same as the AppImage as long as you run Shotcut.app/shotcut and NOT Shotcut.app/bin/shotcut! What you you running?
@sentinel166 reported this problem as well, but I could not reproduce it. I will test it using the additional information in your “EDIT” updates.

I successfully tested 2 projects with the 21.10.31 AppImage - both using a 1080p25 video mode, the slideshow generator, exported with parallel and hardware encoder, and high resolution images (>1080p): 30 JPEGs and 42 PNGs. Each export plays fine with no weird behavior like slowness or high memory usage.

Using appimage makes no diference. A video generated by droping one JPG in the timeline is just white. Ah, if IMAGE does not fit, then is white with vertical black bands (as it should be).

Hello. I’m runing the desktop entry file besides the Shotcut.app folder. And AppImage has the same “white JPG” thing.

I understand that the tar and the AppImage are basically the same?

This is the log of a “success” white video export:

mlt_repository_init: failed to dlopen /tmp/.mount_shotcu5Rurwb/usr/bin/lib/mlt-7/libmltmovit.so
(libOpenGL.so.0: cannot open shared object file: No such file or directory)
mlt_repository_init: failed to dlopen /tmp/.mount_shotcu5Rurwb/usr/bin/lib/mlt-7/libmltsox.so
(libsox.so.3: cannot open shared object file: No such file or directory)
[AVIOContext @ 0x556bbf075900] Statistics: 620072 bytes read, 0 seeks
[AVIOContext @ 0x556bbf033240] Statistics: 620072 bytes read, 0 seeks
[h264_nvenc @ 0x7f4e4401e800] Loaded Nvenc version 11.1
[h264_nvenc @ 0x7f4e4401e800] Nvenc initialized successfully
[h264_nvenc @ 0x7f4e4401e800] 1 CUDA capable devices found
[h264_nvenc @ 0x7f4e4401e800] [ GPU #0 - < NVIDIA GeForce GTX 960 > has Compute SM 5.2 ]
[h264_nvenc @ 0x7f4e4401e800] supports NVENC
[h264_nvenc @ 0x7f4e4401e800] Using global_quality with nvenc is deprecated. Use qp instead.
[AVIOContext @ 0x7f4e18011380] Statistics: 620072 bytes read, 0 seeks
[producer avformat] /home/shared/video-kinu/RECURSOS COMUNES/PARA PRESENTACIÓN CANAL (copia)/computer-bolts-1-1529259.jpg
checking VFR: pkt.duration 1
[swscaler @ 0x7f4e44987580] YUV color matrix differs for YUV->YUV, using intermediate RGB to convert
[swscaler @ 0x7f4e44a0f240] YUV color matrix differs for YUV->YUV, using intermediate RGB to convert 

.....lot of these lines and then

[mp4 @ 0x7f4e44000f80] Timestamps are unset in a packet for stream 1. This is deprecated and will stop working in the future. Fix your code to set the timestamps properly
[mp4 @ 0x7f4e44000f80] Encoder did not produce proper pts, making some up.
[mp4 @ 0x7f4e44000f80] Application provided invalid, non monotonically increasing dts to muxer in stream 1: 191488 >= 191488
[mp4 @ 0x7f4e44000f80] Starting second pass: moving the moov atom to the beginning of the file
[AVIOContext @ 0x7f4e44a1f640] Statistics: 1290836 bytes read, 0 seeks
[h264_nvenc @ 0x7f4e4401e800] Nvenc unloaded
[aac @ 0x7f4e440c50c0] Qavg: 65536.000
[AVIOContext @ 0x7f4e4497bc80] Statistics: 4 seeks, 13 writeouts
[AVIOContext @ 0x7f4e18016500] Statistics: 620072 bytes read, 0 seeks
Completed successfully in 00:00:04

I’ve detected that slideshow tool has an strange behavior when you use lot of PNG images (85 and 93 in my case). It omits transitions. Maybe is there some problem with the library used for PNG?

Indeed: Now I can do nothing with shotcut.

I posted a project with a few files (purging the playlist this time). It might take a while to upload though.
Only the mov file is shown, nothing else. Tomorrow I’ll try on another computer. Same linux distribution though, only the desktop changed.

the .mov file and new.jpg is missing from the upload so I can’t load it.

Yeah… I said it would take a while, I didn’t lie. But in fact my internet had issues, now it’s been instantaneous.

I have no problems with rendering this video, the rendering look just like it does in Shotcut

I am running Fedora Linux 35 (Gnome/Wayland) and use the flatpak version of shortcut 22.01.30

It looks like the OP is using Hardware Encoding (h264_nvenc), which could well be the cause of the problem. Do you have an Nvidia card and if so perhaps you’d like to try that?

Or the OP coud try switching Hardware Encoding off and try that.

I don’t use HW encoding, so my test is with software rendering

I guessed as much. Probably 90% of these types of errors (Audio and White screen, Audio and Black screen etc… go away when you stop rendering with Hardware Encoding and use libx264 instead.

1 Like

Mind you that was from the logfile that was posted. The original post did say:

So maybe this isn’t his problem after all.

I quit using jpgs. Recoding all them to png before use them in Shotcut. I really like to know why the white video is happening. Say I make a slideshow with pngs and jpg. It exports ok until it reachs the first jpg, then white video until the end. :open_mouth:

Do the pngs following that first jpg render well ?
I have no hardware acceleration here. It says there are none.
I’ll tryon the other computer. if no good either, I’ll conclude it’s Archlinux/endeavous. which would pain me A LOT.

No. After jpg all video is white.

And it isn’t an Archlinux thing. Linux Mint Cinnamon here.

then our beloved programmer has a big task on his desk…
If someone needs a core dump or whatever (I have no idea what I’m talking about), just give me the command to run :slight_smile:

I do not know what is wrong and still unable to reproduce it. I made another test with the AppImage on Ubuntu 20.04 using a mixture of 80 JPEG and PNG.

I suppose it is possible there is something wrong with loading some incompatible png and jpeg libraries from the system instead of the bundled ones, but the only way I see how is by running Shotcut.app/bin/shotcut directly from the portable instead of one of the launchers. You can try with the flatpak if you want even more isolation between the app and the OS.

ddennedy@Gamerbox-9400:~/Desktop/Shotcut/Shotcut.app$ source source-me
ddennedy@Gamerbox-9400:~/Desktop/Shotcut/Shotcut.app$ ldd lib/libQt5* | grep png
	libpng16.so.16 => /home/ddennedy/Desktop/Shotcut/Shotcut.app/lib/libpng16.so.16 (0x00007fa2afb99000)
	libpng16.so.16 => /home/ddennedy/Desktop/Shotcut/Shotcut.app/lib/libpng16.so.16 (0x00007f384756a000)
	libpng16.so.16 => /home/ddennedy/Desktop/Shotcut/Shotcut.app/lib/libpng16.so.16 (0x00007fd87a326000)
	libpng16.so.16 => /home/ddennedy/Desktop/Shotcut/Shotcut.app/lib/libpng16.so.16 (0x00007fc9e2441000)
	libpng16.so.16 => /home/ddennedy/Desktop/Shotcut/Shotcut.app/lib/libpng16.so.16 (0x00007f2120a14000)
	libpng16.so.16 => /home/ddennedy/Desktop/Shotcut/Shotcut.app/lib/libpng16.so.16 (0x00007f52c9ddf000)
	libpng16.so.16 => /home/ddennedy/Desktop/Shotcut/Shotcut.app/lib/libpng16.so.16 (0x00007f5bc28ee000)
	libpng16.so.16 => /home/ddennedy/Desktop/Shotcut/Shotcut.app/lib/libpng16.so.16 (0x00007f4f7a866000)
	libpng16.so.16 => /home/ddennedy/Desktop/Shotcut/Shotcut.app/lib/libpng16.so.16 (0x00007f202a63c000)
	libpng16.so.16 => /home/ddennedy/Desktop/Shotcut/Shotcut.app/lib/libpng16.so.16 (0x00007fc249168000)
	libpng16.so.16 => /home/ddennedy/Desktop/Shotcut/Shotcut.app/lib/libpng16.so.16 (0x00007f79babe7000)
ddennedy@Gamerbox-9400:~/Desktop/Shotcut/Shotcut.app$ ldd lib/qt5/imageformats/* | grep jpeg
	libjpeg.so.8 => /home/ddennedy/Desktop/Shotcut/Shotcut.app/lib/libjpeg.so.8 (0x00007fc17c497000)

Next, I installed Linux Mint 20.2 Cinnamon in a virtual machine, loaded the same images, and exported with no problem.

I went on a third computer, with still the same Endeavouros (but xfce4) and it worked.
This bug is only remotely due to shotcut, and is hard to replicate… At least i know where to do the exporting now.

This topic was automatically closed after 90 days. New replies are no longer allowed.