Where is that Declick audio filter?

So I was looking at some of the changelog and found something that I might be able to use to help with some audio issues. Declick. Declick Audio Filter However, for whatever reason I can’t seem to find it in the filter list? That forum post shows that it should be under the “Time Categories” but … I don’t see that in my list of filters. Am I being dense and just not seeing it? Using Version 24.02.29

Hi @SimPaulJack


To see the Time category, you need to have an Audio clip, or a Video clip selected.

1 Like

Make sure you’re selecting a single clip, not the entire Track or Output - I had the same question myself just yesterday wanting to use it on the entire track.

1 Like

TLDR: Time category isn’t available on OPUS or video tracks that are sped up (at least) but is available on MP3 and maybe others I’ve not tested. read below where I show my work :slight_smile:

Then maybe that’s the problem. I don’t even have a “time” set there:
Just “Favorite”, “Video”, “Audio”, and “Sets”

Is there a setting I need to check somewhere? I have recently completely reinstalled Shotcut and wiped out the registry and appdata folder just in case.

I have to be missing something obvious here. I selected a just recorded track on the TimeLine and even a video track but it never pops up.

… oh wait … that’s odd…

So not sure what is going on here BUT I use a custom layout for my two screens and the filter window is on the 2nd screen. So to test I switched to the default “Editing” layout and then BAM the “Time” category is there now. Then switch back to my custom layout and it’s there too!

… Oh wait again … SO apparently the TIME category isn’t available on OPUS or video tracks that are not 1x speed BUT it does show on the MP3 I just dropped in or my video track (MP4) that isn’t sped up:

So good to know. So only tracks and not OPUS files.

FYI a little testing I’ve done it seems like OGG is the best format for this if you’re extracting it from a video and want to keep it synced. Not sure if it’s just me but whenever I tried to extract to an MP3 it always lost a few seconds and got a little de-synced (used ffmpeg). OGG doesn’t suffer from this and you can “declick” it too

This topic was automatically closed after 90 days. New replies are no longer allowed.