When putting videos into playlist, video is washed out. Lost of picture quality

Before my videos were coming out great. But sometime in November 2020, whenever I tried putting a video in the playlist. The videos are washed out. Like greyish, lost of color, and brightness. For example, when I record a video from my Playstation or Xbox and play it from my PC/laptop, it will play just fine. Great picture quality. When I import the video into Shotcut’s Playlist, the video becomes washed out, hopefully I’m saying that right. The video is dark, lost of color, and lost of contrast. I have to literally go into filters and put up the brightness, contrast, and Hue to make it look somewhat back to normal.

Please help, what is happening or what did I not update in my settings. I had updated my version to the latest and it is still doing the same.

What is your operating system?

Win 10

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
20.11.28

Can you repeat the problem? If so, what are the steps?
(Please be specific and use the names as seen in Shotcut, preferably English. Include a screenshot or screen recording if you can. Also, you can attach logs from either View > Application Log or right-click a job and choose View Log.)

Log.txt (858.9 KB)

1 Like

Hi @Learningshotcut666
Can you show us a screen capture of your entire Shotcut window with of course the video displayed in the viewer ?
And possibly a screen capture of the same video opened in a media player ?

I have attached several screen shots. Two screen shots of a video recorded just last night. Ready to go but it has been any video I put in. I used media player to play the video and took two different screen shots. Then put the video in Shotcut’s playlist to edit. You can see right away how the picture quality changes in Shotcut. Greyish in color and faded out. I then exported the video and played it the same media player and can see it saved/exported it the same way how it looked on Shotcut.

Any help would be appreciated.

Thank you! Screen Shot.pdf (919.6 KB)

That’s strange…
Sorry, I forgot to ask what Video Mode you were using in these Shotcut screen captures ? (Settings -> Video Mode)

I had tried to set it to default “Automatic,” “HD 1080p 60 fps,” or “UHD 2060P 60 fps.” I had tried different modes thinking this could be the issue but no change. I had upgraded to this latest version, uninstalled it and put it back to 20.7.11 which had the same issue but it worked fine before. Uninstalled and put it back to the latest version and hasn’t been working properly since.

I’ve been a member of this forum for almost 2 years and I can’t remember reading about a similar problem. But don’t worry, I’m sure someone will come up with a solution pretty soon. There are few big brains in this community :slightly_smiling_face:

Your video is probably HDR. You can send the output of Properties > menu > More Information… to confirm. Shotcut does not yet support HDR, but the next version has a feature to convert this to SDR so it looks correct.

Thank you guys for assisting. It had worked before and I really didn’t do anything change any settings on the consoles or tv. But I’m sorry, how can I verify if the video is here from properties output. What am I looking for because I didn’t find anything referencing hdr from properties (right clicking from video itself) or from properties from shotcut after selecting the video and clicking properties.

In Shotcut, Properties > menu > More Information…

Logs for Shotcut.txt (2.5 KB)

I apologize for the delay. I have saved the information listed under “more information” from the properties menu.

From the log: color_transfer=smpte2084
This indicates that the video is encoded as HDR. Shotcut does not support editing HDR.

The latest beta build has a feature to allow you to convert the HDR file to 709 so that it can be edited in Shotcut.